yavdr ansible

  • Hi


    I think I have the same problem as razorblade has in post #18 (50 Hz problem) to try to get 50 Hz refresh rate with my Intel NUC7i5BNK with Intel Iris Plus Graphics 640 display card.

    Code
    1. Nov 12 09:34:12 vdrsrv02 vdr: video: decoder buffer empty, duping frame (23524/10932) 0 v-buf
    2. Nov 12 09:34:12 vdrsrv02 vdr: video: 4:21:43.347+1646 831 0/\ms 0+1 v-buf
    3. Nov 12 09:34:12 vdrsrv02 vdr: video: slow down video, duping frame
    4. Nov 12 09:34:12 vdrsrv02 vdr: video: decoder buffer empty, duping frame (23526/10932) 0 v-buf
    5. Nov 12 09:34:12 vdrsrv02 vdr: video: 4:21:43.347+1626 811 0/\ms 0+1 v-buf
    6. Nov 12 09:34:12 vdrsrv02 vdr: video: slow down video, duping frame
    7. Nov 12 09:34:12 vdrsrv02 vdr: video: decoder buffer empty, duping frame (23528/10932) 4 v-buf
    8. Nov 12 09:34:12 vdrsrv02 vdr: video: 4:21:43.347+1607 792 0/\ms 4+1 v-buf
    9. Nov 12 09:34:12 vdrsrv02 vdr: video: slow down video, duping frame

    I have only tried to run this command, but it is not helping. Any advice?

    Code
    1. sudo -H ansible-playbook yavdr07.yml -c local -i localhost, --tags="yavdr-xorg"

    Thanks

    Harald

  • The playbook does not yet handle the automatic display configuration for Intel IGPs, so you need to configure Xorg yourself if you want to use a mode with 50Hz refresh rate.


    fnu has described a way to enforce a display resolution and refresh rate which works even if the display is not connected or powered during startup, so a reliable operation is guaranteed: Zusammenfassung Intel VAAPI & edid.bin


    For this method I still need to find a reliable method to associate the xrandr connector name (e.g. HDMI-0) to the name required for the grub boot parameter (like HDMI-A-0) in order to automate these steps (and the method mentioned above has the drawback that only one display is supported).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hmm, das bringt auch nichts. Nach ein paar Minuten "Displayinaktivität" gehen beide Displays wieder aus und der Ton ist weg.

    Ich hatte xset s off -dpms in /var/lib/vdr/.config/openbox/autostart eingebaut.

    Hast du mal das Debug-Logging von KODI aktiviert und geschaut, ob das ungewollt noch irgendetwas macht?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Habe das LOG Level mal auf 2 gesetzt, aber im kodi.log wird nichts bzg. des Abschaltens geschrieben.

    Das syslog ist dazu schweigsam und im Xorg.0.log steht auch nichts.


    Cheers,

    Ole

  • Moin zusammen, habe hier das Problem, dass Kodi 18 im yaVDR ansible nach einiger Zeit der Wiedergabe (Audio) die Bildschirme abschaltet und den Ton stumm. Ist das jemandem bekannt bzw. kann ich das irgendwie unterbinden?

    Drücke ich dann eine Taste an der FB oder auf der Tastatur, geht es weiter. Vmtl. Der Displaymanager?


    Cheers,

    Ole

    Hatte das gleiche Thema,

    Habe in "/var/lib/vdr/.config/openbox/autostart" folgende Zeilen angefügt, seitdem ist es nicht mehr aufgetreten:

    Code
    1. export DISPLAY=:0.0
    2. xset s off -dpms
  • Die Variante in der autostart habe ich auch schon ausprobiert, hat aber leider nicht geholfen.

    Auch mit zusätzlichem export DISPLAY bin ich nicht zum Erfolg gekommen.


    Cheers,

    Ole

  • Frage zu den Einstellungen für pulsaudio:

    Seit dieser Woche habe ich einen neuen AV-Receiver zu Hause, der jetzt das Bild + Ton über HDMI empfängt und das Bild dann an den TV weitergibt.

    Bisher hatte ich den HDMI-Ausgang der NVidia-GT1030 direkt mit dem TV verbunden und den Ton per SPDIF vom Mainboard geholt und im alten AV-Receiver verarbeitet.


    Bei meinem Produktiv-VDR mit yavdr-0.6 habe ich jetzt über das WebIF den Ton auf HDMI umgestellt, dabei wurde eine neue /etc/asound.conf erstellt:

    Code
    1. pcm.!default {
    2. type hw
    3. card NVidia
    4. device 7
    5. }
    6. ctl.!default {
    7. type hw
    8. card NVidia
    9. }


    Und danach musste ich noch die softhddevice.conf anpassen, die nun so aussieht:

    Code
    1. [softhddevice]
    2. -D
    3. # SPDIF vom Mainboard
    4. #-a iec958:AES0=0x4,CARD=PCH,DEV=0
    5. #-p iec958:AES0=0x6,CARD=PCH,DEV=0
    6. # HDMI von NVidia GT1030
    7. -a hw:NVidia,7
    8. -p hw:NVidia,7

    Damit funktioniert alles perfekt. :thumbup:

    Der VDR gibt Stereo, DolbyDigital usw. aus!

    Über das installierte KODI-17.6 kann ich nun auch zusätzlich noch die HiRes-Audioformate wie DD-TrueHD und DTS-MasterHD wiedergeben!

    Das ganze läuft beim yavdr-0.6 über ALSA.



    Auf der 2. Partition im gleichen PC habe ich yavdr-ansible installiert, was momentan Pulsaudio verwendet, wenn ich das richtig verstanden habe.

    Aber damit komme ich irgendwie nicht zurecht und am liebsten würde ich auch hier zu ALSA zurückwechseln, aber ich will mal Pulsaudio noch eine Chance geben.

    Meine softhdcuvid.conf sieht momentan sehr übersichtlich aus, denn sie enthält nur den Parameter -D und mehr nicht.


    Wenn ich hier ebenfalls die Parameter von yavdr-0.6 übernehme -p hw:NVidia,7, kriege ich gar keinen Sound mehr!

    Ohne diese Parameter hab ich einen Stereo-Ton, aber nur wenn ich im Pulscontrol output:hdmi-stereo auswähle.

    Was müsste ich denn hier einstellen, um Passthrough zu bekommen?

    Meist muss man für passthrough unter pulseaudio das Profil hdmi-stereo-extra auswählen. Ja, stereo. Nicht das surround-Profil wählen. Und passthrough in softhddevice aktivieren.

    Ein Profil hdmi-stereo-extra gibt es bei mir nicht, dafür aber hdmi-stereo-extra1, vermutlich weil bei meiner Karte MSI-GT1030 der Displayport der Port0 ist und der HDMI-Ausgang ist Port1.

    Wenn ich dieses Profil auswähle, dann habe ich gar keinen Ton mehr und bei GP108 High-Definition-Audio Controller steht dann auch "unplugged", ansonsten steht da "plugged in"


    Jetzt bin ich mit meinem Latein am Ende.

    Was muss ich denn nun einstellen um wie bei der Verwendung von ALSA alle Tonformate inkl. der Highres-Audioformate zu bekommen?


    Paul

    PS: Wie groß wäre denn der Aufwand, um von Pulsaudio zu ALSA zu wechseln, denn da funktioniert ja alles perfekt!

    Gibt es da ein kleines HowTo? :/

    The post was edited 1 time, last by Paulaner ().

  • gibt es eine Möglichkeit, z.B den anthra-1920-OSt Skin, auch unter yavdr ansible weiter zu nutzen?

    Ich habe das Paket gerade nach ppa:yavdr/experimental-main hochgeladen, probier mal, ob das so passt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Moin,

    Ich habe das Paket gerade nach ppa:yavdr/experimental-main hochgeladen, probier mal, ob das so passt.

    super. vielen Dank schon mal

    bekomme hier beim Start leider einen Parse error -> Unexpected tag display within document

  • Wie es aussieht verunstaltet er das Theme beim Ausführen von make beim Paketbau, das liegt an der Zeile

    Code
    1. @for FILES in $(wildcard xml/*.xml); do cat "$${FILES}" >> $(SKIN).skin; done

    im Makefile, wobei die Anordnung der von der Funktion zurückgegebenen Dateien nicht wie erwartet ist:

    Code
    1. $ make -n
    2. for FILES in xml/03_menu.xml xml/04_replayInfo.xml xml/06_volume.xml xml/09_close.xml xml/01_header.xml xml/02_channelInfo.xml xml/07_audioTracks.xml xml/08_message.xml xml/05_replaySmall.xml; do cat "${FILES}" >> anthra_1920_OSt.skin; done

    Laut https://git.savannah.gnu.org/cgit/make.git/tree/NEWS#n316 war das noch nie garantiert, dass die Wildcard-Funktion die Treffer sortiert ausgibt (aber sie hat es mindestens bis Make 3.28 gemacht) und wie es aussieht, ist das Verhalten spätestens in Ubuntu 18.04 weggefallen.


    Das heißt, man braucht für alle Anthra-Skins, die das Muster nutzen, diese Änderung:

    Für ost habe ich es gerade hochgeladen, die restlichen Varianten fixe ich im Laufe des Tages. die anderen Anthra-1920 Varianten sind davon nicht betroffen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Hallo,

    habe gerade die anderen 3 skins installiert, da gibt es keinen Parse error.

    Beim anthra_1920_FSE/anthra_1920_FSE.skin

    bekomme nach der Eingabe von OK, das 'channel display' aber nicht angezeigt.

    Weiter habe ich noch nicht getestet. Danke nochmal.

    mfg

  • Weiter habe ich noch nicht getestet

    Gibt es da eventuell Hinweise auf ein Problem bei der Locking-Reihenfolge oder sonstige Meldungen im Log? Welches Ausgabeplugin nutzt du?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,

    ja, gibt Meldungen , habe softhddevice-openglosd installiert

    Bei Ok ist folgendes im log

    Bei allen anthra-skins und deren Themes, erfolgt keine Farbausgabe.

    mfg

  • Paulaner

    Hab schon lange nicht mehr am vdr gesessen... Bei Pulseaudio muss man auch paasthrough aktivieren, musst mal im Plugin pulsecontrol schauen.


    Lars

  • Bei Pulseaudio muss man auch paasthrough aktivieren, musst mal im Plugin pulsecontrol schauen.

    Yepp, das hatte ich schon gesehen und auch aktiviert.

    Mein Problem wird sein, dass ich beim aktivieren von hdmi-stereo-extra1 keine Verbindung zum HDMI-Audio mehr habe,

    weil dann das Profil GP108 High-Definition-Audio Controller als "unplugged" angezeigt wird.


    Ich werde erstmal zur Sicherheit ein Backup vom yavdr-ansible machen und dann mal Pulsaudio deaktivieren/deinstallieren und schauen, ob ich es mit Alsa hinbekomme, wie bei meinem yavdr-0.6.

  • So, nach dem ich ein Backup vom yavdr-ansible zur Sicherheit erstellt habe, habe ich anschließen einfach mal folgendes gemacht:

    apt-get purge pulseaudio

    Anschließend noch die /etc/asound.conf reinkopiert und die softhdcuvid.conf angepasst, wie ich das hier im Beitrag #329 beschrieben habe.


    Nach einem "reboot" habe ich keinen Ton mehr im VDR. :(

    Kodi gestartet und im Kodi-Setup die richtigen Audio-HDMI-Devices ausgewählt und ein paar Testvideos laufen lassen.

    Hier in Kodi läuft alles jetzt perfekt: :)

    Je nach Testvideo wird Stereo, DD, DTS und auch die Highres-Audioformate Dolby-TruHD und DTS-HD Master wiedergegeben!


    Zurück auf den VDR, aber hier ist kein Ton zu hören!

    Irgendwo muss hier noch etwas sein, was man einstellen muss, aber ich weiß nicht was, denn im syslog finde ich nichts, da scheint alles i.O. zu sein. Hier mal ein paar relevante Auszüge aus dem syslog:


    Nach dem Umschalten auf einen anderen Sender ist für mich auch alles i.O.


    Wenn ich auf der Konsole den "alsamixer" aufrufe, dann habe ich 2 Positionen: S/PDIF und S/PDIF 1.

    Beides ist bei mir "unmuted", müsste also funktionieren.


    Kann mir mal hier jemand evtl. helfen, wo ich da noch was einstellen muss, damit ich auch Ton im VDR habe und nicht nur in KODI?


    Paul

  • Das kann ich nachvollziehen (genauso wie die fehlende Kanalinfo-Anzeige), aber habe leider keine Idee, woran das liegen könnte. Falls da jemand Patches erarbeiten will, baue ich die gerne ein.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)