• Hi


    I think I have the same problem as razorblade has in post #18 (50 Hz problem) to try to get 50 Hz refresh rate with my Intel NUC7i5BNK with Intel Iris Plus Graphics 640 display card.

    Code
    1. Nov 12 09:34:12 vdrsrv02 vdr: video: decoder buffer empty, duping frame (23524/10932) 0 v-buf
    2. Nov 12 09:34:12 vdrsrv02 vdr: video: 4:21:43.347+1646 831 0/\ms 0+1 v-buf
    3. Nov 12 09:34:12 vdrsrv02 vdr: video: slow down video, duping frame
    4. Nov 12 09:34:12 vdrsrv02 vdr: video: decoder buffer empty, duping frame (23526/10932) 0 v-buf
    5. Nov 12 09:34:12 vdrsrv02 vdr: video: 4:21:43.347+1626 811 0/\ms 0+1 v-buf
    6. Nov 12 09:34:12 vdrsrv02 vdr: video: slow down video, duping frame
    7. Nov 12 09:34:12 vdrsrv02 vdr: video: decoder buffer empty, duping frame (23528/10932) 4 v-buf
    8. Nov 12 09:34:12 vdrsrv02 vdr: video: 4:21:43.347+1607 792 0/\ms 4+1 v-buf
    9. Nov 12 09:34:12 vdrsrv02 vdr: video: slow down video, duping frame

    I have only tried to run this command, but it is not helping. Any advice?

    Code
    1. sudo -H ansible-playbook yavdr07.yml -c local -i localhost, --tags="yavdr-xorg"

    Thanks

    Harald

  • The playbook does not yet handle the automatic display configuration for Intel IGPs, so you need to configure Xorg yourself if you want to use a mode with 50Hz refresh rate.


    fnu has described a way to enforce a display resolution and refresh rate which works even if the display is not connected or powered during startup, so a reliable operation is guaranteed: Zusammenfassung Intel VAAPI & edid.bin


    For this method I still need to find a reliable method to associate the xrandr connector name (e.g. HDMI-0) to the name required for the grub boot parameter (like HDMI-A-0) in order to automate these steps (and the method mentioned above has the drawback that only one display is supported).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hmm, das bringt auch nichts. Nach ein paar Minuten "Displayinaktivität" gehen beide Displays wieder aus und der Ton ist weg.

    Ich hatte xset s off -dpms in /var/lib/vdr/.config/openbox/autostart eingebaut.

    Hast du mal das Debug-Logging von KODI aktiviert und geschaut, ob das ungewollt noch irgendetwas macht?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Habe das LOG Level mal auf 2 gesetzt, aber im kodi.log wird nichts bzg. des Abschaltens geschrieben.

    Das syslog ist dazu schweigsam und im Xorg.0.log steht auch nichts.


    Cheers,

    Ole

  • Moin zusammen, habe hier das Problem, dass Kodi 18 im yaVDR ansible nach einiger Zeit der Wiedergabe (Audio) die Bildschirme abschaltet und den Ton stumm. Ist das jemandem bekannt bzw. kann ich das irgendwie unterbinden?

    Drücke ich dann eine Taste an der FB oder auf der Tastatur, geht es weiter. Vmtl. Der Displaymanager?


    Cheers,

    Ole

    Hatte das gleiche Thema,

    Habe in "/var/lib/vdr/.config/openbox/autostart" folgende Zeilen angefügt, seitdem ist es nicht mehr aufgetreten:

    Code
    1. export DISPLAY=:0.0
    2. xset s off -dpms
  • Die Variante in der autostart habe ich auch schon ausprobiert, hat aber leider nicht geholfen.

    Auch mit zusätzlichem export DISPLAY bin ich nicht zum Erfolg gekommen.


    Cheers,

    Ole