yavdr ansible

  • Die Fehlermeldung des ansible-playbook werde ich am Wochenende nachreichen!

    Anbei wie angekündigt, die Ausgabe auf der Konsole, wenn das yavdr-ansible playbook ausgeführt wird: Fehler yavdr ansible playbook


    Vielen Dank für die Hilfe!


    Schöne Grüße


    Christian

    Files

  • Ah, du hast noch eine alte KODI 17 Version installiert, bei der das Update auf KODI 18 nicht sauber klappt. Am besten du entfernst die alten KODI-Pakete und lässt sie danach vom Playbook wieder installieren.

    sudo apt remove kodi*

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ah, du hast noch eine alte KODI 17 Version installiert, bei der das Update auf KODI 18 nicht sauber klappt. Am besten du entfernst die alten KODI-Pakete und lässt sie danach vom Playbook wieder installieren.

    sudo apt remove kodi*

    Jetzt ist das ansible playbook ohne Fehler durchgelaufen!


    Vielen Dank!


    Noch eine Frage zur Anleitung, fehlt unter Punkt "1.3.1 Herunterladen von yavdr-ansible" nicht noch der Befehl $ git checkout bionic?


    Schöne Grüße


    Christian

  • Noch eine Frage zur Anleitung, fehlt unter Punkt "1.3.1 Herunterladen von yavdr-ansible" nicht noch der Befehl $ git checkout bionic?

    Der branch bionic ist mittlerweile der Standard-Branch, d.h. wenn man das Repository neu per git clone holt, ist der bereits ausgewählt - ich habe einen Abschnitt ergänzt, der das klarstellt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich habe jetzt den 2ten vdr mit ansible installiert und alles lief prima durch, bis das Fernsehbild kam.

    Das Bild ist jetzt etwas kleiner als der Vollbildschirm und wenn ich das Menu öffne ist es links abgeschnitten.

    Sobald man eine Taste drückt, wird das Menu unübersichtlich und hat teilweise eine grün/gelbe Farbe (fast nicht mehr lesbar).


    Wenn ich eine andere Application, z.B. Firefox via Menu starte, füllt der den ganzen Bildschirm, heißt der X-Server scheint zu passen, aber der vdr nutzt ihn nicht vollständig.


    Ich habe schon, wie in vorherigen Posts beschrieben, mit overscan via nvidia-settings versucht zu korrigieren (GraKa ist eine GeForce GT 730 und Fernseher ein Sony KDL-52W815B). Da passiert aber gar nichts, egal was ich eingebe.

    Scheint mir aber eh kein Xserver Problem zu sein, da andere Programme ja den vollen Bildschirm nutzen.

    Habe auch schon versucht, die setup.conf vom 0.6er vdr zu nehmen, bei dem ich das Problem nicht hatte. Hat aber auch nichts geändert.

    Ich hatte auch schon im softhddevice auf pan&scan umgestellt. Das macht mir zwar das Bild groß, aber das OSD ist immer noch abgeschnitten und hat die komischen Farben. Jegliche Änderungen in den OSD Positions- und Größenparametern bewirken auch nichts.


    Hat jemand einen Tipp zur Lösung?

  • Welches Ausgabedevice verwendest du? Falls es softhddevice ist, probier mal die openglsosd-Variante und wenn die nicht geht die mit ffmpeg 2.8.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Hallo,

    GraKa ist eine GeForce GT 730

    welchen Nvidia-Treiber nutzt du??


    Gruss

    Wolfgang

  • Welches Ausgabedevice verwendest du? Falls es softhddevice ist, probier mal die openglsosd-Variante und wenn die nicht geht die mit ffmpeg 2.8.

    Mit openglsosd funktioniert es wunderbar, ffmpeg2.8 hat das gleiche Problem wie der vpp.

    Es geht erstmal mit openglsosd => Danke davie2000!


    Ich würde aber trotzdem wissen wollen, warum vpp mit dem einen PC nicht geht.

  • Hallo,

    welchen Nvidia-Treiber nutzt du??


    Gruss

    Wolfgang

    Den 430, wie vom NVIDIA tool als Bester Treiber ausgegeben (und von ansible auch installiert).

    Habe aber auch schon den 384/390 versucht, das ändert nichts an dem Verhalten( kann aber auch sonst keinen Unterschied zwischen den Treibern bei meiner GraKa feststellen).

    Habe trotzdem wieder den 430 installiert.

  • Mit openglsosd funktioniert es wunderbar, ffmpeg2.8 hat das gleiche Problem wie der vpp.

    Es geht erstmal mit openglsosd => Danke davie2000!


    Ich würde aber trotzdem wissen wollen, warum vpp mit dem einen PC nicht geht.

    Was mir bei openglsosd nicht gefällt, ist das die Transparenzbehandlung nicht gut funktioniert, heißt z.B. das man beim weiterblättern im osdteletext noch die alte Seite im Hintergrund hat und daher gar nichts mehr lesen kann. Das hatte ich beim vpp nicht. Konnte es nur loswerden, wenn ich den Transparenzwert auf Maximum stelle. Selbes auch im normalen OSD, da fällt es bei mir aber nicht so stark auf, weil ich mit Anthrax ein relativ dunkles Skin benutze.

    Gibt es dafür ne andere Lösung (oder wie bekomme ich vpp wieder zum Laufen)?

  • Mit openglsosd funktioniert es wunderbar, ffmpeg2.8 hat das gleiche Problem wie der vpp.

    Es geht erstmal mit openglsosd => Danke davie2000!


    Ich würde aber trotzdem wissen wollen, warum vpp mit dem einen PC nicht geht.

    Hab gestern was falsch gemacht, openglsosd geht doch nicht. War wohl aus versehen pan&scan aktiv.

    Habe mal die xorg.conf vom neuen mit dem 0.6 yavdr verglichen und wenn ich folgende Option in die screen section einfüge, hat das Bild keine schwarzen Ränder mehr:


    Option "DPI" "100x100"


    Weiß nicht, ob das auch andere betrifft und man das generell in die xorg.conf aufnehmen sollte.


    Das Menu Thema ist aber damit nicht gelöst und man kann das Menu mit softhddevice-vpp wegen der Farben und der Verschiebung nicht lesen, mit openglsosd geht es aber, wenn auch nicht perfekt. Das versuche ich noch weiter zu analysieren, aber dauert etwas.

  • Welches Theme nutzt du denn und gibt es auf deinem System irgendwelche Besonderheiten? Beim voreingestellten anthraize wird die Uhrzeit jede Sekunde aktualisiert. IIRC sollte das unabhängig vom VDR klappen, weil die Ermittlung der Uhrzeit in JS implementiert ist und somit direkt vom Browser ausgeführt wird.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Option "DPI" "100x100"


    Weiß nicht, ob das auch andere betrifft und man das generell in die xorg.conf aufnehmen sollte.

    Das könnte alle Betreffen, deren Monitor keine quadratischen Pixel hat. Was sagen denn bei dir ohne die Zeile in der xorg.conf xrandr -d :0 -q und xdpyinfo -display :0 | grep -E 'dimensions|resolution'?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 2 times, last by seahawk1986 ().

  • Das könnte alle Betreffen, deren Monitor keine quadratischen Pixel hat. Was sagen denn bei dir ohne die Zeile in der xorg.conf xrandr -d :0 -q und xdpyinfo -display :0 | grep -E 'dimensions|resolution'?

    Hier die Ausgabe für die Befehle:


    xdpyinfo -display :0 | grep -E 'dimensions|resolution'

    mit der Zeile:

    dimensions: 1920x1080 pixels (488x274 millimeters)

    resolution: 100x100 dots per inch

    ohne die Zeile:

    dimensions: 1920x1080 pixels (1134x623 millimeters)

    resolution: 43x44 dots per inch



    xrandr -d :0 -q (ohne die Zeile):

    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384

    VGA-0 disconnected (normal left inverted right x axis y axis)

    DVI-D-0 disconnected (normal left inverted right x axis y axis)

    HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1110mm x 620mm

    1920x1080 60.00 + 59.94 59.93 50.00* 29.97 23.98 60.00 50.04

    1680x1050 59.95 59.88

    1600x900 60.00 59.95 59.82

    1440x900 59.89

    1400x1050 59.98

    1400x900 59.96 59.88

    1368x768 59.88 59.85

    1360x768 59.96 59.80

    1280x1024 60.02

    1280x960 60.00

    1280x800 59.91 59.81

    1280x720 60.00 59.94 59.86 59.74 50.00 29.97 23.97

    1152x864 60.00

    1024x768 60.00

    1024x576 59.90 59.82

    960x540 59.82 59.63 59.99 59.96

    864x486 59.92 59.57

    840x525 60.01 59.88

    800x600 60.32 56.25

    800x450 59.95 59.82

    720x576 50.00

    720x480 59.94

    720x450 59.89

    720x405 59.51 58.99

    700x525 59.98

    700x450 59.96 59.88

    684x384 59.88 59.85

    680x384 59.96 59.80

    640x480 59.94 59.93

    640x400 59.98 59.88

    640x360 59.84 59.32 59.86 59.83

    512x384 60.00

    512x288 60.00 59.92

    480x270 59.82 59.63

    432x243 59.92 59.57

    360x202 59.51 59.13

    320x240 60.05

    320x180 59.84 59.32

  • Das Menu Thema ist aber damit nicht gelöst und man kann das Menu mit softhddevice-vpp wegen der Farben und der Verschiebung nicht lesen, mit openglsosd geht es aber, wenn auch nicht perfekt. Das versuche ich noch weiter zu analysieren, aber dauert etwas.

    Hab in einem anderen Post die Lösung gefunden. Das Problem ist wohl die GT 730 und der nvidia-driver-430, nvidia-384 oder nvidia-driver-390 Treiber.
    Wenn man den nvidia-340 Treiber installiert, sieht das Menu wieder gut aus und geht auch mit softhddevice-vpp.