yavdr ansible

  • Öhm wie kann ich die Datei denn also die main.yml öffnen?


    sorry für die dumme Frage, aber so tief steck ich nicht drin in der Materie...

    VDR 1:
    Mainboard: Foxconn 45GM
    Prozessor: Core2Duo E6600
    Grafik: Geforce 210 Low Profile (passiv)
    DVB-Karte: Skystar HD/SkyStar HD 2
    Festplatten: 60 GB SSD als Boot/ 1 TB HDD als sdb gemountet als /srv
    Distri: Yavdr 0.6
    zusätzliche Pakete: yaepghd, istreamdev, Filezilla Client
    ----------------------------------------------------------------------
    VDR 2:


    Raspberry PI 512 MB
    16 GB SD Karte
    MLD 4 als Streamdev Client am VDR 1 für Gäste


    ------------------------------------------------------------------------


    (Linux ist ein System das durch Schmerz, Frust und Leid erlernt werden muss, aber wenn es einmal läuft macht es tierisch viel Spaß)

    The post was edited 1 time, last by Morpheus1607 ().

  • Es ist We, es regnet, als viel Zeit zum VDR basteln :-)


    ASROCK J4205-ITX


    Folgende Fehlermeldung erscheint:


    Hilfe!


    Grüße an die Ansible Gemeinde.


    Matthias

    HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7

  • Probier mal bitte folgende Änderung:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986: Die erste Variante hat nicht funktioniert, weil lookup("file", "/etc/yavdr/autoinstalled", errors="ignore") None zurückgibt. ().

  • Ich habe mal eine leere /etc/yavdr/autoinstalled erstellt, damit ist die installation dann durchgelaufen, Bild ist auch da.


    Er erkennt aber nicht die max. Auflösung (UHD) von meinem TV.


    ok: [localhost] => {

    "xorg.primary": {

    "connector": "DP-2",

    "edid": "/etc/X11/edid.DP-2.bin",

    "mode": "1920x1080_50",

    "model": "Unknown",

    "modelines": [],

    "refreshrate": 50,

    "resolution": "1920x1080",

    "vendor": "Unknown"


    UHD1 belibt auch dunkel, nur der Ton ist zu hören

    HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7

  • Er erkennt aber nicht die max. Auflösung (UHD) von meinem TV.

    Kannst du mal den Inhalt von /etc/ansible/facts.d/xrandr.fact und /etc/ansible/facts.d/xorg.fact zeigen?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)


  • HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7

  • Also 1080p hat der Installer gewählt, weil dein TV laut der geparsten Ausgabe von xrandr 4k nur mit maximal 30 Hz kann, was zu miesen Rucklern und Asynchronitäten mit softhddevice führt.


    UHD1 belibt auch dunkel, nur der Ton ist zu hören

    Hast du zufällig der Warnung in der Readme.md zum Trotz nicht das Alternate Installer Iso sonder das Cloud-Installer ISO für die Ubuntu Server Installation genommen (das ist eine beliebte Ursache - in dem Fall sieht man auch keinen yaVDR-Bootsplash)?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • Warnung in der Readme.md

    Muss es da "openssh-server" heißen?

    Software: yaVDR0.6.1 mit VDR 2.2.0-13yavdr0~trusty, Kernel 4.4.0-148-generic, nvidia 384.130, dddvb 0.9.36.0easyVDR0
    Hardware: ASRock B75 Pro3-M, Intel G2030, RAM 4GB, SSD 64GB, HDD 4TB, Zotac GT630 ZONE Edition 1024MB GK208 (SKU:ZT-60408-20L), DD Cine C2/T2 V7
    Fernseher: SONY KDL-32D3000


  • Ja, danke für den Hinweis.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Quote

    Also 1080p hat der Installer gewählt, weil dein TV laut der geparsten Ausgabe von xrandr 4k nur mit maximal 30 Hz kann, was zu miesen Rucklern und Asynchronitäten mit softhddevice führt.


    Mein Fernseh kann mehr.


    xrandr -q mit einer GTX1030:


    3840x2160 60.00 + 59.97 59.94 50.00* 29.97 25.00 23.98

    4096x2160 59.94 50.00 29.97 25.00 24.00 23.98

    3200x1800 59.96 59.94

    2880x1620 59.97 59.96

    2560x1600 59.99 59.97

    2560x1440 59.96 59.95

    2048x1536 85.00 75.00 60.00

    2048x1152 59.91 59.90

    1920x1440 85.00 75.00 60.00

    1920x1200 59.95 59.88

    1920x1080 119.88 100.00 60.00 59.96 59.94 59.93 50.00 29.97 25.00 23.98 60.01 59.97 60.00 50.04



    Die Intel hardware auf dem ASRock j4205 sollte UHD bis 60 Hz schaffen.


    Ich verwende definitv das mini iso.


    Yavdr bootsplash ist da.


    Unter Kodi kann ich sogar ein 10bit hvec wiedergeben, was mit der GTX1030 nur geruckelt hat.


    Dafür geht mit dem J4205 kein UHD im VDR.....


    Verzweiflung :-)

    HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7

  • War das am selben HDMI-Eingang? Es gibt soweit ich weiß Modelle, die nur einen HDMI 2.0 Anschluss haben.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Mit xrandr -d :0.0 kannst du dir ansehen, was da aktuell erkannt wird - bietet KODI die 4k-Auflösung mit 60 Hz an?


    Bist du schon auf der aktuellsten BIOS-Version? Laut Changelog wurde da etwas bei der 4k-Ausgabe geändert: https://www.asrock.com/mb/Intel/J4105-ITX/index.de.asp#BIOS


    Ich verwende definitv das mini iso.

    Eventuell mal mit dem Alternative Installer ISO im UEFI-Modus probieren, nicht dass es am Legacy-Boot scheitert.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Guten Morgen,


    Quote


    Bist du schon auf der aktuellsten BIOS-Version? Laut Changelog wurde da etwas bei der 4k-Ausgabe geändert: https://www.asrock.com/mb/Intel/J4105-ITX/index.de.asp#BIOS


    Bingo, nach dem BIOS update sieht es besser aus:



    Das findet er bei der Installation vom playbook:


    Die Wiederholfrequenz steht aber bei 60 obwohl. Im laufenden Betrieb kann ich sie umschalten mit:


    xrandr --output DP2 --mode 3840x2160 -r 50


    Nach dem nächsten Neustart hat er wieder 60Hz.


    Wie kann ich das permanent einstellen?


    Bei 3840x2160 50Hz sind mikroruckler zu sehen, bei 1920x1080 50Hz ist das Bild flüssig.

    HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7

    The post was edited 1 time, last by kdgsv ().

  • Nach dem nächsten Neustart hat er wieder 60Hz.


    Wie kann ich das permanent einstellen?

    Wie sehen denn die vom Plabook erzeugte /etc/X11/xorg.conf.d/20-intel.conf und die /etc/ansible/facts.d/drm.conf sowie /etc/ansible/facts.d/xorg.conf jetzt aus?

    Bei 3840x2160 50Hz sind mikroruckler zu sehen, bei 1920x1080 50Hz ist das Bild flüssig.

    Eventuell kommt er da die IGP aufgrund der Option

    Code
    1. Option "TearFree" "true"

    an ihre Grenzen. Zumindest auf meinem Haswell-Laptop war die aber notwendig, um ein sauberes Bild zu erhalten (habe ich aus https://wiki.archlinux.org/index.php/Intel_graphics#Tearing) - in https://bugs.freedesktop.org/show_bug.cgi?id=37686 wird die Nutzung von compton als Compositor als mögliche Alternative genannt - da könntest du mal experimentieren.


    BTW: Hast du einen Dual-Channel Konfiguration für den RAM? Immerhin müssen da eine Menge Daten bewegt werden (und zumindest bei den ION-Boards war das eine der Engstellen bei höheren Auflösungen).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 2 times, last by seahawk1986 ().

  • vaapidevice statt softhddevice-vpp wäre ggf. noch einen Versuch wert - die Konfigurationsdatei für das Plugin sollte so aussehen: yavdr ansible

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Quote

    Wie sehen denn die vom Plabook erzeugte /etc/X11/xorg.conf.d/20-intel.conf und die /etc/ansible/facts.d/drm.conf sowie /etc/ansible/facts.d/xorg.conf jetzt aus?

    20-intel.conf


    drm.fact hab ich da nur, keine .conf


    xorg.fact hab ich da nur, keine .conf


    Hab kein Dual Channel.

    HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7

  • "modelines": [],

    Ok, dann schafft er es nicht die Modelines aus der EDID zu extrahieren und fällt im Template auf die Standard-Modelines zurück. Du könntest mal versuchen in der 20-intel.conf die Modelines für 3824x2160 zu ergänzen:

    Code
    1. "3840x2160_25" 219.40 3840 3888 3920 4000 2160 2183 2188 2194 +hsync -vsync
    2. "3840x2160_30" 263.28 3840 3888 3920 4000 2160 2183 2188 2194 +hsync -vsync
    3. "3840x2160_50" 442.20 3840 3888 3920 4000 2160 2183 2188 2211 +hsync -vsync
    4. "3840x2160_60" 533.28 3840 3888 3920 4000 2160 2183 2188 2222 +hsync -vsync

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Erstmal vielen Dank für die Mühe die ich gemacht habe :-)


    Die Zeilen habe ich eingefügt.....müßte das nicht "+vsync" sein?


    xrandr -q zeigt:




    Das Bild im VDR läuft nur flüssig wenn ich auf 1920x1080 50Hz einstelle.


    Kann man das als standard gemäße Auflösung einstellen?


    UHD weiterhin nur Ton.


    Im Kodi laufen alle sender Flüssig, UHD hat Bild und Ton aber Mikroruckler.


    Alles in allem erscheint mir Die Bildqualität schlechter wie mit dem anderen Testsystem (Dell Optiplex 760 mit GTX 1030)

    Das Bild ist Matschiger, unschärfer und die Farben sind auch nicht so dolle.


    Gibt es hier noch jemand der das ASROCK J4205-ITX einsetzt und vieleicht schon Erfahrungen damit gemacht hat?


    Ich hab jetzt erstmal den Dell aktiver und mach mal Pause, Formel 1 kommt gleich :-)


    Einen schönen Tag noch.


    Grüße

    Matthias

    HTPC mit ASROCK J4205-ITX und Yavdr 0.7, HTPC Dell Optiplex 760 mit Nvidia GTX 1030 und Yavdr 0.7