Vdr 2.3.8 auf Ubuntu Xenial

  • Ja, wenn er das nicht extra softhddevice als Startoption mitgeben will, bietet sich der Eintrag in der asound.conf an.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Das habe ich noch in /usr/local/bin


    Shell-Script
    1. #!/bin/bash
    2. if pidof vdr >/dev/null; then
    3. if wmctrl -l | cut -d" " -f5 | grep "^vaapidevice$" > /dev/null; then
    4. /usr/bin/vdr-dbus-send /Plugins/vaapidevice plugin.SVDRPCommand string:'deta' string:''
    5. else
    6. /usr/bin/vdr-dbus-send /Plugins/vaapidevice plugin.SVDRPCommand string:'atta' string:''
    7. fi
    8. fi

    Braucht eventuell einmal:

    Code
    1. sudo apt-get install wmctrl

  • Habe das mit dem socket jetzt selber ausprobiert und funktioniert :)

  • Was wäre nach deiner Meinung jetzt die bessere Lösung?

  • Bringt das irgendwelche Vorteile über TCP zu gehen, wenn man auch einen lokalen unix-Socket nutzen kann? Gefühlt ist bei TCP der Overhead größer.

    Moin,

    via Socket läuft mir der Ton davon. Das ist mir mit TCP so noch nicht aufgefallen.

    Habe also wieder auf TCP zurück gestellt und mache da mal die Gegenprobe (zwei Stunden ohne Umschalten).

  • Was wäre nach deiner Meinung jetzt die bessere Lösung?

    Das war wohl zeitgleich :)


    Mit TCP ist der Ton hier jetzt auch nicht mehr synchron :(

    Ich fummel nebenbei an meinem RPI3 und habe dafür den TV auf HDMI2.

    Der VDR an HDMI1 hatte also bei meinen Test keinen aktiven TV-Eingang.

    Darum habe ich jetzt den Socket wieder aktiv und teste nochmal mit aktivem HDMI1...


    An deiner Stelle, würde ich es jetzt also erst (wie von seahawk empfohlen) mit dem Socket versuchen. Schalte dann auf einen Sender und lass ein zwei Stunden laufen.

    Wenn Bild und Ton dann noch synchron sind ...


    Edit: Es scheint bei mir tatsächlich mit dem aktivieren des TV-Eingangs zusammenzuhängen.

    Solange der TV für den VDR auf HDMI1 gestellt ist sind BEIDE Methoden synchron.

    Das konnte ich jetzt beim Curling schön sehen "KLACK".

    Schalte ich dann zur RPi3 auf HDMI2 und nach einiger Zeit wieder zurück auf HDMI1 passt es nicht mehr.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Saman ()

  • Habe die Socket Variante installiert.


    3 Stunden laufen lassen.Bild und Ton sind synchron.