[gelöst] Debian Stretch Speicherzugriffsfehler?

  • Hallo!

    Debian Jessie 8.10(?)! Alles in Ordnung, oder sagen wir, keine Fehler festgestellt, weil lief schon ewig.

    Dist-upgrade auf Stretch 9.3 (amd_64)! Unterschiedliche Programme verursachten Speicherzugriffsfehler, medienplayer, etc.

    Dann ein "Format C:" :) Alles neu installiert und es war erstmal gut.

    Nun stelle ich fest, das Programme die eine grafische Oberfläche brauchen wieder vermehrt Speicherzugriffsfehler verursachen. (Lilypond console, keine Fehler! grafisches Frontend, Speicherzugriff)

    Keine Fremdquellen eingetragen!

    Nvidia aus dem Backport 375.xx installiert.

    Memtest zeigt keine Fehler und auch fsck sagt alles gut.


    Ich habe nun ein bisschen Angst auf meinem VDR ein Upgrade zu machen.

    Hat jemanand vergleichbare Probleme?

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

  • Rund 1 Monat läuft nun Stretch auf meinem VDR.

    amd_64, VDR2.3.8, e-Tobi, Debian Stretch 9.3,

    Linux vdr 4.9.0-6-amd64 #1 SMP Debian 4.9.82-1+deb9u2 (2018-02-21) x86_64 GNU/Linux

    vdr-sxfe -A alsa:plughw:1,7 -Rvsf (local)

    crashed das System nach 1-2 Tagen

    Ich habe nun einmal libxineliboutput-sxfe installiert, damit ich wirklich local arbeite. Für eine Prognose ist es mir noch zu früh, Es fehlen noch ein paar Stunden für eine Aussage (uptime 1D 9:45)

    Stay tuned!

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

  • Ich hab auf meinen Desktop auch Stretch mit dem Nvidia-Treiber laufen und keine Probleme. Wenn man von dem Macken die der KDE hat absieht.


    Der angehängte Log legt den Schluss nahe, dass es mit dem DVB-Treiber zusammenhängt.

    Ist das immer der Fall oder kommt da immer was unterschiedliches?


    Im Fall des DVB-Treibers als Ursache, würde ich aber eigentlich keine Probleme mit anderen Programmen erwarten.


    Da das Board jetzt auch schon beinahe 10 Jahre alt ist, wären für mich auch die ELKOs verdächtig.

    Gruss
    SHF


  • Der oben genannte Fehler kommt immer nur im "VDR-Betrieb" und ist immer der gleiche, wenn ich vdr-sxfe nutze.

    Seit 2,5 Tagen mit rein lokaler Ausgabe (kein vdr-sxfe -A....) keine Probleme.

    Habe nun ein Image erstellt um einfacher zu testen.

    Speichertest und Festplattentest sind ohne Fehler durchgelaufen. Speicherriegel habe ich auch getauscht, ohne Veränderung.

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

  • Die Fehlermeldung lässt auf die DVB_Treiber schliessen.


    Du hast noch zwei PCI-Karten drin?

    Gruss
    SHF


  • Ja, die Hardware stimmt noch (Signatur).

    Eine Karte produziert immer Klötzchen und ich muss Treiber / VDR neu starten. Wie finde ich heraus welche Karte die Probleme macht? Die Anzeige im VDR Menue sieht nie danach aus das es Probleme gibt.

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

  • Die FF kann "primäres Device" werden. Die Budget-Karte nicht.

    Das FEmon-Plugin zeigt auch den Tuner an, wenn die bei beiden Karten unterschiedlich sind geht das auch gut.

    Beides kannst du bequem im OSD durch probieren.


    Sonst der Weg über die Logfiles.

    VDR device Nummer -> /dev/dvbx -> Treibermeldung beim Laden.

    Gruss
    SHF


  • Moin!

    Ist schon etwas her, aber manchmal dauern Fehlersuchen etwas länger. Ich will nicht sagen das das Problem gelöst ist, es ist aber merklich besser geworden.

    Die Suchmaschine meinte das es am Kernel liegt, ich wollte aber keinen anderen Kernel. Also habe ich weiter probiert und von einem crash pro Tag auf einen alle zwei Wochen "repariert". ;)

    Mir ist irgendwann aufgefallen das wenn ich die Sicherungsplatten nicht wieder ausgehängt hatte der Rechner den Fehler machte.

    Eine Platte für Serien, eine für Dokus und eine für Filme, angeschlossen via USB. Eingehängt auf /var/lib/video.00/Serien */Filme, usw. Nach 1-2 Tagen kam dann der Speicherzugriffsfehler.

    Nun hänge ich die Platten immer wieder aus und es machen nur noch die DVB-Karten zicken.

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

  • Ich glaube mein vdr will mich ärgern.

    Nachdem die Kiste einige Zeit, ohne Probleme, lief und ich das oben geschriebene verfasst hatte, war der vdr nach kurzer Zeit nicht mehr zu benutzen.

    Meine weitere Fehlersuche ging dann erst einmal in Richtung Thermisches Problem, weil sich das Problem mit steigenden Temperaturen (gefühlt) verschlimmerte. Sensors installiert, Temperatur CPU / MB unter 40 Grad, trotzdem ein paar Lüfter installiert. Trotzdem Speicherzugriffsfehler!

    Größeres Netzteil installiert... Speicherzugriffsfehler. Weil ich schon Probleme mit dem CPU-Lüfter hatte auch diesen gewechselt, keine Änderung.

    Aktuellen Kernel aus dem Testing (4.16-0) installiert und das System crashed weiterhin nach 20-120 Minuten.

    Also habe ich versucht meine 386 Installation zum laufen zu bewegen, da ist aber beim upgrade irgendwas falsch gegangen und ich meine mich zu erinnern das die nvidia Treiber Kernel 4.x verlangt(?), also wollte der xserver nicht.

    Also wieder zurück, kurz davor vdr vdr sein zu lassen und eine out of the box zu kaufen.

    Steckplätze der Karten und auch die Sat-Leitungen getauscht, nix.

    Also Karten einzeln betreiben und ich denke ich habe den Übeltäter gefunden!?

    Derzeit läuft seit 18h eine Activity-Budget Karte.

    Ein Teil der Probleme wurden von einer Medion Type SAT-TUNER 7134, REV: CTX929_V.1 DVB-S (die Budget in der Sig.) verursacht. Zumindest die Speicherzugriffsfehler.

    Nun teste ich noch die FF-Karten, weil ich mit denen auch Probleme gehabt hatte. Probleme hatte ich ja schon die ganze Zeit, gefühlt wurden sie mit Kernelversion 4.xx massiver.

    Mit der FF musste ich unregelmäßig die Module ttpci* entladen und neu laden. Da bin ich mal gespannt ob sich das Problem evtl. gelöst hat.

    Ich in gespannt!

    VDR: ASUS P5DL/EPU, 1x FF TT2.1, 1x Budged Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder, 1x WLAN USB, NVIDIA GT610

    DEBIAN 9.latest e-Tobi amd64, VDR 2.4.0 xineliboutput-sxfe

  • Bei den FFs könnte man noch versuchen die PCI-Latency hoch setzen, das hat sich bei mir immer positiv ausgewirkt.

    Gruss
    SHF