[erledigt] Fehlerhaftes UHD Video mit GTX 1050Ti

  • Ich habe auf allen Demokanälen sehr schwere Bildfehler. Die linke Bildhälfte verzerrt sich alle paar Sekunden und scheint eine grüne, gestauchte Version des Gesamtbildes darzustellen. Der Ton stockt dabei auch. Hat noch jemand ein paar Tuning Tips?


    System ist ein Kaby Lake Core i5 mit nVidia GTX 1050Ti. yavdr 0.6 mit dem softdevice-vpp-hevc aus dem dem DVB-T2 thread und 384 Treiber.

  • Mit den Nvidia-Karten und VDPAU (wie es vom softhddevice-Plugin verwendet wird) geht die UHD-10bit-HEVC-Hardware-Decodierung, wie diese bei den UHD-Sendern über Astra verwendet wird nicht!


    Bei DVB-T2-HD funktioniert die HEVC-Hardwaredecodierung noch über VDPAU, aber leider nicht mehr bei UHD-10bit! dafür müsste dann das neuere CUVID von Nvidia verwendet werden. Dazu müsste dann allerdings erst noch ein entsprechendes Ausgabeplugin für den VDRprogrammiert werde!


    Also sind Deine Bild- und Tonprobleme "normal", weil die HEVC-Decodierung nur per Software in der CPU gemacht wird, da ist die GT1050i leider außen vor!


    Paul

  • Nimm die Grafik Deines Kaby Lake Core i5 ...


    Regards

    fnu

    HowTo: APT pinning

  • Aber irgendwie gibt es HDMI 2.0 Ausgang nur bei den hochpreisigen Boards (x70), so daß man auf 4k@30Hz limitiert ist. Oder habe ich eins übersehen?


    Schöne Grüße,


    Space

  • CEC geht mit HDMI an einer PC Grafikkarte nicht (zumindest ist mir kein Mainboard bekannt) bzw. nur mit Zusatzhardware. Meines wissens klappt CEC nur ohne weiteres mit einem RaspberryPi oder anderen Rechnern die im speziellen auf Multimedia spezialisiert sind.

    Gruß
    Frodo

  • Ok danke, für's Feedback das erklärt das Verhalten. Ist natürlich schade, das 4k Bild sieht schon absolut genial aus. Mit Kodi geht es einigermaßen.


    Mein Z270 Board hat übrigens nur HDMI 1.4b. Das ist auch für HDR ein Problem, nicht nur wegen 30Hz.

    Da ich sowieso Probleme mit meinem Board habe (bekomme unter Windows kein PAVP und damit kein BD-UHD Playback hin) werde ich mir wahrscheinlich dieses hier mal anschauen: ASRock Fatal1ty Z270 Gaming-ITX/ac

    Nach meiner Recherche das einzige Kaby Lake Board mit HDMI 2.0 und passendem Formfaktor (µATX oder Mini-ITX).

  • In eigenen Thread ausgelagert.

    HowTo: APT pinning

  • Hi,

    Ya 0.6 verwendet auch noch uraltes ffmpeg. In easyVDR 3.5 ist 3.4.0 drin. Neuer geht wegen dem Wegfall von VDPAU nicht. Evtl bringt das noch etwas. Oder womit ist deins compiled?


    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Gibt es inzwischen schon irgendein Ausgabeplugin, dass NVDEC/CUVID unterstützt?

    Wenn ich das richtig sehe, wird das ja von der Hardware (ab Pascal) unterstützt, die (proprietären) Linux Treiber von nVidia haben Support und ffmpeg 4.0 auch.


    Fehlt also nur ein Ausgabeplugin, dass auf NVDEC anstatt anstatt VDPAU setzt?