XMLTV EPG-Daten werden nur aus einer Quelle eingelesen, 2. Quelle wird ignoriert

  • Ich habe das vdr-plugin-xmltv2vdr und das vdr-plugin-xmltv2vdr-grabber-tvspielfilm2xmltv Plugin installiert. VDR ist 2.2.0

    Zusätzlich habe ich für diverse spanische SAT-Kanäle die in /var/lib/epgsources die Steuerdatei webgrabplus angelegt.


    In /var/lib/epgsources liegt die webgrabplus.xmltv.


    Die Validierung ergibt:


    Code
    1. tv_validate_file webgrabplus.xmltv
    2. Use of uninitialized value in pattern match (m//) at /usr/share/perl5/XMLTV/ValidateFile.pm line 181.
    3. Use of uninitialized value in pattern match (m//) at /usr/share/perl5/XMLTV/ValidateFile.pm line 183.
    4. Validated ok.

    In der setup.conf steht:

    Code
    1. xmltv2vdr.channel.ANTENA-3-HD.es = 0;1073741825;S19.2E-1-1062-30004
    2. xmltv2vdr.channel.M.MOTOGPHD.es = 0;1073741825;S19.2E-1-1062-30002
    3. xmltv2vdr.channel.motorvision-tv.de = 0;1073754141;S19.2E-133-14-168
    4. xmltv2vdr.channel.TELEDEPORTE.es = 0;1073741825;S19.2E-1-1038-30412
    5. xmltv2vdr.options.epall = 0
    6. xmltv2vdr.options.imgdelafter = 30
    7. xmltv2vdr.options.order = LOT,CRS,CAD,ORT,CAT,VID,AUD,SEE,RAT,STR,REV
    8. xmltv2vdr.options.wakeup = 0
    9. xmltv2vdr.source.order = webgrabplus

    Im OSD habe dich die Kamäle gemappt:


    Quelle tvspielfilm2xmltv => motorvision-tv.de

    Quelle webgrabplus => ANTENA-3-HD.es, M.MOTOGPHD.es, TELEDEPORTE.es


    nach dem parsen steht im Logfile vom Plugin:

    Im Syslog steht:

    Code
    1. Jan 29 11:04:06 VDR-UpBoard-01 vdr: [1088] connect from 127.0.0.1, port 44462 - accepted
    2. Jan 29 11:04:06 VDR-UpBoard-01 vdr: [1642] xmltv2vdr importer thread started (pid=1088, tid=1642, prio=high)
    3. Jan 29 11:04:06 VDR-UpBoard-01 vdr: [1642] xmltv2vdr: 'tvspielfilm2xmltv' importing from db
    4. Jan 29 11:04:07 VDR-UpBoard-01 vdr: [1642] xmltv2vdr: 'tvspielfilm2xmltv' processed no vdr events - all up to date?
    5. Jan 29 11:04:07 VDR-UpBoard-01 vdr: [1642] xmltv2vdr importer thread ended (pid=1088, tid=1642)
    6. Jan 29 11:04:07 VDR-UpBoard-01 vdr: [1088] closing SVDRP connection

    Die EPG-Datenbank vom Plugin liegt in /var/cache/vdr/xmltvepg.data.


    Diese EPG Datei enthält nur Daten aus der Quelle tvspielfilm2xmltv, keine Datei aus der Quelle webgrabplus.


    Meine Frage: Warum wird von xmltv2vdr nur die Quelle tvspielfilm2xmltv importiert, nicht aber die von mir manuell angelegte Quelle webgrabplus?


    Im Voraus vielen Dank für alles Tipps!

  • Hallo,


    Soviel ich weiß, ist es ein Problem das schon länger existiert und nicht gefixt wurde.


    Man kann es auf 2 Arten umgehen:

    - Es gibt tools die zwei xmltv Dateien zu einer einzigen xmltv Datei zusammenfügen. So hat man es dann auf einen Import reduziert.

    - Man sorgt dafür, dass der VDR vor dem Import der zweiten xmltv Datei neu startet. Wenn man einen VDR hat, der nicht ständig läuft, kann man es zum Beispiel erreichen, wenn man die Importzeiten weit genug auseinander definiert. Zum Beispiel ein Import morgens und ein zweiter abends, wenn der VDR in der Regel dazwischen runterfährt.


    MfG

  • So, ich habe das Paket vdr-plugin-xmltv2vdr-grabber-tvspielfilm2xmltv deinstalliert und somit auch diese Konfiguration entfernt, so dass nur noch die Konfiguration von webgrabplus so wie oben beschrieben in /var/lib/epgsources vorhanden ist.


    Habe dann im OSD die Kanäle aus webgrabplus => ANTENA-3-HD.es, M.MOTOGPHD.es, TELEDEPORTE.es neu gemappt.


    Anschließend VDR neu gestartet und mit svdrpsend plug xmltv2vdr updt neu geparst.


    Auf der Kommandozeile erscheint:

    Code
    1. svdrpsend plug xmltv2vdr updt
    2. 220 VDR-UpBoard-01 SVDRP VideoDiskRecorder 2.2.0; Mon Jan 29 15:55:12 2018; UTF-8
    3. 250 update started
    4. timeout

    Im EPG tauchen für die gemappten Sender keine EPG Daten auf.

    Dann nochmals das parsen angestoßen, diesmal kein Timeout:

    Code
    1. svdrpsend plug xmltv2vdr updt
    2. 220 VDR-UpBoard-01 SVDRP VideoDiskRecorder 2.2.0; Mon Jan 29 15:55:52 2018; UTF-8
    3. 250 update started

    Im EPG wieder keine Daten.

    Im Log von xmltv2vdr:

    Das kann doch nicht so schwierig sein ein korrektes xml-File in den VDR zu imoprtieren.


    Hat da noch jemand eine Idee für mich?

    Im Voraus vielen Dank für alle Tipps!

  • Habe nochmal alles neu aufgesetzt.

    Die Quelle in /var/lib/epgsources heisst nun : external


    Nach dem Neustart vom VDR, mappen im OSD und manuellem parsen per svdrpsend plug xmltv2vdr steht folgendes im Log:


    Was bedeuten die obigen Fehlermeldungen?


    Ich habe festgestellt, dass die in den EInstellungen vom Plugin definierte Datenbankdatei nicht angelegt wird, es scheitert also schon an dieser Stelle:


    EPG-Datenbank vom Plugin in => /var/cache/vdr/xmltvepg.data

    Hier wird de Datei nicht angelegt, kann also auch nicht befüllt werden.


    Was tun?


  • Stimmen die Zugriffsrechte für das /var/cache/vdr Verzeichnis?


    xmltv2vdr versucht vor dem Import ein Programm in /usr/bin aufzurufen, der den gleichen Namen hat als die Steuerdatei. Dieses Programm sollte eigentlich die Daten herunterladen; das wäre theoretisch bei dir webgrabplus.


    Ich gehe davon aus, dass du die xmltv Datei schon vorliegen hast. In dem Fall, genügt zum Beispiel einfach folgendes Script als Programm:

    Shell-Script
    1. #!/bin/bash
    2. #
    3. #
    4. exit 0

    exit 0 bedeutet für xmltv2vdr dass die Daten für den Import bereit sind.


    Das Script/Programm muss den gleichen Namen als die Steuerdatei haben. (Nicht vergessen, die Ausführungsrecht x beim Script zu setzen.)


    Die xmltv Datei muss auch den gleichen Namen als die Steuerdatei haben, mit der Endung xmltv und im Verzeichnis mit der Steuerdatei liegen.


    Man kann Quellen im OSD ausschalten, indem man die Ziffer 0 auf der Fernbedienung drückt, wenn die Quelle im OSD ausgewählt ist. Das hilft vielleicht beim testen.


    Wenn ich ein Quelle teste, setze ich seine Ausführungszeit im OSD zur aktuellen Zeit + 1 Minute, anstatt das plugin über Kommandozeile aufzurufen. Ich weiß nicht ob es einen Unterschied machen könnte.

  • Hallo ludi,

    TREFFER ;-)

    Super, das war´s. Habe das Script wie von dir angelegt und das Plugin importiert 2 meiner 3 Channels. Beim dritten Kanal stimmt evtl. etwas mit dem Syntax nicht, muss da nochmal genau nachschauen.