Probleme mit Technotrend S2-4200 bzw. DVBSky S952 v3

  • Hallo,


    wie ich schon an anderer Stelle schrieb, hatte ich vor kurzem mein VDR-Box Basissystem von 32bit auf 64bit umgestellt (Gentoo Linux) und dadurch auch einen neuen Kernel (4.12.5) bekommen. Damit lies sich meine ältere DVBSky S952 v2 (!) nicht mehr zufriedenstellend nutzen (Absturz beim Treiberladen nach Reboot).

    Deshalb habe ich mir eine neue Karte besorgt: TT S2-4200, baugleich mit DVBSky S952 v3


    Vom Kernel wurde die sofort unterstützt und funktionierte, bis ich feststellen musste, dass immer wieder Zeilen wie folgt im Log auftauchten:

    Code
    1. frontend X/0 lost lock on channel YZ
    2. frontend X/0 regained lock on channel YX

    Manchmal ist es nur ein einzelner kurzer Aussetzer, meist aber mehrere Sekunden bis zu 10 oder mehr Minuten. Eine Aufnahme von diesem Kanal ist dann natürlich für diesen Zeitraum unbrauchbar ;( Habe dann mal den Kernel auf 4.14.8 aktualisiert. Keine Besserung! Habe dann mal den Einschaltkanal von "Das Erste" auf "Sat.1" geändert, dann wurde es etwas besser, bis ich eine Aufnahme von "Sat.1 Gold" machen wollte: mehrere Minuten "lost lock"... Nun zum Einschalten auf "intv" gewechselt, änderte aber nichts.


    Als Ausgabe-Device nutze ich noch eine ganz alte TT FF DVB-S Karte (saa7146). Auch die macht gelegentlich Probleme, wenn ich einen Wiedergabe pausiere. Im Log:

    Code
    1. irq 16: nobody cared (try booting with the "irqpoll" option)
    2. ...
    3. saa7146: saa7146 (0) saa7146_i2c_writeout [irq]: timed out waiting for end of xfer

    VDR-OSD ist dann nur sehr träge zu bedienen, ein Reboot ist notwendig. Das nur nebenbei, werde hierzu ggf. noch einen eigenen Thread öffnen.


    Mittlerweile geht mir das aktuelle VDR-System ganz schön auf die Nerven:§$%Alle Karten sind doch schon seit Ewigkeiten auf dem Markt, da sollten die Treiber doch ausgereift sein...


    Ich frage mich bzw. euch, welchen Kernel bzw. Treiber man am besten verwenden soll.


    Gruß,

    Andreas

  • Hi,

    Na ja die SD FF war immer etwas problematisch. Daher gab es ja mehrere Hardware Mods (4MB,TS Mod)...


    Evtl neuere Firmware für die FF nutzen...


    Modden...


    Oder wie alle anderen seit Jahren auch auf Nvidia umsteigen...


    Warum ein solches Exoten System wie Gentoo? Nutzt mit VDR seit Jahren keiner so weit ich weiß...


    Teste mit der Hardware mal die EasyVDR3.5.

    Live-DVd geht wohl auch...


    Was ist in grub eingestellt?

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Hallo Stefan,


    danke für Deine Antwort!

    Die TT SD FF läuft hier seit ca. 15 Jahren problemlos. Das "irq 16: nobody cared"-Problem hat erst jetzt mit den neuen 64bit Kernels angefangen. Firmware ist für alle Karten aktuell.

    Oder wie alle anderen seit Jahren auch auf Nvidia umsteigen...


    Warum ein solches Exoten System wie Gentoo? Nutzt mit VDR seit Jahren keiner so weit ich weiß...

    Ich nutze Gentoo auf allen meinen Systemen. Warum sollte ich das nicht auch für den VDR nutzen?

    Klar, ist etwas mehr Handarbeit, machte aber die letzten gut 15 Jahre keine Probleme.

    Teste mit der Hardware mal die EasyVDR3.5.

    Live-DVd geht wohl auch...

    Werde ich mal versuchen.

    Was ist in grub eingestellt?

    Du meinst die Kernel Cmdline? Nichts besonderes:

    Code
    1. BOOT_IMAGE=/boot/vmlinuz-4.14.8-gentoo-r1 root=/dev/sda2 ro quiet net.ifnames=0 rootfstype=ext4

    Gruß,

    Andreas

  • Hi,

    Musste da nicht directisa und so was rein?

    Geht es denn mit nem 4.4?

    Nimm doch erst mal dieselbe Kernelversion wie bei 32bit...

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Hallo Stefan,

    Hi,

    Musste da nicht directisa und so was rein?

    Geht es denn mit nem 4.4?

    Nimm doch erst mal dieselbe Kernelversion wie bei 32bit...

    MfG Stefan


    "directisa" sagt mir nichts, hatte ich noch nie gesetzt.

    Die Idee mit dem 4.4er Kernel ist nicht schlecht. Werde ich mal versuchen (ich hoffe LIRC treibt mich dann nicht wieder in den Wahnsinn, nachdem es jetzt wieder gut läuft...)


    Schön wäre es, wenn jemand der die TT S2-4200 bzw. die DVBSky S952 v3(!!!) im Einsatz hat, die "lost lock" Probleme auch hat.


    Gruß,

    Andreas

  • Hi,

    Mit der Dvbsky gibt es bei easyVDR positive Berichte.

    Aber halt 4.4 oder 3.19. Und ja das ist das alte Lirc.

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Habe die DVBSky 952 V3 und TT-4200 auf einem 64 Bit Kernel 4.14.10 (die aktuellen Patche... warten wir noch etwas) problemfrei im Einsatz. Eigentlich laufen die, seit die Treiber im Kernel sind, stabil.


    Eventuell ist eher das LNB tot / braucht zuviel Stom? Dann löst die Polyfuse aus... Lost Lock...


    Stefan


  • Ich habe sogar die Kombination mit der FF-Karte auf einem 64 Bit Kernel im Einsatz (Sig.).

    Bei der DVBSky ist momentan die v2 drin. Die v3 hatte bei mit etwas weniger Schlechtwetterreserve, lief aber auch problemlos.

    Sehr selten hab ich mal einen Fehler in den Aufnahmen feststellen können, ausser bei Unwetter und so.

    Es könnte aber sein, dass es einen Bereich gibt, wo die v2 noch läuft, die v3 aber schon Macken macht.

    Angeblich soll das Treiberpaket bei schlechtem Signal besser sein als der Kerneltreiber (ich hab letzteren aber noch nicht probiert).

    Bei der DVBSky gibt es unterschiedliche Firmware für den Kerneltreiber und für das Treiberpaket. Ich weiss aber nicht, ob die austauschbar sind.


    Der Stromstecker bei der DVBSky ist aber sicher drauf?

    Code
    1. irq 16: nobody cared (try booting with the "irqpoll" option)

    Das klingt mir nach üblerem.

    Hängt die FF denn überhaupt an irq 16?

    Was hast du denn für ein Mainboard?

    Und was ist da für eine PCI-Bridge verbaut?

    Gruss
    SHF


  • Hallo Stefan,

    Hi,

    Mit der Dvbsky gibt es bei easyVDR positive Berichte.

    Aber halt 4.4 oder 3.19. Und ja das ist das alte Lirc.

    MfG Stefan

    beziehen Sie diese positiven Reports auch auf die S952 v3?

    Ich hatte vorher die S952 v2 jahrelang problemlos im Einsatz mit Kernel 3.1x (x müsste 9 sein, könnte aber auch 7 sein). Leider funktioniert diese nicht mehr korrekt mit Kernel 4.12 oder 4.14. Fand mit Google mehrere, die auch mein Problem (Absturz beim Treiberladen nach Reboot) hatten. Deshalb holte ich mir die v3, die zwar meist zufriedenstellend funktioniert, aber dann doch wieder Aufnahmen zerstört.


    Gruß

    ANdreas

  • Hallo Fourty2,

    Habe die DVBSky 952 V3 und TT-4200 auf einem 64 Bit Kernel 4.14.10 (die aktuellen Patche... warten wir noch etwas) problemfrei im Einsatz. Eigentlich laufen die, seit die Treiber im Kernel sind, stabil.

    Das macht Mut!

    Was meinst Du mit "die aktuellen Patche... warten wir noch etwas"?

    Nutzt Du einen Vanilla-Kernel oder ist der gepatcht?

    Eventuell ist eher das LNB tot / braucht zuviel Stom? Dann löst die Polyfuse aus... Lost Lock...


    Stefan

    Das ist ein Punkt, an den ich noch nicht gedacht habe. Zuviel Strom denke ich nicht, da die Stromversorgung nicht von den DVB-Karten erledigt wird, sondern von der Stromversorgung am Multiswitch. Ob der LNB kaputt ist, kann ich nicht sagen, aber es wäre schon Zufall, dass er beim Wechsel der DVB-Karte kaputt geht.


    Gruß

    Andreas

  • Hi amair,

    Ich schrieb über Berichte mit 4.4 oder 3.19.

    Mit neueren gibt es bei uns kaum Erfahrung, da wir die nicht offiziell ausliefern...

    Dvbsky muss, wie ich selbst festgestellt hatte, aber nicht gleich dvbsky sein (selber Händler liefert 2 Wochen später andere Platinenfarbe mit deutlich besserem Empfang aus).

    Bin von denen daher nicht uneingeschränkt angetan...

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Hallo SHF,

    Ich habe sogar die Kombination mit der FF-Karte auf einem 64 Bit Kernel im Einsatz (Sig.).

    Bei der DVBSky ist momentan die v2 drin. Die v3 hatte bei mit etwas weniger Schlechtwetterreserve, lief aber auch problemlos.

    Sehr selten hab ich mal einen Fehler in den Aufnahmen feststellen können, ausser bei Unwetter und so.

    Es könnte aber sein, dass es einen Bereich gibt, wo die v2 noch läuft, die v3 aber schon Macken macht.

    Angeblich soll das Treiberpaket bei schlechtem Signal besser sein als der Kerneltreiber (ich hab letzteren aber noch nicht probiert).

    danke für diese Info! Ich denke, ich werde mal das Treiberpaket versuchen.

    Bei der DVBSky gibt es unterschiedliche Firmware für den Kerneltreiber und für das Treiberpaket. Ich weiss aber nicht, ob die austauschbar sind.

    Firmware habe ich immer von DVBSky heruntergeladen. Ist mir noch gar nicht aufgefallen, dass es für den Kernel andere gibt.

    Der Stromstecker bei der DVBSky ist aber sicher drauf?

    Werde ich mal prüfen. Danke für den Hinweis!

    Code
    1. irq 16: nobody cared (try booting with the "irqpoll" option)

    Das klingt mir nach üblerem.

    Hängt die FF denn überhaupt an irq 16?

    Was hast du denn für ein Mainboard?

    Und was ist da für eine PCI-Bridge verbaut?

    Ob die FF an IRQ 16 hängt habe ich noch nicht geprüft, aber ich hatte zweimal nach dem Pausieren einer Aufnahme das Problem, dass der VDR extremst langsam zu bedienen war, v.a. das OSD reagierte sehr träge. Im Log fand ich dann diese Meldung. Mothergboard ist ein ASUS P8H61-M Rev 3.0, PCI-Bridge müsste ASMedia ASM1083 sein.


    Gruß

    Andreas

  • Hallo SurfaceCleanerZ,

    was würdest Du dann kostengünstiges empfehlen?


    Gruß

    Andreas

  • Hallo amair,


    ich habe die DVBSky S952 V3:


    SMI PCIe driver 0000:05:00.0: card detected: DVBSky S952 V3

    m88ds3103 9-0069: found a 'Montage Technology M88DS3103' in cold state

    m88ds3103 9-0069: downloading firmware from file 'dvb-demod-m88rs6000.fw'

    m88ds3103 9-0069: found a 'Montage Technology M88DS3103' in warm state

    m88ds3103 9-0069: firmware version: 4.1

    m88ds3103 10-0069: found a 'Montage Technology M88DS3103' in cold state

    m88ds3103 10-0069: downloading firmware from file 'dvb-demod-m88rs6000.fw'

    m88ds3103 10-0069: found a 'Montage Technology M88DS3103' in warm state

    m88ds3103 10-0069: firmware version: 4.1


    hier auch seit einiger Zeit im Einsatz. Seit Kernel 3.19 wird sie auch direkt unterstützt.

    Ich hatte anfangs auch sehr oft solche Meldungen im Log:


    frontend X/0 lost lock on channel YZ

    frontend X/0 regained lock on channel YX


    Im Prinzip lag das an zu wenig Pegel auf den Sat-Leitungen.

    Da ich hier in einem Mietshaus wohne und keinen Einfluß auf die Sat-Anlage habe, habe ich mir dann Leitungsverstärker 16-20dB besorgt und die in meine Leitungen eingebaut. Das brachte schon erhebliche Verbesserungen.

    Außerdem konnte ich dann noch erreichen, das die Sat-Anlage überholt wurde (neues LNB, neuer Multischalter).

    Seitdem sind die Pegel deutlich höher. Da ich hier auch noch "device-bonding" nutze und deshalb noch Verteiler habe, habe ich die Leitungsverstärker auch nach der Modernisierung in den Zuleitungen gelassen.

    Die oben genannten Meldungen habe ich seitdem nicht mehr (Sender inkl. Sky, aber kein HD+).


    Zumindest wäre das mal einen Versuch wert um Pegelprobleme auszuschließen. Die Dinger sind ja auch nicht so teuer, bevor man jezzt in neue DVB-Karten investiert.


    Insgesamt läuft diese Karte jetzt bei mir doch recht stabil.


    Gruß

    kamel5

    VDR 2.4.0: ASUS M5A97 PRO, FX6100, 16GB, 2TB HD, GT630, Fedora 28 Kernel 4.18 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3

  • Hi,

    Das wäre denkbar. Mit Zwischenverstärker teste ich auch heute Abend. Nutze aber TT 3200 auch mit T-Stück dank Mietwohnung.

    Du solltest einen einstellbaren Verstärker eines Markenherstellers nehmen. Ich berichte...

    Hast du auch Verpixelung/Blockartefakte? Die hab ich nämlich mit 2 Karten an dem Kabel.

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Hi,


    Verpixelung/Blockartefakte habe ich mit der Karte jetzt nicht mehr, auch alle Aufnahmen sind in der Regel in Ordnung. Die einzigen Probleme die hin und wieder mal auftreten sind Bildfehler, wenn ich den VDR zu Testzwecken viele Male hintereinander neu starte ohne den Treiber neu zu laden.


    Verpixelung/Blockartefakte habe ich mit meiner 2.ten Karte hin und wieder, das liegt aber eindeutig an der Zuleitung. Wenn ich die Kabel zwischen den Karten tausche wechseln auch die Bildfehler. Da das aber nur sehr sporadisch auftritt, mal tagelang nicht und dann wieder alle paar Sekunden, können das durchaus auch externe Störungen sein. Da bin ich noch dran.


    Einstellbare Verstärker sind auch eine Möglichkeiten, allerdings hatte ich noch nie Probleme mit zu hohen Pegeln.

    Eine Zeit lang, als die Anlage noch schlecht war, hatte ich sogar mal 2 Leitungsverstärker hintereinander in den Leitungen, das ging auch ganz gut.


    Gruß

    VDR 2.4.0: ASUS M5A97 PRO, FX6100, 16GB, 2TB HD, GT630, Fedora 28 Kernel 4.18 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3

  • PCI-Bridge müsste ASMedia ASM1083 sein.

    Bei der Fehlermeldung hätte ich wetten sollen ...

    Ich drücke die Daumen, dass es ein rev 03 oder neuer ist.

    ASM1083 PCI Bridge fehlerhaft. Betrifft viele ASUS, ASROCK und MSI Mainboards!

    Gruss
    SHF