Digital Devices MAXS8 unter ESX6.5

  • Hallo und erstmal PROST 2018!


    Neues Jahr und mich ärgert meine MAX S8 weiter.


    Ich habe eine mystique satix via PCI passthrough unter esx auf einem Ubuntu 16.04 via ngene Modul auf meinem Supermicro X9scl-f nun schon seit ein paar Monaten stabil am laufen. Davor war es unter XEN auch kein Thema. Da aber mittlerweile die Anzahl der libreelec clients zunimmt sind mir zwei Tuner mittlerweile zu wenig. Deshalb stand ich vor der Frage ob CineS2 mit duoflex Erweiterungen oder die MAXS8. Preislich gab's keine Frage, also die MAXS8 zu meinem Weihnatsgeschenk auserkoren und bestellt und damit begannen die Probleme. Die vom also auf Kernel 4.14.10 gehoben und Karte in den selben slot eingebaut wo die satix war. Rebootet und der vm die Karte durchgereicht. Und siehe da: i2c error. Karte ist immer da aber die frontends tauchen wegen der i2c error nicht auf. Gut vm wieder via snapshot retour dann die treiber von digital Devices direkt probiert und damit dasselbe Problem.


    Gut ich habe jetzt folgende varianten:

    1.) Karte in anderem Slot

    2.) BIOS Update

    3.) jegliche Pci-e settings im BIOS bin ich schon durch....

    4.) bare metal


    Jetzt bin ich beim überfliegen des motherboard Manual auf zwei jumper gestoßen. PCI SLOT SMB enable. Laut Beschreibung:

    Use jumpers I2C1/I2C2 to enable PCI SMB (System Management Bus) support to improve system management for the PCI slots. Default is disabled. See the table on the right for jumper setting.


    Da ich derzeit aber in Urlaub bin weiß jemand ob diese jumper bei meinem Problem helfen könnten?


    Danke und LG

    Herby

  • Hast du die ddbridge.conf mit dem Parameter „msi=0“ erstellt?


    Das wird ziemlich weit unten beschrieben:


    http://support.digital-devices…ledgebase.php?article=151


    Gruß Hoppel

    frontend software - android tv | libreelec | windows 10 | kodi krypton | emby for kodi | vnsi
    frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
    -------------------------------------------
    backend software - proxmox | openmediavault | debian jessie | kernel 4.4lts | zfs | emby | vdr | vnsi | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | raid-z2 | digital devices max s8

  • Hi,


    ja habe ich. Mit oder ohne ist dem i2c egal. Habe irgendwo einen Thread gefunden wo die Frontends nur nach ca. 10-minütigem stromlos machen des PC's erkannt werden. Und ja dass ist bei mir gleich. Wenn der PC ca. 10 Minuten vom Strom ist und ich den Host wie auch die VM hochfahre habe ich die frontends. Nach einem reboot ist wieder alles das selbe.


    Hatte aber schon gehofft, dass die Karte in meinem SLOT4 funktioniert wie bei dir, denn auch bei mir ist wie bei der der SLOT4 nicht direkt an die CPU sondern an den PCH angebunden, aber dies geht bei mir leider auch nicht,.... Ich habe jetzt die Karte in allen 3 PCI-E Slots durch und nirgend funktioniert sie.


    Punkt 1 & 3 habe ich mal durch und es geht nicht. Werde jetzt noch die beiden Jumper (jumpers I2C1/I2C2 to enable PCI SMB) probieren.


    lg

    Herby

  • Hi,


    gerade probiert, leider das selbe in lichtblau.... Egal ob in kombination mit pci=nomsi und pci=noaer oder jeweils alleine, Frontends werden nicht gefunden.


    Vielleicht hat ja noch jemand einen Einfall....


    lg

    Herby

  • Meine maxs8 läuft auch immer noch bare metal. Mittlerweile mit Debian Stretch (Openmediavault4)


    Wollte mich aber demnächst auch nochmal dran setzen und alles virtualisieren, so wie es vor der maxs8 bereits schon mit meiner cines2 v6.5 war und einwandfrei lief. Als Hypervisor setze ich allerdings Proxmox mit KVM und LXC ein.


    Bare metal läuft die Karte bei mir tadellos. Ich nutze aber immer noch Kernel 4.9 und ddbridge 0.9.28. Das lief unter Debian Jessie schon einwandfrei und scheint jetzt mit Stretch auch wieder zu laufen.


    Heute wurde in den Stretch Backports Kernel 4.14.7-1~bpo9+1 veröffentlicht. Den werde ich vor der Virtualisierung auf jeden Fall noch ein paar Wochen betreiben und testen. Wenn ich es richtig verstanden habe, müsste dieser Kernel nun die maxs8 ohne irgendwelche manuellen Treiberinstallationen zum Laufen bringen.


    Habe keine Lust mehr auf ewiges Rätzelraten, ob Probleme mit der Virtualisierung zusammenhängen. Bevor ich nicht weiß, dass es bare metal läuft, wird nicht virtualisiert.


    Ich empfehle dir also auch erstmal deinen Punkt 4 umzusetzen.


    Für BIOS-Updates habe ich mir übrigens nochmal eine Extra-Lizenz für mein IPMI geholt. Damit habe ich mittlerweile schon 2 BIOS-Updates erfolgreich durchgeführt. Evtl. gibt‘s sowas auch für die x9-er Serie von Supermicro.


    Halt uns mal auf dem Laufenden.


    Gruß Hoppel

    frontend software - android tv | libreelec | windows 10 | kodi krypton | emby for kodi | vnsi
    frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
    -------------------------------------------
    backend software - proxmox | openmediavault | debian jessie | kernel 4.4lts | zfs | emby | vdr | vnsi | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | raid-z2 | digital devices max s8

  • Hi,


    @hoppel: Ich vermute eher das Problem nicht an der Virtualisierung sondern am Zusammenspiel der DD mit dem Supermicro, da ich auch mit der Mystique mit den LatencyTimern spielen mußte. Ja BareMetal und Z99 Extreme 3 Board sind meine nächsten schritte,....


    9000H : Firmware ist die aktuellste. ;-(


    lg

    Herby

  • Hi,


    ein sehr guter Kumpel, mit dem ich zusammen einen Server aufgebaut habe, hatte auch schon damals Probleme mit der Mystique gehabt und ist (leider) den selben Weg gegangen und hat sich eine S8 zugelegt weil er meinte dann wird's besser. Mit den Latencys haben wir auch ewig rumgespielt bis es irgendwie lief. Aber selbst BareMetal war das ehr schlecht als recht...


    Er hatte zwar ein X9SCA-F von Supermicro, welches fast das selbe Board ist nur mit anderen NICs, wir haben es aber nach endlosen verkonfigurierten Nächten irgendwann rausgeworfen. Die Boards sind gut, keine Frage, aber alles andere wie kompatibel zu Sat-Karten - hier im Forum habe ich auch schon viel von Supermicro und Sat-Karten gelesen.


    Natürlich ist das nicht so richtig die Lösung einfach Board umbauen und gut ist - aber manchmal geht's nicht anders...


    Wir haben dann ein Z87-G43 von MSI verbaut - das Teil rennt rockstable und das habe ich hier auch im Server.

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Hi,


    so jetzt ein kleines Update. Karte läuft auch mit meinem Z68 Extreme 3 von Asrock und ESX 6.5 überhaupt nicht. Habe dann wieder openmediavault gebootet, da dieses Board sowieso das Datengrab bedient und dann direkt unter openmediavault mit 4.9 Debian Kernel die Treiber für die MAX S8, VDR und die Plugins gebaut, und siehe da, läuft jetzt mal 3h ohne Probleme,...


    Digital Devices MAX S8:

    1.) Supermicro X9SCL-F mit ESX => funktioniert nicht > i2c timeouts

    2.) AsRock Z68 Extreme 3 mit ESX => funktioniert nicht > i2c timeouts

    3.) AsRock Z68 Extreme 3 BareMetal => funktioniert


    Mystique Satix V5.0:

    1.) Supermicro X9SCL-F mit ESX => funktioniert

    2.) AsRock Z68 Extreme 3 mit ESX => funktioniert

    3.) AsRock Z68 Extreme 3 BareMetal=> funktioniert


    Ist jetzt zwar nicht mein Zielsetup aber da ich die StorageBox sowieso getrennt vom ESX-Server betreibe muss ich eben damit leben,....


    Problem dürfte also wirklich an ESX passthrough mit der MAX S8 Karte liegen,....


    Noch jemand Ideen? Ich bin kurz davor mir ein TYAN Board zu holen, aber ob dass besser mit der MAX S8 ist, als das Supermicro?


    g3joker : Bin nicht wegen Unzufriedenheit von der Mystique zur Max gekommen, sondern weil mir die Tuner ausgingen,.... Und die Mystique eben nicht erweitert werden kann,.... Bei mir läuft die Mystique weiterhin parallel zur Max, somit habe ich 10 Tuner, ich glaube dass sollte mal reichen,... ;-)


    lg

    Herby

  • Kann mir nicht vorstellen, dass du mit dem Tyan glücklich wirst. Das ist doch im Endeffekt dasselbe wie Supermicro. Versuchen kann man es natürlich.


    Welche Hardware-Revision ist deine MaxS8? Bei mir läuft eine v1.2. Das steht unten am Flügel neben den PCIe-Kontakten, siehe auch folgenden Beitrag unter „Die Erkenntnisse“:


    [ERFOLGREICH GELÖST] Digital Devices Max S8 und Supermicro X11SSH-CTF - ein paar generelle Fragen


    Gruß Hoppel

    frontend software - android tv | libreelec | windows 10 | kodi krypton | emby for kodi | vnsi
    frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
    -------------------------------------------
    backend software - proxmox | openmediavault | debian jessie | kernel 4.4lts | zfs | emby | vdr | vnsi | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | raid-z2 | digital devices max s8

  • Die Beiträge bezüglich Supermicro und Asrock in der Digital Devices Wissensdatenbank hattest du gesehen?


    http://www.digital-devices.eu/shop/de/wissensdatenbank


    Gruß Hoppel

    frontend software - android tv | libreelec | windows 10 | kodi krypton | emby for kodi | vnsi
    frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
    -------------------------------------------
    backend software - proxmox | openmediavault | debian jessie | kernel 4.4lts | zfs | emby | vdr | vnsi | fhem
    backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | raid-z2 | digital devices max s8

  • Hi Hoppel,


    ja danke die Einstellungen hatte ich schon alle probiert,..... Ich lass die Karte mal Baremetal laufen,.... Habe auch die v1.2.


    Irgendwann muss ich eh meinen ESX-Host tauschen, und dann muss ich mir eben was überlegen,....


    lg

    Herby

  • Du kannst noch ESXi 6.5 passthrough Einstellungen überprüfen (VM option):




    Ich habe hier eine VMware 6.5 L4M V6.2 passthrough im Laufen. Treiber habe ich von DD direkt, hier habe ich ein paar Problemen beschrieben, leider keinen Antwort erhalten, jedoch es läuft.

  • Hallo,


    so nachdem es mir jetzt gereicht hat, und ich für den VDR nicht immer einen eigen PC laufen lassen wollte habe ich jetzt Xenserver 7.5 installiert. Und siehe da. Die Karte läuft mit 7.5 auch in einer domU. Allerdings muss ich dazusagen, ich habe auch 18.04 als Betriebssystem in der virtuellen Maschine verwendet. Und da sind ja auch nochmals andere Treiber dabei als wie die die es damals mit 16.04 gab,...


    Nur als kleine Info für andere. MaxS8 und Supermicro X9SCL-F mit Xenserver 7.5 und unter Ubuntu 18.04 läuft die Karte!


    lg

    Herby