0.6.1 Installation: Kein Netzwerk, keine Tastatur nach 1. Boot

  • Wie hast Du denn Deinen USB-Stick mit yavdr präpariert?

    Manchmal klappt dann eine Installation nicht richtig.

    Beste Variante wie hier oft beschrieben ist mit dd. Ich benutze rufus für meine USB-Sticks.


    Markus

    Gute Frage.


    Ich habe das ISO mit "LinuxLive USB Creator" auf den USB Stick gebrannt.


    Das Dateisystem ist FAT2.


    Das LogFile der Installation habe ich im ersten Threadbeitrag verlinkt. Kann man dort sehen ob was schiefgelaufen ist? Wonach müsste man suchen?

    VDR2012:

    • Coolermaster Caviar4 Gehäuse, 5'' VGA TFT gooddisplay.com, Wasserkühl-Set "Magicool DIY" + Wasserkühler GraKa, PicoPSU 160XT + 150W ext. Netzteil
    • Asrock DZ68 extreme3, Core i5 2500T (<45W), ASUS NVIDEA GT520 Wakü-Mod, HD1: Samsung 64GB SSD, HD2: WD CaviarGreen 1TB, DVD Sony AD-7283S
    • Fernbed.: Philips SRU6008, CIR Empfänger mit TSOP1838, Keyboard/Mousepad Logitech K400
    • SAT: DD Cine 2xS2, DD DuoFlex 2xS2, Inverto Einkabel Multischalter 1/4/1
    • SW: yaVDR4, graphTFT
  • Kann ich Dir nicht genau sagen, gibt aber hier genug Threads zum Thema yavdr und USB-Stick-Erstellung.

    Klappt nicht mit jedem Programm zufriedenstellend.

    Wie gesagt dd ist die zuverlässigste Methode.

    Schau Dir mal diesen Thread an 0.6.0 USB-Installation [gelöst => "dd" verwenden!]

  • Der LinuxLive USB Creator ist wie der Name schon sagt vor allem für Live-Medien gedacht - du musst sicherstellen, dass das ISO 1:1 auf den USB-Stick geschrieben wird. Soweit ich weiß können das z.B. rufus und der Win32 Disk Imager.


    Was sonst noch als funktionierende Möglichkeit bleibt (das habe ich hier gerade ausprobiert) ist ein normales Ubuntu Server 14.04 ISO zu nehmen (wie z.B. http://releases.ubuntu.com/14.…-14.04.5-server-amd64.iso von http://releases.ubuntu.com/14.04/ - da stehen auch die Checksummen) und dann den preseed für die unstable-PPAs (vdr-portal.de/index.php?attachment/41535/) von einem HTTP-Server zu laden.


    Mit Python 2 (oder 3) kann man bei Bedarf schnell einen rudimentären Webserver für das aktuelle Verzeichnis aufsetzen:

    python2 -m SimpleHTTPServer 8000 bzw. python3 -m http.server 8000

    Im Boot-Menü des Ubuntu Server Image drückt man dann F6 ESC ESC, um die Boot-Optionen bearbeiten zu können und dort tauscht man das file=[...]/ubuntu-server.seed Argument durch url=http://Server-IP:8000/yavdr.seed aus.


    Ich schaue mir die Paketquellen für stable und testing noch mal genauer an, wenn man auf Launchpad wieder Pakete bauen kann.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Für die stable PPAs funktioniert diese seed-Datei: https://github.com/seahawk1986…/master/yavdr-stable.seed

    Das Problem ist anscheinend, dass der Installer sich für das virtuelle Paket libegl1-x11 für keine der Kandidaten entscheiden kann - wenn man ihm explizit sagt, dass es libegl1-mesa sein soll, läuft er durch.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Vielen vielen Dank für die Tipps!


    An den USB Stick habe ich gar nicht gedacht, er hat ja anstandslos gebootet.


    Habe das Image jetzt mit rufus im dd mode geschrieben und installiere gerade ... Netzwerk nach NTP timesync gezogen und bei GRUB Konf wieder gesteckt.


    Ich muss ja den ersten boot manuell anstoßen weil die grub.cfg leer ist (wegen dem LILO Kram auf /dev/sdb).

    Dringende Frage: Muss ich bei grub was besonderes beachten, also dem Kernel für den initialen Start von yaVDR6 besondere Parameter mitgeben???



    Plan-B wäre also ein Ubuntu Server. Ich verstehe aber nicht, wann ich F6-ES-ESC für die seed-Datei drücken soll. Beim aller-aller-ersten Bildschirm des Ubuntu-Installers (Sprachauswahl)??

    VDR2012:

    • Coolermaster Caviar4 Gehäuse, 5'' VGA TFT gooddisplay.com, Wasserkühl-Set "Magicool DIY" + Wasserkühler GraKa, PicoPSU 160XT + 150W ext. Netzteil
    • Asrock DZ68 extreme3, Core i5 2500T (<45W), ASUS NVIDEA GT520 Wakü-Mod, HD1: Samsung 64GB SSD, HD2: WD CaviarGreen 1TB, DVD Sony AD-7283S
    • Fernbed.: Philips SRU6008, CIR Empfänger mit TSOP1838, Keyboard/Mousepad Logitech K400
    • SAT: DD Cine 2xS2, DD DuoFlex 2xS2, Inverto Einkabel Multischalter 1/4/1
    • SW: yaVDR4, graphTFT

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von schrauber ()

  • Also, leider, der USB-Stick und LinuxLiveCreator waren nicht das Problem.


    Auch beim neuen, wie vorgeschlagen mit Rufus erzeugten VDR Image, fehlt nachher auf der Platte fast alles in /lib/modules:

    Keine HID Module, keine Maus, keine Tastatur, kein Netzwerk, kein usbkeyboard, kein Logitech. Nur die dkms-updates werden brav erzeugt ...


    Ich gebe es jetzt auf mit dem yaVDR6.1er ISO.


    Wenn ich mich morgen dazu aufraffen kann, dann versuche ich es ganz von vorne mit dem Ubuntu Server Vorschlag von seahawk.


    Ein normales 14er Ubuntu oder ein 14.04er easyVDR lassen sich ja schließlich auch problemlos installieren.

    VDR2012:

    • Coolermaster Caviar4 Gehäuse, 5'' VGA TFT gooddisplay.com, Wasserkühl-Set "Magicool DIY" + Wasserkühler GraKa, PicoPSU 160XT + 150W ext. Netzteil
    • Asrock DZ68 extreme3, Core i5 2500T (<45W), ASUS NVIDEA GT520 Wakü-Mod, HD1: Samsung 64GB SSD, HD2: WD CaviarGreen 1TB, DVD Sony AD-7283S
    • Fernbed.: Philips SRU6008, CIR Empfänger mit TSOP1838, Keyboard/Mousepad Logitech K400
    • SAT: DD Cine 2xS2, DD DuoFlex 2xS2, Inverto Einkabel Multischalter 1/4/1
    • SW: yaVDR4, graphTFT
  • Hi,

    Dann nimm doch einfach easyvdr 3.5!

    Ist eh aktueller!

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
    VDR5: Gigabyte
    GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
    VDR-User #1068 
    www.easyvdr.de 

  • Mit Hilfe der speziellen "seed" Datei und dem 14.04er-Server ISO hat's jetzt funktioniert.


    Alles da, Tastatur, Netzwerk, Audio, Maus ...


    Während der Installation hatte ich zunächst Zweifel weil ein 4.04er Kernel statt dem 3.13er installiert wurde. Aber der anschließende Boot lief ohne größere Probleme durch. Habe jetzt auch schon Audio und Unicable LNB konfiguriert.


    Vielen Dank vor allem an seahawk, ohne Hilfe hätte ich es aufgegeben ...

    VDR2012:

    • Coolermaster Caviar4 Gehäuse, 5'' VGA TFT gooddisplay.com, Wasserkühl-Set "Magicool DIY" + Wasserkühler GraKa, PicoPSU 160XT + 150W ext. Netzteil
    • Asrock DZ68 extreme3, Core i5 2500T (<45W), ASUS NVIDEA GT520 Wakü-Mod, HD1: Samsung 64GB SSD, HD2: WD CaviarGreen 1TB, DVD Sony AD-7283S
    • Fernbed.: Philips SRU6008, CIR Empfänger mit TSOP1838, Keyboard/Mousepad Logitech K400
    • SAT: DD Cine 2xS2, DD DuoFlex 2xS2, Inverto Einkabel Multischalter 1/4/1
    • SW: yaVDR4, graphTFT
  • Während der Installation hatte ich zunächst Zweifel weil ein 4.04er Kernel statt dem 3.13er installiert wurde.

    Das kannst du beeinflussen, indem du ein anderes Point-Release für das Server-ISO auswählst - die alten Images gibt es hier: http://old-releases.ubuntu.com/releases/14.04.1/

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für den Tipp. Der erste Eindruck ist gut mit dem neuen Kernel.


    Ich muss Audio aber noch von Nvidia auf Pulseaudio umstellen und auch noch das Wakeup testen. Manchmal zeigen sich die Probleme erst wenn man länger damit arbeitet ...


    Aber den aktuellen Thread hier könnte ich jetzt als gelöst markieren...

    VDR2012:

    • Coolermaster Caviar4 Gehäuse, 5'' VGA TFT gooddisplay.com, Wasserkühl-Set "Magicool DIY" + Wasserkühler GraKa, PicoPSU 160XT + 150W ext. Netzteil
    • Asrock DZ68 extreme3, Core i5 2500T (<45W), ASUS NVIDEA GT520 Wakü-Mod, HD1: Samsung 64GB SSD, HD2: WD CaviarGreen 1TB, DVD Sony AD-7283S
    • Fernbed.: Philips SRU6008, CIR Empfänger mit TSOP1838, Keyboard/Mousepad Logitech K400
    • SAT: DD Cine 2xS2, DD DuoFlex 2xS2, Inverto Einkabel Multischalter 1/4/1
    • SW: yaVDR4, graphTFT
  • Nun ja, nvidia ist vermutlich nur über den HDMI-Ausgang zu haben, und wenn ein Fernseher dran hängt, will man dessen Lautsprecher meist nicht hören :)

    Mit Pulsaudio lassen sich die Ausgänge bzw. mehrere Sound"karten" sogar zur Laufzeit umschalten, ggf. auch mehrere simultan betreiben.

    --
    hdvdr: Intel(R) Xeon(R) CPU W3520, 12 GB Ram, Grafik nvidia GeForce GT 430, nvidia-387
    Octopus (ddbridge-6.2) mit 2xDVB-S2 und 2xDVB-C/T Tunern, TT-3200 (SAA7146) mit 1xDVB-S2 + FB,
    System btrfs, apt-btrfs-snapper,+5x1TB Raid5 XFS, yavdr0.6-frodo,

    Kernel 4.14.10-041410 mit DD-S2+C+SAA7146-Support, epgd/tvm/tvsp, vdradmin-am, vdrmanager