[gelöst] video data stream broken bei Aufnahme mit DD DuoFlex C/C2/T/T2/ISDB-T

  • Hallo zusammen,


    versuche unter yavdr 0.6.1 headless mittels w_scan Sender zu finden, es werden aber keine gefunden. Mit dem gleichen Kabel am Fernseher gibt's über 100 Programme.


    Die Duoflex hängt an Port 2 einer Cine 6.5, an der an Port 1 noch eine Duoflex DVB-S2 angeschlossen ist. Dieser Treiber ist installiert: media-build-dkms und die Karte wird offenbar auch erkannt.


    Nachdem ich mittels wirbelsan-Plugin nichts gefunden habe und im Syslog permanent diese Einträge aufgeschlagen sind

    Code
    1. Dec 27 11:55:08 vdr1 vdr: DVB-C 602,000MHz M2 SR6900
    2. Dec 27 11:55:08 vdr1 vdr: [2812] ERROR: no free receiver slot!
    3. Dec 27 11:55:09 vdr1 vdr: DVB-C 602,000MHz M2 SR6875
    4. Dec 27 11:55:09 vdr1 vdr: [2812] ERROR: no free receiver slot!
    5. Dec 27 11:55:10 vdr1 vdr: DVB-C 610,000MHz M2 SR6900
    6. Dec 27 11:55:10 vdr1 vdr: [2812] ERROR: no free receiver slot!
    7. Dec 27 11:55:11 vdr1 vdr: DVB-C 610,000MHz M2 SR6875
    8. Dec 27 11:55:11 vdr1 vdr: [2812] ERROR: no free receiver slot!

    habe ich es probiert per

    Code
    1. w_scan -fc -c DE -t 3 -F > channels.dvb

    Durchlauf endet mit leerer channels.dvb und folgender Meldung:

    Code
    1. ERROR: Sorry - i couldn't get any working frequency/transponder
    2. Nothing to scan!!

    Irgendeine Idee, was ich falsch mache?

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Max Power () aus folgendem Grund: Thema angepasst, war ursprünglich "Keine DVB-C Sender zu finden mit DD Duoflex C/C2/T/T2/ISDB-T"

  • VDR ist während des Scans gestoppt?

    Hast du vor dem Scan mal versucht, das Frontend explizit auf DVB-C umzustellen (dvb-fe-tool)? Eigentlich sollte w_scan das aber selbst umschalten.


    Welche Version von w_scan benutzt du denn?


    Lars.

  • Irgendwas passt da bei Dir nicht:

    Code
    1. $ modinfo ddbridge
    2. version: 0.9.31intermediate-integrated
    3. $ modinfo cxd2841er
    4. author: Sergey Kozlov <serjk@netup.ru>, Abylay Ospan <aospan@netup.ru>
    5. description: Sony CXD2837/38/41/43/54ER DVB-C/C2/T/T2/S/S2 demodulator driver

    Stock-Treiber aus 4.14(.7). w_scan auf 2854er Frontend mit Unitymedia am Antenneneingang:

    Gleiches Ergebnis, wenn die Antenne an der CineCTv6 am STV0367 Demod hängt, dauert nur länger, weil der Demod bzw. der Treiber kein QAM_AUTO unterstützt und daher separat auf QAM64 und QAM256 gescannt wird.

    Server: Gigabyte P35-DS4, Intel Core2Duo E6850, 4GB DDR2-RAM (Headless), Gentoo Linux x86_64 / Kernel 4.16.7 / DD CineCTv6+DuoFlex C/T/T2+DuoFlex C/C2/T/T2 w/Kernel Stock Drivers / TVHeadend-GIT-3356759d8

    HTPC: ASRock J5005-ITX (Intel Pentium Silver J5005, 1.5GHz), 8GB SO-DDR4, Intel UHD Graphics 605 in Antec Fusion Remote Black+SoundGraph iMON LCD ( 0038 ), Kodi v18 Leia
    SW: Kodi Krypton+Leia auf allerlei Gerätchen (HTPC: VAAPI+HD-Audio+LCDproc addon / Ubuntu Bionic 18.04 (x86_64), RPi2, NVIDIA Shield Android TV, Wetek Play 1@LibreELEC/NAND, Tablets, Smartphones, Win/Mac/Linux Desktops)

  • Kernel ist 4.4.0-104-generic (aus HWE Stack Xenial)

  • Hi,

    dann upgrade doch mal auf 4.14, dort ist der Treiber von nst ja drin.


    Denk aber dran, dass du noch mehr upgraden musst:

    s.:

    http://wiki.easy-vdr.de/index.php?title=Kernelupdate_4.8


    Danach muss Lirc noch gefixt werden, da sich da was geändert hat, daher dann erst mal per Keyboard testen!


    Btw hast du in leere Datei gescannt?


    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Ich dachte mit dem o.g. Treiberpaket von Jasmin kriege ich diese Treiber per DKMS?


    Broken Lirc wäre kein Problem, ist ja ein headless Server, aber da dann noch ein weiteres Repo dazu muss und eine neue Version g++ usw. habe ich da jetzt ein wenig Bedenken, dass ich mir dadurch anderweitig Schwierigkeiten einfange. Ich probier's nachher mal aus.


    Die Datei war übrigens leer (vor und nach dem Scan).

  • Mach Backup und teste es!

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easyvdr.de

  • Code
    1. $ uname -r
    2. 4.14.9-041409-generic

    Exakt gleiches Ergebnis wie vorher, sowohl mit wirbelscan als auch mit w_scan.


    Eines ist mir im Syslog noch aufgefallen bei der Suche mit dem wirbelscan-Plugin. Und zwar kommt nach den ersten Frequenzen immer wieder die Fehlermeldung

    Code
    1. ERROR: no free receiver slot!

    Siehe hier:

    So geht das dann durchgängig weiter bis zum Ende des Scanvorgangs. Bei w_scan tritt diese Meldung nicht auf.

  • Ok, jetzt habe ich nochmal das Kabel gewechselt und unter Umgehung des Multischalters direkt an die Kabeldose angeschlossen, damit scheint sich zumindest mal irgendwas zu tun.


    wirbelscan findet mit der Einstellung SDTV + HDTV, nur FTA insgesamt 388 Sender, währenddesssen gibt es im Syslog folgende Einträge:

    Wenn ich dann auf einen dieser Sender schalte sieht das Log sauber aus:

    Code
    1. Dec 29 17:42:51 vdr1 vdr: [4020] switching to channel 1 (SWR RP HD)
    2. Dec 29 17:42:51 vdr1 vdr: [4225] device 6 TS buffer thread ended (pid=4020, tid=4225)
    3. Dec 29 17:42:51 vdr1 vdr: [4224] buffer stats: 0 (0%) used
    4. Dec 29 17:42:51 vdr1 vdr: [4224] device 6 receiver thread ended (pid=4020, tid=4224)
    5. Dec 29 17:42:51 vdr1 vdr: [4226] device 6 receiver thread started (pid=4020, tid=4226, prio=high)
    6. Dec 29 17:42:51 vdr1 vdr: [4227] device 6 TS buffer thread started (pid=4020, tid=4227, prio=high)

    Ich kann auch per streamdev-client auf Port 3000 auf andere Sender schalten und die Wiedergabe klappt per VLC:

    Code
    1. Dec 29 17:44:57 vdr1 vdr: [4073] Streamdev: Accepted new client (HTTP) 192.168.0.104:34990
    2. Dec 29 17:44:57 vdr1 vdr: [4244] streamdev-livestreaming thread started (pid=4020, tid=4244, prio=high)
    3. Dec 29 17:44:57 vdr1 vdr: [4243] streamdev-writer thread started (pid=4020, tid=4243, prio=high)
    4. Dec 29 17:44:57 vdr1 vdr: [4245] device 7 receiver thread started (pid=4020, tid=4245, prio=high)
    5. Dec 29 17:44:57 vdr1 vdr: [4246] device 7 TS buffer thread started (pid=4020, tid=4246, prio=high)

    Wenn ich jedoch versuche eine Aufnahme zu starten, bleiben die ts-Files leer und der vdr steigt nach wenigen Sekunden mit VDSB Error aus:

  • Also BEVOR du dích an einem headless Serverversuchst, solltest du dringend an VDR mit normaler TV Ausgabe zum laufen bewegen.

    Man fängt immer mit dem Einfachen an, bevor man sich zu Höherem aufschwingen will. Und etwas blind (=kein Menue) zu konfigurieren ist definiv schwieriger.


    Außerdem..


    >> Ok, jetzt habe ich nochmal das Kabel gewechselt und unter Umgehung des Multischalters direkt an die Kabeldose angeschlossen


    Äh - willst du jetzt DVB-C oder DVB-S/S2? Bei Kabel-TV (DVB-C) gibt es keine Sat-Multischalter.



    Und ganz sicher willst du weder vdr-2.2.0 noch wirbelscan-0.0.9 mehr verwenden. Upgrade mal auf neuere Versionen.

  • Der Server läuft seit Jahren headless, wie gesagt mit Cine S2 und Duoflex S2. Ich wollte für einen zusätzlichen Empfangsweg DVB-C in die Terrestrik des Multischalters einspeisen, was direkt am Fernseher ja wie beschrieben funktioniert.


    Menü habe ich ja per remote Plugin über tcp.


    Und mit den Versionen bin ich bislang auch zufrieden gewesen, yavdr stable halt. Ich wollte da jetzt nicht mit Versionsupdates zusätzlich Komplexität reinbringen, theoretisch sollte doch vdr 2.2.0 damit kein Problem haben oder? Und wirbelscan hat ja Sender gefunden, die per streamdev funktionieren...

  • wirbelscan Version 0.0.9 verwendet VDRs Interfaces um auf MPEG TS Daten von der DVB Karte zuzugreifen.

    Leider gab es dabei häufig genau die Zugriffsprobleme die du beschreibst. Ich denke es gab deadlocks direkt in VDR beim Benutzen von cReceiver


    Nachfolgende Versionen greifen direkt auf das Kernel Interface der DVB Karten zu und haben das Problem nicht.




    btw. vdr-2.2.0 ist von Februar 2015, jetzt haben wir fast 2018.

  • Hab jetzt mal vdr ohne wirbelscan gestartet, Streaming kein Problem, Aufnehmen führt nach knapp 20 Sekunden zu vdr Restart wg. VDSB Fehlern.


    Könnte es tatsächlich an der alten vdr-Version liegen? Gibt's für yavdr ein Repo mit aktuellen Versionen? Selbst in deren testing und unstable Zweigen ist nichts Neueres als die 2.2.0 enthalten?

  • Hi,


    Gibt's für yavdr ein Repo mit aktuellen Versionen? Selbst in deren testing und unstable Zweigen ist nichts Neueres als die 2.2.0 enthalten?

    testing-vdr-dev aus PPA von Frodo nehmen. ...was noch installiert/eingebunden werden muss

    kann ich dir nicht sagen. Da müsste Einer antworten der dieses PPA nutzt.


    Gruss

    Wolfgang

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von wolfi.m () aus folgendem Grund: edit link

  • Ich habe jetzt Frodos PPA eingebunden und bin auf vdr 2.3.8. Verhalten ist nach wie vor unverändert: Streaming funktioniert, Aufnahme mit der Duoflex C/C2/T/T2/ISDB-T führt nach etwa 20 Sekunden zu video data stream broken Fehler und emergency exit. Aufnehmen per DVB-S2 klappt problemlos.


    Ich habe dann, ausgehend von hier: [VDR 2.3.8] Timer-Aufnahme unterbrochen und läuft dann endlos weiter wirbelscan, streamdev und vnsiserver deaktiviert, keine Änderung des Verhaltens (also VDSB Error bei Aufnahme, Streaming wg. inaktivem streamdev geht natürlich dann auch nicht).


    Was kann ich noch prüfen?

  • Na ja, du bist jetzt bei den Themen Hardware + DVB angekommen und kannst diese schrittweise abarbeiten


    - Kernel + Treiber + Firmware (braucht die spezielle Karte Firmware - keine Ahnung..)

    - Antennenkabel (wie lang ist das Kabel, wie viele Splitter (hoffentlich nicht mehr als einer), sind alle Stecker 100% i.o. verarbeitet?)

    - Kernel sleep states (bios/uefi + kernel config)

    - möglicherweise PCI(e) Probleme

  • Probier mal einen Verstärker aus.

    Ich hatte selber mit Cine. DVB C Karten schlechten Empfang und Klötzchen gehabt, bis ich sowas dazwischengeschaltet habe:

    https://www.amazon.de/gp/aw/d/…er%C3%A4teverst%C3%A4rker


    Gibt es auch mit mehr als 2 Anschlüssen.

    VDR- Server: Gigabyte Brix 3150 - (2x Sunteck DVB-C) - jessey - Aufnahme und Streaming-Server (12Watt unter Last)
    Client Wohnzimmer: DQ77KB - i3 - Logitech z-5500 - Blaupunkt 39" TV - Openelec (Streaming)
    Client Büro: Asus AT3N7A-I , yaVDR0.6.1 (Streaming + Cutting) - 19" TFT
    Test Client1: Raspberry Pi & openelec

  • Es funktioniert jetzt. Ausschlaggebend war letzten Endes dann, dass am Mulitischalter die Verstärkung für das terrestrische Signal offenbar zu groß war und die Karte damit scheinbar ein Problem hatte. Ich habe es dann deutlich runtergeregelt und seitdem läuft es.


    Warum das nur bei Aufzeichnungen aufgetreten ist und nicht beim Streaming; und warum es auch nicht funktioniert hat, als ich ohne Multischalter direkt von der Multimediadose abgegriffen habe (da hängt auch die Vodafone Kabel Fritzbox dran mit stabilen 100 MBit down und der Fernseher tat dort mit gleichem, vorkonfektioniertem kurzen Kabel problemlos; davor sitzt noch ein Vodafone eigener Breitband-Verstärker) verstehe ich nicht, aber sei's drum. Genug probiert.


    DVB-T2 hatte ich zwischenzeitlich auch probiert, da ging direkt Streaming UND Aufzeichnen von Anfang an, auch in H.265. Da war dann klar, dass entweder die DVB-C Komponente der Karte einen Hau haben muss oder was mit dem Signal nicht stimmt.


    Ich bin jetzt mit Frodos Paketen auf vdr 2.3.8 mit erneuerten Plugins, Xenial LTE Kernel (4.4) und dem media-build-dkms von Jasmin. Kernel 4.14 aus dem Mainline PPA lief nicht stabil bei mir (musste mit noapic booten und der VGA Ausgang der NVidia Karte lieferte eine kaum bedienbare Konsolengrafik mit verschobenen Zeilen und senkrechten bunten Streifen).