softhddevice - Sender in 1920x1090 - VDR startet neu

  • Hallo Zusammen,


    einige spanische Sender senden wohl in der krummen Auflösung 1920x1090. :(

    Beim Umschalten auf einen solchen Sender sehe ich kurz ein Bild mit vertikalen Streifen in der untern Bildhälfte, danach startet der VDR neu.

    Log:



    vdr -V



    Über streamdev + VLC funktioniert der Sender einwandfrei, daher vermute ich, dass das softhddevice Plugin den Crash verursacht. VLC zeigt die krumme Auflösung an:



    Ich benutze zur Ausgabe

    Code
    1. vdr-plugin-softhddevice-vpp-hevc 0.6.1rc1+git20170121-rofa-4yavdr1~trusty amd64 Plugin for VDR. A software and GPU emulated HD device



    Über Tipps zum weiteren Debuggen würde ich mich freuen! :)



    Edit:

    Habe ein bisschen gegoogelt, wie man gdb benutzt, hier ein BT:

  • Wenn ich von der größer als FullHD-Auflösung lese, dann fällt mir ein, dass der Speicher für OSD in softhddevice eine Grenze hat. Stell das OSD in softhddevice mal fest auf 1920x1080.


    Lars

  • Bei mir tritt dieser Fehler bei BBC 1 HD mit softhddevice auf.

    KODI kann BBC 1 HD.


    softhddevice wird halt nicht mehr weiterentwickelt :( .

    VDR1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 18.04, VDR 2.4x
    VDR2: ASUS P4B533, Celeron 2.4G, FF 1.5, Ubuntu 10.10, VDR 1.6 (SS2 Rev 2.6B)
    VDR Server: sheeva-plug

  • Das Paket aus dem Fork von jojo61 ist als vdr-plugin-softhddevice-hevc in ppa:yavdr/experimental-vdr enthalten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hier nochmal ein aktuelles Backtrace gdb-vdr.txt, von yavdr-ansible, mit


    Code
    1. $ apt-cache policy vdr-plugin-softhddevice-hevc
    2. vdr-plugin-softhddevice-hevc:
    3. Installiert: 0.6.1rc1+git20180526-b546a0a-1yavdr0~bionic
    4. Installationskandidat: 0.6.1rc1+git20180526-b546a0a-1yavdr0~bionic
    5. Versionstabelle:
    6. *** 0.6.1rc1+git20180526-b546a0a-1yavdr0~bionic 500
    7. 500 http://ppa.launchpad.net/yavdr/experimental-vdr/ubuntu bionic/main amd64 Packages
    8. 100 /var/lib/dpkg/status



    @Inj

    I cloned your fork and tried to build it, see output from make at attached make.txt


    As ffmpeg is not found I think the result is not what I want,...

    Can you please give me a hint, what to install on Ubuntu bionic?


    Edit:

    Did simply

    apt-get install ffmpeg

    Then the not found disapears, but the plugin is not woking for me, get just blinking between a standing picture and black screen, here the syslog of this:


    syslog.txt




    Edit2:

    Seit wann gibt es hier im Forum diese Zeichenbegrenzung:

    Ihre Nachricht ist zu lang. Es stehen maximal 10.000 Zeichen zur Verfügung.

    Das ist echt nervig wenn man Log-Schnipsel in Code-Tags einfügen will. :-/

  • Can you please give me a hint, what to install on Ubuntu bionic?

    Mit sudo apt-get build-dep packetname werden die benötigten Packete zum Compilieren automatisch installiert unter der Voraussetzung, dass das Paket in den eingeschalteten Repositories des Computers vorhanden ist. Aber Achtung: Es werden die benötigten Pakete für die Version installiert, die im Repository der apt Quelle ist; nicht die Pakete für die git Version; aber wenn die Version im Repository der Version im git ziemlich entspricht, hast du wenigstens einen guten Ausgangspunkt.

    Seit wann gibt es hier im Forum diese Zeichenbegrenzung:

    Ich war auf das gleiche Problem gestoßen und habe es umgangen, indem ich die Daten in eine Datei gespeichert habe, die ich hochgeladen habe. Bei der Meldung der Zeichenbegrenzung sollte man vielleicht hinzufügen, eine Datei zu benutzen.