Neuer VDR mit Intel-Grafik - Anleitung/Howto

  • ab gen4 ist modesetting die besser Wahl.

    Was ist gen4?


    Und dann einfach anstatt "intel" als Driver eintragen? Der Rest der xorg.conf bleibt gleich?

    HowTo: APT pinning

  • @ lostinpc,


    Ich dachte auch man muss den xf86 Treiber nehmen und es war ein Schuss ins Blaue. Jedenfalls haben es nun 2 mld User probiert und sagen, dass sie ihre Last halbiert haben.


    fnu ,


    Ab Generation 4 Intel gpu die es wohl seit 2007 gibt. Das habe ich glaube aus dem archwiki finde es aber auch gerade nicht mehr :/


    Ja einfach Intel gegen modesetting tauschen.


    Anscheinend würde der neuere xorg automatisch diesen nehmen. Libglamore muss auf jeden Fall vorhanden sein.


    Gruß


    MarMic


    Edit:// habe auf der Suche nach dem gen4 Part noch folgendes gefunden:

    Intel vs modesetting Benchmark


    Edit2://xorg stellt Default um:

    Modesetting wird default


    Edit3:// das gen4+ kam vllt von hier her

    Gentoo wiki

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

    Dieser Beitrag wurde bereits 3 Mal editiert, zuletzt von MarMic ()

  • MarMic

    Hab jetzt den modesetting Treiber am laufen. Sieht soweit nicht schlecht aus, die load ist (mit 4.13 kernel) aber nur leicht gesunken, liegt jetzt so zwischen 1,65 und 1,8, also so ca. 10 - 20% niedriger als vorher.

    Das Kernproblem mit dem 4.13 kernel behebt er also nicht.

    Ich lass ihn trotzdem mal drin ...

    VDR1: vdr-latest, arch x86_64, Octopus net 2 x Duoflex C/C2/T2 , NUC7i3BNH, Crucial MX300 2TB, LG LM 669S
    VDR2: RasPI 2, MLD
    VDR-User #81

    Linux is the best OS I have ever seen -- Albert Einstein

  • Hi lostinspc,


    Einer der mld entwickler hat ein Apollo Lake geholt und da ist der Unterschied auch nicht so krass wie bei mir oder anderen.


    Ich bin auf Kernel 4.14.x gespannt. Weißt du ab welchem Kernel genau die Last so angestiegen ist? Oder bist du gleich von 4.8 auf 4.13?


    Gruß


    MarMic

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • Moin,

    Ich bin auf Kernel 4.14.x gespannt. Weißt du ab welchem Kernel genau die Last so angestiegen ist? Oder bist du gleich von 4.8 auf 4.13?

    Auf 4.14 bin ich auch gespannt (befürchtet aber, das der an dieser Ecke nichts ändert).


    Reingekommen ist das meiner Erinnerung nach mit 4.12 oder 4.13. Ich habe das nach dem Hardwarewechsel auf den NUC festgestellt, das war im Sommer.


    Ist mM ja prinzipiell auch kein Problem.

    Die prozentuale CPU Auslastung ist bei mir "idle", der Lüfter bleibt aus, das System ist weiterhin voll responsiv.

    Irgendwie aber trotzdem unschön und war ja vorher auch nicht :-)


    Peter

    VDR1: vdr-latest, arch x86_64, Octopus net 2 x Duoflex C/C2/T2 , NUC7i3BNH, Crucial MX300 2TB, LG LM 669S
    VDR2: RasPI 2, MLD
    VDR-User #81

    Linux is the best OS I have ever seen -- Albert Einstein

  • MarMic


    Hmm, ok, mal überflogen, modesettings ist nach meinem ersten Verständnis eine Umstellung auf OpenGL, was evtl. die beobachtete Senkung der CPU Load erklären könnte. Ist ein interessanter Ansatz, da theoretisch generisch für alle GPUs verwendbar.


    Muss aber erstmal klären dann für den VPP Branch überhaupt die nötigen Features zur Verfügung stehen.


    Bzgl. Load noch was, die Ausgabe hängt auch von der Taktfrequenz der CPU ab, mein Core i3 im NUC läuft zu 90% auf der niedrigsten Stufe von 800MHz ... höchste wäre 1,7GHz.


    Bzgl. Intel GPU Generations, Sandy Bridge ist schon Gen6 ... https://en.wikipedia.org/wiki/…graphics_processing_units


    Regards

    fnu

    HowTo: APT pinning

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von fnu ()

  • Hmm, der modesetting-Treiber sollte eigentlich keine Auswirkungen auf Anwendungen haben, die vaapi nutzen. Siehe auch

    https://www.reddit.com/r/archl…_to_ditch_xf86videointel/


    Auf meinem VDR2 nutze ich seit dem Update auf Mint 18.2 auch den modesetting-Treiber und augenscheinlich hat sich dadurch nichts geändert.

    VDR 1: Linux Mint 18.1 mit VDR 2.2.0 und Ausgabe auf X11 (Radeon HD6450) via softhddevice/vdpau. DVB-Karte: DVBSky T9580V3
    VDR 2: Ausgabe auf X11 (Intel i5 Kaby Lake) via softhddevice/vaapi, sonst wie VDR 1

  • @All,


    der Load ist aber auch nicht ganz so wichtig, denn die Frage ist, wie wird der Load berechnet,

    bei einer integrierten GPU.


    Gruß,

    Roland


    P.S.: Einfach mal die MLD 5.4 unstable (https://www.minidvblinux.de/do…/5.4/amd64?class=unstable) testen ,

    es wird auch nciht gebohrt ;)

    1x OctopusNet mit 2x DVB-S2 u. 2x DVB-C
    1x Zotac ITX-A Atom 330 als Client MLD 5.4.0-64bit
    1x Raspberry 3 als Client MLD 5.4

    1x Raspberry 2 als Client MLD 5.4

    1x Raspberry 1 (staubt gerade so vor sich hin) ;)
    1x Cubietruck

    1x MCC 100
    1x BananaPi

    1x Zotac CI327 (https://www.zotac.com/de/product/mini_pcs/ci327-nano)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von rfehr ()

  • Hallo MarMic,


    wollte ich heute Nachmittag mal versuchen, aber es wird leider kein Netzwerk erkannt (bei easyvdr und yavdr gibts in dieser Hinsicht kein Problem).


    Gruss,

    Markus

  • ot on

    Das wundert mich aber. welches Modul wird denn bei den anderen geladen und soll dann bei uns fehlen?

    Das letzte Mal als wir sowas hatten, dass ein System kein Netzwerk hatte war es das Kabel. Auch wenn es komisch klingt mit dem Kabel gingen allerdings andere Rechner und OSs. Ein Kabeltausch brachte erst Netzwerk zur mld.

    Ich bin im Urlaub aber bei uns im forum oder hier im Unterforum wird dir sicher geholfen falls Interesse besteht

    Ot off

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • Moin,

    Auf 4.14 bin ich auch gespannt (befürchtet aber, das der an dieser Ecke nichts ändert).

    Hi da hast du Recht!

    Wir sind nun auf 4.14.1 und es ändert sich nichts.

    Kannst ja Mal das liveboot testen wenn du willst.

    Bei uns im Team hat ein mitglied den load auf 30 gebracht und das System lief noch sauber!

    Wir sind uns nun einig (vermuten), dass da ein Berechnungsfehler oder eine andere Interpretation wirken muss.

    Bei meinem nvidia Celeron System ist ein load >2.0 der Untergang! Osd und co träge wie ***


    Gruß


    MarMic

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • Hi,


    bei den MLD ISOs sind nicht alle verfügbaren Netzwerktreiber mit dabei, sondern nur die ca. 20 Stück, die bisher überhaupt mal verwendet wurden.

    Es kann also sein, dass Du einen von den tausend anderen Netzwerk Treibern benötigst. Die sind in dem zusätzlichen Paket network-drivers.

    Du musst Dir also ein angepasstes Image erstellen und neben den "netinstall" Paketen auch noch das network-drivers Paket hinzufügen.


    Claus

    MLD 5.1 mit vdr 2.2 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM -
    WD Green 6TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.3 mit vdr 2.3.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.1 mit vdr 2.2 - Banana Pi - softhddevice
    MLD 5.0 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT
    MLD 2.0 mit vdr 1.6 - SMT-7020s - 80GB HDD