Neuer VDR mit Intel-Grafik - Anleitung/Howto

  • Muss ich mal eine auf den VDR kopieren.

    Aktuell sitze ich auf Arbeit und bin via putty auf dem vdr.

  • So, nun habe ich mal easyvdr-3.5 installiert.

    Gleiche Meldungen wie bei yavdr im Log.

    Abspielen einer Aufnahme läuft 2s und dann stürzt der VDR ab.

    Wundert mich doch etwas, da hier doch einige berichten (auch bei easyvdr und mld) sogar mit älterer Hardware erfolgreich ein Bild zu haben.

    Ist denn noch irgendwas essentielles im Bios einzustellen?


    Ansonsten kommt da jetzt doch eine nvidia-Karte rein und gut ist.

  • Hi,


    Ist denn noch irgendwas essentielles im Bios einzustellen?

    installiere doch Bitte mal Kernel-4.8.12 wie hier beschrieben!

    http://www.easy-vdr.de/thread-…ost-177122.html#pid177122


    Gruss

    Wolfgang

  • Hi,


    wir hatten gerade einen Videochat und haben es anhand eines Notebooks versucht nachzustellen.


    Probiere Mal bitte eine mld 5.4 unstable und dazu noch ein:


    apt-get install mesa


    Danach


    runx -r

    runvdr -r



    Gruß


    MarMic

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • Den Kernel hatte ich schon unter der yavdr-Installation hochgezogen, das hatte nichts geändert. Zumindest die Fehlermeldungen bezüglich nicht unterstütztem Deinterlacer blieben (Aufnahme hatte ich dort noch nicht getestet gehabt). seahawks ppa müsste ja mit euren Paketen identisch sein. Werde ich am Wochenende aber gerne nochmal versuchen.


    Probiere ich am Wochenende gerne auch nochmal aus und gebe Feedback.


    Die nvidia-Karte ist aber schon bestellt und es wird letztlich doch wieder damit laufen müssen.


    Gruss.

    Markus

  • seahawks ppa müsste ja mit euren Paketen identisch sein.

    Ich habe an dem vaapi-PPA aus Zeitmangel seit Monaten nichts mehr geändert, die von wolfi.m gepflegten Pakete dürften aktueller sein.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi Markus,


    Die nvidia-Karte ist aber schon bestellt und es wird letztlich doch wieder damit laufen müssen.

    [OT ON]

    hoffe du hast nee GT 1030 bestellt. Nvidia-Treiber muss dann 384.xx sein. Kodi-17.5(vdpau) funktioniert auch.

    [OT OFF]


    Gruss

    Wolfgang

  • Nö, die einzige die in das Board passt, ist eine GT710 mit einem PCIe 2.0 1x Steckplatz.

    Die reicht ja völlig aus.

  • noch ja, nur für DVB-T2 nicht... (und 710 ist eher schwachbrüstig)...

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
    VDR5: Gigabyte
    GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
    VDR-User #1068 
    www.easyvdr.de 

  • Wer braucht schon DVB-T(2). Reines Sat mit den normalen HD-Kanälen. Dafür reicht auch eine 710 völlig, sowie eine 210, 520 oder 610.

    Und ausserdem ist es die einzige vdpau-fähige mit diesem Steckplatz. Früher gab es mal eine 730er mit PCIe 2.0 x1 von Zotac, aber die ist leider nicht emhr verfügbar.

  • Hi Ofenheizer,


    Seit gestern sollte es bei MLD ootb laufen. Zumindest tut es das auf meinem Test notebook und bei 2 anderen Usern.


    Das Log wird so geflutet wie bei dir, wenn kein Input kommt! Scheint normal zu sein.


    Mesa und co wie in dem Beitrag oben zu lesen musst du nicht mehr nach Installieren.


    Mld 5.4 unstable erkennt nun, dass du ne Intel hast und nimmt xorg-intel und auch automatisch alles weitere für vaapi.


    Da ich kein Input device hatte lief bei mir ne Aufnahme in 1080i die kompletten 2h durch.


    Achso wir haben noch einen Bug das beim ersten booten shd nicht zwingend aufgeht. Eventuell über webif Befehle restart VDR oder über Konsole restart vdr


    Über Feedback freuen wir uns


    Gruß


    MarMic

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • MarMic, hört sich ja zu gut an.... was für eine CPU hat benutzt? Das ist ja entscheidend, mit einer J1900 wird es wohl nie was werden, eine i5 oder i7 für den VDR zu nutzen, etwas Mit Kanonen nach Mücken schießen ;)


    Wollte und dachte das Intel GPU mitlerweile gut genug ist, aber alles bastelei oder besser noch Frickelei, liegt nicht an euch, ihr mach super Support hier, Danke, (Nicht das das wieder einer in den falschen Hals bekommt)


    Bei meinen Versuchen, selbst mit Nvidia einen yaVDR/MLD aufzusetzen, der so wie der alte läuft, ist mir bis jetzt noch nicht wirklich gelungen, irgendwas war immer. Alles Kleinigkeiten sicher, irgendwie dachte ich es würde mittlerweile runder laufen.


    Warum gebt ihr bei MLD nicht in etwa vor, was drin sein darf (Hardware) und was oob unterstützt wird und was nicht? (Vorbild Apple)

    Das macht euch doch auch das Leben leichter beim Bauen und testen. Ich weiß, ihr sucht die Herrausforderung, aber einige, wie ich auch, würden nach basteljahren jetzt einfach eine Distri nutzen wollen, die geht. Habe auch nicht sonderlich viel Zeit zum testen. Keine Kritik, ist nur meine zu hohen Erwartungen nach jahren sorgloser VDR Nutzung. Bei den Plugins finden man sich so ad hoc auch nicht mehr durch, was brauche oder will ich, was wäre nützlich und was ist schon abgestorben. Habe mich jetzt doch dazu entschlossen den alten VDR-Patienten im WZ mit künstlichen Organen weiter am leben zu erhalten, bis meine Tests Erfolgreich sind.

    interne Displays sind ja auch scheinbar nicht mehr inn... finde ich schade.

    Gruß Martin (linuxdep)

  • Hi,


    Zufrieden bin ich nicht. Ich habe ein Lenovo T430 benutzt für die Tests. Mir gefällt die Last aber überhaupt nicht. Verstehe aber noch nicht woher die kommt.


    OT on

    Was für Probleme hast du den mit Nvidia? Das ist seit jahren das einzige Setup, das ich locker schon auf 30 unterschiedlichen Hardware Setups am laufen habe.

    Würde natürlich gerne wissen was da bei dir bei MLD nicht läuft - damit wir es für alle fixxen können.

    Wegen den Vorgaben... Wir sind kein Hersteller der etwas vorgibt... Wir machen das aus Spaß an der Freude und ich denke die User, die es nutzen haben einen gewissen Ehrgeiz es ans laufen zu bringen. Wenn man keine Lust auf basteln hat holt man sich meiner Meinung nach ne fertige Lösung.

    OT Off


    fnu falls du das lesen solltest: wie hoch ist deine load (top) im va-api Betrieb? Und falls deutlich kleiner als 1.5 - hast du eine Idee woran es liegen könnte, dass die Last so hoch ist bei CPU Idle 95%?


    Gruß


    MarMic

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • MarMic


    Sieh selbst, ich nutzt den VPP Branch von Antti/Rolf.


    Ein Load von 1,5 ist doch kein Problem, der Load pro OS-CPU ist ja kleiner. Wenn in meinem System eine Load von 4 anliegen würde, würde ich mir Sorgen machen. Das würde bedeuten ein Prozess pro OS-CPU wäre am warten ...


    Bei der Ausgabe über Intel ist die Haupt-CPU noch mehr involviert, als bei Nvidia's VDPAU, so ist das Design. Komplett losgelöst von CPU ist die Ausgabe nur bei AddOn Karten wie FF-SD, FF-HD oder DXR3 ...


    Regards

    fnu

    Bilder

    HowTo: APT pinning

  • Hi fnu,


    Danke für deine Antwort! Das beruhigt mich nun ein wenig. Hatte irgendwie noch fest im Kopf >1 ist BÖSE :)

    Mir ist aufgefallen, dass wenn ich anstatt Driver "Intel" ein Driver "modesetting" in der xorg.conf eintrage die Last runter geht. Und vainfo trotzdem sagt, das alles ok ist.


    Ich denke du hast ziemlich viel Knowhow bei dem Thema. Es wäre nett wenn du Mal nen Liveboot von uns testen könntest, da von uns keiner so eine Hardware verwendet. Auf dem Notebook macht das keinen so rechten Spaß.

    Tipps zu den Default shd settings (allgemein gültig) wäre auch sehr nett.


    Danke


    Gruß


    MarMic

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • Hatte irgendwie noch fest im Kopf >1 ist BÖSE

    Das stimmt auch immer noch für eine OS-CPU, aber wir haben ja heute Mehrkerner i.d.R. 2-4 Kerne/Hyperthreading.


    Ja, wenn ich mal was Zeit habe, kann ich das gerne machen, mein Test-VDR ist auch ein Haswell NUC ... kann ein paar Tage dauern.


    Regards

    fnu

    HowTo: APT pinning

  • MarMic

    Zufrieden bin ich nicht. Ich habe ein Lenovo T430 benutzt für die Tests. Mir gefällt die Last aber überhaupt nicht. Verstehe aber noch nicht woher die kommt

    Die hohe load bei intel vaapi ist bei mir ein Problem mit neuen Kernelversionen.


    Unter arch mit kernel 4.8 lts habe ich eine load von 0,1 bis 0,2 (SD oder HD Livebild, NUC siehe Sig).


    Mit dem aktuellen Kernel 4.13 habe ich mit ansonsten unveränderter config eine Load von >= 2

    Ansonsten verhält sich das System aber nicht anders, die hohe load stellt kein merkbares Problem dar.


    Habe auch schon mal kurz versucht, mit strace etwas Licht in die Sache zu bringen, war aber auf die Schnelle nicht so richtig erfolgreich.


    VG, Peter

    VDR1: vdr-latest, arch x86_64, Octopus net 2 x Duoflex C/C2/T2 , NUC7i3BNH, Crucial MX300 2TB, LG LM 669S
    VDR2: RasPI 2, MLD
    VDR-User #81

    Linux is the best OS I have ever seen -- Albert Einstein

  • Hallo lostinpc,


    Danke für die Rückmeldung. Wir nutzen zZ Kernel 4.13.x auf dem Weg zu 4.14.1

    Das ist natürlich komisch mit einer Zehn-fachen Last. Hast du nur den Kernel hochgezogen oder dabei auch libva/vaapi und was da noch so rein spielt angefasst?

    Nutzt du Intel als Treiber oder modesetting? Ich habe gelesen ab gen4 ist modesetting die besser Wahl.

    Empfinde ich zumindest bei meinem HD4000 Test auch so.


    Gruß


    MarMic

    SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLDHD-3.0.1


    SDVDR: Dell Optiplex GX150: P3 1Ghz - 256Mb Ram - 20Gb HDD - Technotrend Premium C-2300 Hybrid - KabelBW - MLD-2.0.0 @Eltern

  • Hast du nur den Kernel hochgezogen oder dabei auch libva/vaapi und was da noch so rein spielt angefasst?

    Nutzt du Intel als Treiber oder modesetting?

    Hi,


    der Rest des Systems inkl. libva usw. ist auf dem neusten (arch stable) Stand, das ist ziemlich aktuell.


    Das mit dem modesetting-driver ist ein interessanter Hinweis, kannte ich noch gar nicht, ich dachte man müsste zwingend xf86-video-intel verwenden.

    Habe mal kurz drüber gelesen, werde ich auf jeden Fall heute Abend ausprobieren.

    Ob es in dem speziellen Fall Besserung bringt ... man wird sehen.


    VG Peter

    VDR1: vdr-latest, arch x86_64, Octopus net 2 x Duoflex C/C2/T2 , NUC7i3BNH, Crucial MX300 2TB, LG LM 669S
    VDR2: RasPI 2, MLD
    VDR-User #81

    Linux is the best OS I have ever seen -- Albert Einstein