[SOLVED] Zoomfunktion in Softhddevice

  • Stimmt! die Zeile mit dem DETA ist überflüssig. Das ATTA sorgt im Anschluss für die Aktualisierung ohne Bildverlust. Klasse - Danke

    Bei mir leider nicht. :(

    Ohne das DETA gibt es keine Aktualisierung der Anzeige und es wird nicht sofort gezoomt. Erst nach einem Senderwechsel ist dann das Bild gezoomt. Das Umschalten "switching to channel 1 ..." in der letzten Zeile habe ich manuell gemacht und dann war erst der Zoom da:


    Mit dem aktiviertem DETA wird das Bild beim Ausführen des Scriptes kurz dunkel und dann ist der Zoom gleich aktiv. Die letzte Zeile "switching to channel 1 ..." wird hierbei automatisch ausgeführt, sieht man auch an der gleichen Ausführungszeit.

    Also bei mir läuft es leider nur mit aktiviertem DETA, so wie es sein sollte. :(


    Taipan ,

    wieso geht es bei Dir auch ohne DETA? :/

    Richtig perfekt wäre es wirklich, wenn dieses leidige Abschalten der Anzeige nicht wäre! ;)



    Hier nochmals mein aktuelles Script mit deaktiviertem DETA:

    Paul

  • Wenn ich das wüßte! Mein Bild springt ohne Zip und Zap auf die Zoomgröße, allerdings NUR als Befehl aus dem OSD heraus!!! Wenn ich die Scripte im Terminal ausführe rührt sich nix ohne umschalten wie bei Dir! Ich habe keine Ahnung woran das liegt...

  • Mein Bild springt ohne Zip und Zap auf die Zoomgröße, allerdings NUR als Befehl aus dem OSD heraus!!!

    Kannst Du mal kurz beschreiben, wie Du das machst bzw. meinst?



    Ich mache es so, wie Du bereits ganz oben beschrieben hast, über einen Eintrag in der menuorg.xml, wo das Script aufgerufen wird.

    Die 1. Zeile ist Deaktivieren des Zooms, die 2. Zeile ist das Aktivieren des Zooms.

    Code
    1. <command name="Zoom AUS" execute="/usr/local/bin/zoom_off &amp;> /dev/null " />
    2. <command name="Zoom EIN" execute="/usr/local/bin/zoom_on &amp;> /dev/null " />

    Der Aufruf erfolgt dann ganz normal über die Fernbedienung:

    Menü --> System --> Befehle --> Zoom AUS bzw. Zoom EIN


    Paul

  • Genau so ist es bei mir auch. Nur der Pfad weicht ab und ist user-/rechtemäßig root/root 0755


    Code
    1. <command name="21:9 Zoom" execute="/etc/vdr/scripte/zoom1 &amp;> /dev/null" />
    2. <command name="Test Zoom" execute="/etc/vdr/scripte/zoom2 &amp;> /dev/null" />
    3. <command name="Zoom Aus" execute="/etc/vdr/scripte/zoom0 &amp;> /dev/null" />
  • Bei mir stehen die Werte für User und Rechte ebenfalls auf root/root 755.

    Inzwischen habe ich auch Deinen Pfad /etc/vdr/scripte genommen, aber es funktioniert trotzdem ohne ein DETA oder Senderwechsel nicht.


    Selbst wenn mal testweise direkt im Setup-Menü des softhddevice-Plugin die Werte für "Schneide oben und unten ab (Pixel)" beliebig ändert, wird das nicht sofort übernommen, sondern ich muss ein DETA machen oder einen Senderwechsel ausführen!



    Taipan ,

    kannst Du mal nachschauen, was bei Dir in der syslog steht, wenn Du den Zoom aufrufst. Wird denn bei Dir da automatisch ein "switching to channel ..." ausgeführt, oder wie sieht das bei Dir aus?

    Bei mir ist es ja so, das durch das DETA im Prinzip auch ein Senderwechsel (in dem Fall auf den gleichen Sender) ausgeführt wird. Siehe hier die letzte Zeile:


    Das ganze kann man auch manuell über die Fernbedienung machen! Aufruf des Zoom-Scriptes ohne DETA und anschließend noch auf der Fernbedienung die gleiche Sendernummer drücken. Jetzt wird der Zoom übernommen, ohne dass das Bild dunkel wird, es stockt nur kurz!



    Mir sind noch 2 Dinge aufgefallen, wobei der 1. Punkt am meisten stört:

    1. Wenn man während der Wiedergabe eines Filmes den Zoom aktiviert wird durch das DETA die Wiedergabe abgebrochen und man landet wieder im Live-TV. Ohne das DETA muss man die erst Wiedergabe stoppen und neu starten, damit der Zoom aktiviert wird. Also einfach während einer Wiedergabe den Film den Zoom umschalten klappt bei mir nicht. :(
    2. Bei einer 4:3-Sendung funktioniert der Zoom nicht richtig, wenn im softhddevice-Plugin der Wert von "4:3 video display format: letterbox" steht. Da wird nur das Bild innerhalb der "letterbox" vergrößert, aber die schwarzen Balken links und rechts bleiben bestehen. Bei den anderen Einstellungen für 4:3-Sendungen wird immer voll aufgezoomt, was nicht so mein Geschmack ist.


    Ich habe jetzt noch ein paar kosmetische Verbesserungen gemacht und die beiden Scripte für zoom_off und zoom_on in ein einziges Script "zoom_on.sh" zusammengefasst und gleichzeitig noch verschiedene Zoomstufen wie 0%, 10%, 15%, 20% und 25% eingebaut, die man je nach belieben aufrufen kann. Dabei entspricht 0% = Zoom AUS und 25% = voller Zoom bei einer 21:9-Sendung:


    Der Aufruf des Scriptes erfolgt dann mit Übergabe des entsprechenden Parameters in der menuorg.xml:

    Code
    1. <command name="Zoom AUS" execute="/etc/vdr/scripte/''zoom_on.sh -0'' &amp;> /dev/null" />
    2. <command name="Zoom EIN 10%" execute="/etc/vdr/scripte/''zoom_on.sh -10'' &amp;> /dev/null" />
    3. <command name="Zoom EIN 15%" execute="/etc/vdr/scripte/''zoom_on.sh -15'' &amp;> /dev/null" />
    4. <command name="Zoom EIN 20%" execute="/etc/vdr/scripte/''zoom_on.sh -20'' &amp;> /dev/null" />
    5. <command name="Zoom EIN 25%" execute="/etc/vdr/scripte/''zoom_on.sh -25'' &amp;> /dev/null" />


    Taipan ,

    Wenn dieses leidige DETA nicht wäre, was jetzt vor allem bei der Wiedergabe eines Filmes stört, wäre für mich diese Lösung für eine "Zoomfunktion im Softhddevice" perfekt. Aber ich vermute mal, dass dies ohne eine Änderung direkt im softhddevice-Plugin nicht lösbar ist.


    Im Prinzip kannst Du also jetzt dem Thread ein [Solved] voranstellen!

    Denn nun gibt es ja einen "funktionierenden" Zoom über das softhddevice-Plugin! ;)

    Für die noch bestehenden kleineren Problemchen bin ich leider hoffnungslos unterqualifiziert und maximal als Tester geeignet! 8) 


    Paul

    PS: Taipan , Du bist mein Held, denn mit der doch so simplen Idee, gibt es endlich eine Möglichkeit auch im VDR die schwarzen Balken wegzuzoomen! :)

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Paulaner ()

  • Also,


    Ich habe gar keine weiteren Einträge im syslog! Ausser das bekannte:


    Und bei einer laufenden Wiedergabe kann ich auch den Befehl absetzen und das Bild springt sofort 'groß' - Wiedergabe läuft weiter (zurück natürlich auch)...

    Und es funktioniert auch OHNE die Zeilen ATTA und DLIC, gerade getestet - Bild ist sofort groß/klein


    Habe keine Ahnung warum es so ist wie es ist - vielleicht ein Patch - bin mit Frodos Paketen und der opengl-Version von softhddevice unterwegs


    meine softhddevice Einträge der setup.conf:


    BTW: Deine Variante des einzelnen Scripts habe ich gern übernommen - Danke!

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Taipan ()

  • Und bei einer laufenden Wiedergabe kann ich auch den Befehl absetzen und das Bild springt sofort 'groß' - Wiedergabe läuft weiter (zurück natürlich auch)...

    Oh Mann, dass klingt ja super und funktioniert ja genauso, wie es sein sollte! :)



    Und es funktioniert auch OHNE die Zeilen ATTA und DLIC, gerade getestet - Bild ist sofort groß/klein

    Da es bei mir leider nicht so perfekt läuft, könnte an den unterschiedlichen Distries liegen.

    Ich habe des ganz normale yavdr-stable am laufen! Mit dem funktioniert es nur mit dem DETA oder Sendewechsel. :(


    Auf dem "Reserve-VDR", den ich jetzt allerdings vorwiegend nutze, habe ich nur als Zusatz das ppa: für DVB-T2-HD von @seahawk eingebunden, um von hier das softhddevice-vpp-hevc zu verwenden. Damit kann ich dann auch die DVB-T2-HD-Sender und auch die UHD-Sender anschauen, die ja in HEVC (h.265) codiert sind. Das kann ja das "normale" softhddevice-Plugin nicht. Auch hier geht das Zoomen nur mit einem DETA oder Senderwechsel! :(



    Habe keine Ahnung warum es so ist wie es ist - vielleicht ein Patch - bin mit Frodos Paketen und der opengl-Version von softhddevice unterwegs

    Wenn ich mich recht entsinne, dann basieren ja Frodos Pakete auch auf Trusty und yaVDR.

    Vielleicht kannst Du mir mal bei Gelegenheit die von Dir verwendeten Frodo-ppa: nennen (sind ja unter /etc/apt/sources.list.d zu finden), dann würde ich das auch mal bei Gelegenheit testen.

    Die kann ich bestimmt direkt über meinen yavdr drüberbügeln. Und falls es nicht klappt, dann habe ich ja immer ein Backup vom yaVDR, so dass ich schnell wieder ein laufendes System habe! ;)


    Paul


    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Paulaner ()

  • Das sind sie (testing.pref):


    Gleich aber mal vorher deine genutzten Plugins ab.

  • Ich habe gestern abend auch mal das "softhddevice-openglosd" vom yavdr-stable getestet, aber das hat auch keine Verbesserung gebracht.

    Irgendwas ist bei Dir bzw. den PPAs von Frodo doch noch anders! :(


    Das PPA: "frodo-vdr-testing-dev" benutzt ja schon den aktuellsten vdr-2.3.8!

    Das kann natürlich eine Ursache sein, warum es bei Dir so einfach funktioniert, denn hier wurden ja einige Pluginaufrufe usw. gravierend geändert!

    Zumindestens wird es dadurch nichts mit einfach drüberbügeln, sondern ist doch eine längere Geschichte. Vielleicht mache ich mal einen Versuch in den kommenden grauen Wintertagen, aber momentan eher nicht.

    Kann man den vdr-2.3.8 schon richtig produktiv einsetzen, oder gibt's damit noch paar Probleme, die den WAF beeinflussen können? 8)



    Ich habe jetzt übrigens ebenfalls auch das ganze DETA, ATTA und DLIC im Script "zoom_on.sh" auskommentiert und es klappt auch damit, wenn ich immer anschließend nochmal die gleiche Sendernummer eingebe oder einen Senderwechsel mache. Bei der Wiedergabe einer Aufnahme drücke ich jetzt einfach kurz hintereinander STOP/START und dann ist der Zoom aktiviert, ohne dass es eine große Unterbrechung gibt! Ist für mich wesentlich angenehmer, als immer der schwarze Bildschirm durch das DETA / ATTA vom softhddevice-Plugin. ;)



    Noch was zum Komfort:

    Ich habe noch ein kleines Script "softhddevice-zoom-off.conf" gebastelt, welches einmal beim Start des VDR immer den Zoomlevel = 0% einstellt. Damit erhöht sich mein WAF wesentlich, falls man mal abends nach dem Filmschauen vergessen hat den Zoomlevel wieder auf 0% zu setzen! ^^

    Das Script kopiert man einfach in das Verzeichnis "/etc/init/" und beim nächsten Start des VDR wird es sofort ausgeführt!


    Zumindestens finde ich es erstmal super, dass es dank Deiner genialen Idee eine praktikable Lösung für das Zoomen über das softhddevice-Plugin gibt. :)

    Bei Dir funktioniert es etwas komfortabler als bei mir, aber damit kann ich kann vorläufig leben! Denn es ist allemal noch besser als immer auf KODI umzuschalten, oder am TV zu zoomen, wo dann das OSD nicht mehr richtig lesbar ist, weil es leider auch gezoomt wird!


    Paul

  • Nachtrag + Lösung zum oben diskutierten Unterschied bei der Ausführung des Zoom-Befehls in meinem VDR (hier ging es nur mit zusätzlichem Bildwechsel) und dem VDR von Taipan (bei Ihm wurde der Zoom-Befehl sofort ausgeführt)!


    Dank eines Tipps von Taipan , der herausgefunden hatte, dass das "Zoomen" über das softhddevice-Plugin bei Ihm auch nur funktionierte, weil er immer den shady_KISS-Skin verwendet hat. Ich hingegen benutze immer einen etwas abgewandelten simplex-Skin, da ich eine 65"-TV habe und mir da die Skins, welche den gesamten Bildschirm nutzen einfach zu groß sind.

    Als Taipan nun mal den metrix-Skin testen wollte, musste er ebenfalls nach dem Aktivieren des Zoomfaktors "einmal" das Bild wechseln, bevor das Zoomen aktiv war. Zurück zum shady_KISS-Skin und schon funktionierte es sofort wieder!



    Das habe ich nun sofort getestet und siehe da, auch bei mir klappt das Zoomen sofort, wenn ich den shady_KISS-Skin verwende! Und es ist nicht nur der shady-KISS-Skin wo es so funktioniert, sondern auch alle anderen Skins, bei welchen im Hauptmenü des VDR das TV-Bild innerhalb des OSD verschoben und skaliert wird, wie z. B. auch beim estuary4vdr-Skin oder blackhole-Skin.



    Ich habe daraufhin mal die verantwortliche "displaymenumain.xml" aus den Skins angeschaut und da ist sofort aufgefallen, das die 1. Zeile in der XML-Datei etwas anders aussieht, als beim von mir verwendeten simplex-Skin!


    Hier die 1. Zeile der "displaymenumain.xml" aus dem estuary4vdr-Skin:

    Code
    1. <menumain x="0" y="0" width="100%" height="100%" fadetime="0" scaletvx="39%" scaletvy="8%" scaletvwidth="60%" scaletvheight="60%">


    Bei mir hingegen bzw. im verwendeten (etwas abgewandelten) simplex-Skin sieht die 1. Zeile einfach nur so aus:

    Code
    1. <menumain x=x="20%" y="34%" width="60%" height="65%" fadetime="0">


    Beim estuary4vdr-Skin (und auch den anderen o.g. Skins) wird also das TV-Bild beim Öffnen des OSD auf die vorgegebenen Werte verschoben und entsprechend skaliert. Beim Schließen des OSD wird dann wieder das "normale" Vollbild angezeigt. Und das scheint die Ursache dafür zu sein, dass das Zoomen sofort übernommen wird, weil das TV-Bild im softhddevice-Plugin neu gezeichnet werden muss!


    Also habe ich nun einfach mal testweise bei mir ebenso diese Parameter zusätzlich eingefügt und schon hat es sofort funktioniert!

    Ich gehe also ins OSD, wähle den Zoomfaktor und dabei schließt sich das OSD automatisch wieder und sofort ist das gezoomte TV-Bild da, ohne einen zusätzlichen Tastendruck, wie ich es vorher machen musste! Perfekt! :);):)


    Da ich aber nicht das TV-Bild verschieben und skalieren will, habe ich die Parameter für mich etwas angepasst! Nun sieht das bei mir so aus:

    Code
    1. <menumain x="20%" y="34%" width="60%" height="65%" fadetime="0" scaletvx="{areawidth}*0.001" scaletvy="0%" scaletvwidth="100%" scaletvheight="100%">

    Damit wird jetzt beim Öffnen des OSD das TV-Bild lediglich um 0,1% = 2 Pixel (bei 1920x1080px) nach rechts verschoben und nicht weiter skaliert, was dadurch nicht sichtbar ist! Beim Schließen des OSD wird dann wieder das "normale" Vollbild angezeigt! Dadurch klappt nun das Zoomen bei mir perfekt, mit nur einem Tastendruck! :)


    Für mich ist damit das "Zoomen" des Bildes über das softhddevice-Plugin perfekt gelöst und man kann es wirklich sehr komfortabel einsetzen, in dem man einfach in das OSD die entsprechenden Befehle einfügt und das Zoom-Script "zoom_on.sh" (siehe Dateianhang) nach /etc/vdr/scripte kopiert.

    Und wer noch etwas Komfort liebt, der kopiert das Script "softhddevice-zoom-off.conf" nach /etc/init , denn damit wird beim Start des VDR der Zoomlevel wieder auf 0% gesetzt, falls man das mal vergessen haben sollte! Nicht vergessen, das ".txt" wieder zu entfernen, da ich sonst die Scripte nicht hochladen konnte! ;)


    Das ganze funktioniert dann sicherlich (ohne es jetzt explizit getestet zu haben) auch bei jedem anderen Skin, wie z. B. reufer-Skin, metrix-Skin usw.


    Paul

    Dateien