[gelöst] Rechner wacht nicht mehr per acpi auf

  • Hallo zusammen,


    seit ca. 4 Wochen habe ich Probleme mit meinem VDR Rechner beim Ausschalten und Aufwachen per acpi.

    Das Problem beim Ausschalten konnte ich durch Abklemmen des DVD-Laufwerks lösen, ist scheinbar defekt.

    Das Aufwachen funktioniert aber trotzdem nicht.

    Für mich völlig unverständlich:

    Das acpi-test skript aus dem WIKI funktioniert jedes Mal, egal ob ich eine Zeit in ein paar Minuten oder Stunden setze.

    Wird der Rechner per VDR ausgeschaltet, wacht er nicht mehr auf.


    In den Logfiles ist für mich absolut nichts zu erkennen, syslog zeigt die richtige Uhrzeit und Tag und auch in acpiwakeup.time.old stimmt alles.

    Einzig wenn ich den Rechner dann manuell starte steht in /proc/driver/rtc zwar die richtige Uhrzeit, aber der Tag ist einen Tag in der Zukunft.


    Ich bin absolut ratlos und wäre für jede Idee dankbar!;(


    Kernelparameter hpet=disable und acpi=force habe ich schon probiert.


    Rechner:

    Plugins:

    Code
    1. cat /var/cache/vdr/acpiwakeup.time.old
    2. 2017-09-15 16:59:00

    Nachdem manuellen Start:

    VDR User: 2127
    YaVDR-bionic , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6
    YaVDR-bionic (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: SkyTV Ultimate VIII, Miscellaneous: epgd, pihole

    YaVDR-bionic (headless), System: HP 260 G2 DM, DVB-S: Sundtek SkyTV Ultimate IV

    YaVDR-focal (TEST), Mainboard: Gigabyte Aorus Pro B450, CPU: Ryzen 5 3400G, IPTV

  • minixjr wrote:

    Das Problem beim Ausschalten konnte ich durch Abklemmen des DVD-Laufwerks lösen, ist scheinbar defekt.

    Das ist aber seltsam, davon das ein kaputtes DVD-Laufwerk (was genau soll da überhaupt kaputt sein, kenne die Vorgeschichte nicht?) das Ausschalten des Computers verhindern kann, hab ich noch nie gehört. Bist du sicher, dass nicht eher das Netzteil eine Macke hat und deshalb der PC nicht mehr richtig aus- und per ACPI einschaltet?

  • Die genaue Fehlermeldung habe ich leider nicht mehr, sie wurde auch nicht im Syslog protokolliert, da zu diesem Zeitpunkt rsyslog bereits beendet war.

    Die Meldung wurde nur auf dem Bildschirm angezeigt.

    Sowas wie:

    Code
    1. ata2: ... error ... {DRDY} ...

    und ata2 war das DVD-Laufwerk

    Code
    1. ata2.00: ATAPI: ASUS DRW-1814BLT, 1.13, max UDMA/66

    Das Netzteil hatte ich auch in Verdacht und habe mir ein neues bestellt.

    Ist heute gekommen, habe es aber noch nicht ausprobiert.


    Gegen das Netzteil spricht, meines Erachtens, dass das Aufwachen mit einer durch acpi-test.sh erstellten Zeit funktioniert.


    Bevor ich den halben Rechner zerlege werde ich versuchen ein eigenes Skript, angelehnt an acpi-test.sh, für das Setzen der Zeit zu erstellen.

    VDR User: 2127
    YaVDR-bionic , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6
    YaVDR-bionic (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: SkyTV Ultimate VIII, Miscellaneous: epgd, pihole

    YaVDR-bionic (headless), System: HP 260 G2 DM, DVB-S: Sundtek SkyTV Ultimate IV

    YaVDR-focal (TEST), Mainboard: Gigabyte Aorus Pro B450, CPU: Ryzen 5 3400G, IPTV

  • Habe jetzt doch das Netzteil gewechselt.

    Keine Änderung, der Rechner wacht nicht auf:§$%

    VDR User: 2127
    YaVDR-bionic , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6
    YaVDR-bionic (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: SkyTV Ultimate VIII, Miscellaneous: epgd, pihole

    YaVDR-bionic (headless), System: HP 260 G2 DM, DVB-S: Sundtek SkyTV Ultimate IV

    YaVDR-focal (TEST), Mainboard: Gigabyte Aorus Pro B450, CPU: Ryzen 5 3400G, IPTV

  • So, habe es wieder zum Laufen gebracht, allerdings fehlt mir die Fantasie wo hier das eigentliche Problem liegt.

    Vielleicht hat ja von den tiefer im Code steckenden Usern jemand eine Idee warum das Aufwachen mit aktiviertem ACPI-Addon nicht funktioniert.

    Aktueller Stand (muss ich natürlich noch ein paar Tage beobachten):

    • Aufweck-Methode im Web-If auf "NONE" gesetzt
    • S90.acpiwakeup nach S90.custom kopiert
    • in S90.custom fest eingetragen "ACPI_ENABLED="yes""

    --> Der Rechner wacht wie gewohnt auf.


    Ich habe es mehrfach ausprobiert und auch die Gegenprobe gemacht, also ACPI wieder aktiviert.

    Immer mit dem gleichen Ergebnis, ACPI aktiv = wacht nicht auf, ACPI deaktiviert = wacht auf.

    VDR User: 2127
    YaVDR-bionic , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6
    YaVDR-bionic (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: SkyTV Ultimate VIII, Miscellaneous: epgd, pihole

    YaVDR-bionic (headless), System: HP 260 G2 DM, DVB-S: Sundtek SkyTV Ultimate IV

    YaVDR-focal (TEST), Mainboard: Gigabyte Aorus Pro B450, CPU: Ryzen 5 3400G, IPTV

  • Nach nunmehr zwei Wochen ohne Probleme, beim Shutdown oder Aufwachen, setze ich das Thema mal auf "gelöst", auch wenn mir die Ursache des Problems nicht klar ist.

    Egal, mein Workaround funktioniert jedenfalls.

    VDR User: 2127
    YaVDR-bionic , Case: HFX Classic, Mainboard: ASUS H97M-E, CPU: Intel Celeron CPU G1840T, GPU: GeForce GT 1030, DVB-S: Digital Devices Cine S2 V6
    YaVDR-bionic (24/7), Case: Akasa, Mainboard: NUC D34010WYB, DVB-S: SkyTV Ultimate VIII, Miscellaneous: epgd, pihole

    YaVDR-bionic (headless), System: HP 260 G2 DM, DVB-S: Sundtek SkyTV Ultimate IV

    YaVDR-focal (TEST), Mainboard: Gigabyte Aorus Pro B450, CPU: Ryzen 5 3400G, IPTV