Kein lirc device

  • [..] Fortsetzung vom letzten post:


    Prozesse sind in diesem Zustanf bzgl. lirc folgende aktiv:

    Code
    1. ps ax | grep -i lirc
    2. 519 ? S<s 0:00 /usr/sbin/eventlircd -f --socket=/var/run/lirc/lircd
    3. 532 ? Ss 0:00 /usr/bin/irexec /etc/lirc/lircrc
    4. 905 ? Ss 0:00 /usr/sbin/lircd


    In VDR geht damit gar nichts, aber mode2 gibt beim Drücken etwas aus - 3x Menu, 4x OK


    Also nun immer ein space zwischen den pulse. Das war vorhin anders. Dann hab ich einfach einmal lirc (ohne "d") gestartet, den link /etc/init.d/lirc --> lircd wieder entfernt und durchgebootet.


    Auf einmal funktioniert die Fernbedienung ohne Aussetzer, wenn man "sauber" drückt - man muß aber wesentlich länger auf eine Taste an der RC drücken, damit es stabil zu bedienen ist. Ist aber schon ein Fortschritt :tup


    Warum es jetzt funktioniert, kann ich nicht nachvollziehen.



    Jetzt muß ich noch herausfinden, wie man es etwas "empfindlicher" machen kann.


    Gruß!

  • Es gibt kein /etc/init.d/lirc

    Es gibt einen Upstart-Job (/etc/init/lircd.conf), der ist dafür gedacht lircd zu starten. Das SysV-Init Skript, die aus dem lirc-Paket stammt, wird IIRC durch ein Skript aus yavdr-utils entfernt.


    Wie sehen denn die Werte in der lircd.conf für den Decoder aus? Eventuell schwanken die Zeiten etwas zu stark als dass lircd das noch richtig interpretieren kann.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • .. also kann ich diese Meldung in dmesg irgnorieren?

    Code
    1. [ 4.148587] systemd-udevd[819]: failed to execute '/etc/init.d/lirc' '/etc/init.d/lirc restart udev': No such file or directory


    An die lircd.conf komme ich erst etwas später. Danke für's Reinschauen zu meinem Problem.


    Gruß

  • Ich vermute, dass das SysV-Init Skript durch das postinst-Skript eines lirc-Pakets wieder aktiviert wurde. Das sollte sich so wieder abschalten lassen:

    sudo /usr/sbin/update-rc.d lirc disable

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Zitat


    /etc/lirc/lircd.conf sieht so aus (standard "KLS-vdr-1.6" .. ?)


    Gruß

  • lircd.conf ist 2 posts vorab - ich glaub es ist die standard-mitgelieferte.


    Das Verhalten ist beim Bedienen so, daß man bei jeder Taste einmal lange/"sauber" drücken muß. Schnell "zappen" geht, nicht. Es fehlt "die erste Reaktion auf den Tastendruck". Wenn eine Taste an der RC gedrückt bleibt, wiederholt es auch lt. irw sauber und im OSD kann man auch von oben nach unten scrollen.


    .. wieder "gefühlt" beschrieben :O)

  • Hallo,


    was ich bzgl. lirc Problem nicht erwähnt hatte: die Fernbedienung (alte Harmony One) benimmt sich nur mit den vdr/lirc so eigenartig, alle anderen Devices (AVR / TV) lassen sich ganz normal bedienen.


    Hab das problem also leider immer noch.


    Gruß!

  • Moin, seit ihr denn sicher, das es lircd überhaupt noch braucht?


    Hintergrund ist, das ich in den letzten Tagen drei PCs mit neuem Libreelec eingerichtet habe.

    Die hatten einen HomeBrew-, eine CIR- und einen selbst gebauten RPi-Empfänger dran.

    Alle drei laufen ohne lircd und ohne lircd.conf mit einer Logitech FB und der rc6-mce keymap.

    Anpassen der Tasten geht dann in der keymap oder direkt in Kodi.


    Grüsse

  • Bei yaVDR ist es prinzipiell egal, ob ein Dienst wie lircd oder ein von rc-core Treibern bereitgestelltes Kernel Input Device genutzt wird - wichtig ist nur, dass die Tastendrücke bei eventlircd ankommen, denn von dessen Socket lesen der VDR und Kodi.

    Laut der Ausgabe von ir-keytable aus Kein lirc device könnte man auch statt lircd zu nutzen versuchen den RC-5 Decoder für den Empfänger laden, dann müsste man sich halt noch eine Keymap erstellen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ui, da habt ihr wieder was zum knappern hingelegt - hoffentlich nicht zum Zähneausbeissen :)

    Daran könnte ich mich noch versuchen!


    Zitat

    [..]versuchen den RC-5 Decoder für den Empfänger laden

    daran scheitert's schonmal - wie macht man das? "

    Code
    1. sudo ir-keytable -t

    hatte bei mir vorab nichts ausgegeben ..


    Muß ich später mal versuchen, wenn ich an die Box komme.


    Danke!

  • daran scheitert's schonmal - wie macht man das? "

    Man stoppt lircd, liest die Manpage zu ir-keytable und dann legt man los: sudo ir-keytable -p RC-5 -c

    Dann sollte man mit sudo ir-keytable -t die Scancodes für Tastendrücke sehen können.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Das fand ich dazu noch ganz hilfreich: https://wiki.libreelec.tv/infrared_remotes


    Für den HomeBrew Empfänger am Serial-Port habe ich noch:

    Code
    1. setserial /dev/ttyS0 uart unknown
    2. modprobe serial_ir

    gesetzt.

  • super!


    via "ir-keytable -t" kommen die Tastendrücke sauber und zackig an:


    auch der kürzeste Druck auf der FB bringt sofort einen Eintrag!


    "eventlircd" mußte zusätzlich (+lircd) noch gestoppt werden.


    Danke für die Alternative! :] .. "keymap" muß ich noch erstellen, wenn mal Luft bleibt - mal schauen, ob ich's hinbringe.


    Gruß!

  • Saman : Danke für den Wink mit dem rc-core device!

    @seahawk: .. und dir für die weiterhelfenden Infos!


    cat /etc/rc_keymaps/harmony-one sieht nun manuell erstellt so aus:



    in /etc/rc_maps.cfg den Eintrag:

    Code
    1. serial_ir rc-rc6-mce /etc/rc_keymaps/harmony-one



    den link von /etc/lirc/lircd.conf

    auf

    /usr/share/lirc/remotes/yavdr/kls-1.6-lircd.conf


    hab ich zusätzlich entfernt.


    Es läuft jetzt wieder zackig (auch kodi) - nur "scrollen" geht nicht (repeat ..?). Also auf Up/Down im Menu/Channels/etc ..


    Gruß

  • .. da bin ich wieder - zu früh gefreut ?(


    Nach einem reboot gibt mir ir-keytable das hier aus (RC6):



    und es geht nichts. Die Konfigdateien sehen so wie o.a. aus. Wenn ich manuell lade, nimmt er die Einstellungen und es geht:

    Code
    1. sudo ir-keytable -c -w /etc/rc_keymaps/harmony-one
    2. Read rc-rc6-mce table
    3. Old keytable cleared
    4. Wrote 44 keycode(s) to driver
    5. Protocols changed to RC-5


    Jetzt kommt's - wenn ich dann reboote, übersteht es diesen und es geht immer noch. In dmesg/kern.log steht dann


    .. also zuerst RC6, dann wird auch RC5 initialisiert. Wenn's nicht funktioniert, steht nur RC6 - erst, wenn ich's dann manuell mache, kommt der Eintrag mit RC5.


    Was läuft denn da schief? :wand


    Gruß

  • .. schade. Stehe da immer noch an.


    Ich hab jetzt versucht, einfach in rc.local "ir-keytable -c -w /etc/rc_keymaps/harmony-one" aufzurufen, was aber auch nicht funktioniert hat (kann auch sein, daß ich die Syntax dort nicht ganz richtig habe). Müßte ich da ein mini-script machen und dieses dann in rc.local aufrufen.


    Irgendwie scheint es da (auch ohne den rc.local Eintrag) ein timing-Problem zu geben .. ?


    Gruß!

  • .. habe nun ein sleep vor dem Aufruf in rc.local getan

    Code
    1. /bin/sleep 15 && /usr/bin/ir-keytable -c -w /etc/rc_keymaps/harmony-one


    Jetzt funktioniert es auch nach jedem reboot. Ist zwar nicht ganz sauber ..


    Jetzt bleibt (hoffentlich) nur, das Problem zu lösen, daß man bei bleibenden Tastendruck durch längere Menülisten scrollen kann. Vllt geht das ja mittels Parameter -P (Sets the period to repeat a keystroke) von ir-keytable ..


    Gruß