Kein lirc device

  • [..] Fortsetzung vom letzten post:


    Prozesse sind in diesem Zustanf bzgl. lirc folgende aktiv:

    Code
    1. ps ax | grep -i lirc
    2. 519 ? S<s 0:00 /usr/sbin/eventlircd -f --socket=/var/run/lirc/lircd
    3. 532 ? Ss 0:00 /usr/bin/irexec /etc/lirc/lircrc
    4. 905 ? Ss 0:00 /usr/sbin/lircd


    In VDR geht damit gar nichts, aber mode2 gibt beim Drücken etwas aus - 3x Menu, 4x OK


    Also nun immer ein space zwischen den pulse. Das war vorhin anders. Dann hab ich einfach einmal lirc (ohne "d") gestartet, den link /etc/init.d/lirc --> lircd wieder entfernt und durchgebootet.


    Auf einmal funktioniert die Fernbedienung ohne Aussetzer, wenn man "sauber" drückt - man muß aber wesentlich länger auf eine Taste an der RC drücken, damit es stabil zu bedienen ist. Ist aber schon ein Fortschritt :tup


    Warum es jetzt funktioniert, kann ich nicht nachvollziehen.



    Jetzt muß ich noch herausfinden, wie man es etwas "empfindlicher" machen kann.


    Gruß!

  • Es gibt kein /etc/init.d/lirc

    Es gibt einen Upstart-Job (/etc/init/lircd.conf), der ist dafür gedacht lircd zu starten. Das SysV-Init Skript, die aus dem lirc-Paket stammt, wird IIRC durch ein Skript aus yavdr-utils entfernt.


    Wie sehen denn die Werte in der lircd.conf für den Decoder aus? Eventuell schwanken die Zeiten etwas zu stark als dass lircd das noch richtig interpretieren kann.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • .. also kann ich diese Meldung in dmesg irgnorieren?

    Code
    1. [ 4.148587] systemd-udevd[819]: failed to execute '/etc/init.d/lirc' '/etc/init.d/lirc restart udev': No such file or directory


    An die lircd.conf komme ich erst etwas später. Danke für's Reinschauen zu meinem Problem.


    Gruß

  • Ich vermute, dass das SysV-Init Skript durch das postinst-Skript eines lirc-Pakets wieder aktiviert wurde. Das sollte sich so wieder abschalten lassen:

    sudo /usr/sbin/update-rc.d lirc disable

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Zitat


    /etc/lirc/lircd.conf sieht so aus (standard "KLS-vdr-1.6" .. ?)


    Gruß

  • lircd.conf ist 2 posts vorab - ich glaub es ist die standard-mitgelieferte.


    Das Verhalten ist beim Bedienen so, daß man bei jeder Taste einmal lange/"sauber" drücken muß. Schnell "zappen" geht, nicht. Es fehlt "die erste Reaktion auf den Tastendruck". Wenn eine Taste an der RC gedrückt bleibt, wiederholt es auch lt. irw sauber und im OSD kann man auch von oben nach unten scrollen.


    .. wieder "gefühlt" beschrieben :O)

  • Hallo,


    was ich bzgl. lirc Problem nicht erwähnt hatte: die Fernbedienung (alte Harmony One) benimmt sich nur mit den vdr/lirc so eigenartig, alle anderen Devices (AVR / TV) lassen sich ganz normal bedienen.


    Hab das problem also leider immer noch.


    Gruß!