Ton bei Nutzung einer Soundbar asynchron

  • Hallo,

    ich bin mir nicht sicher, ob ich in diesem Unterforum richtig bin. Wenn es falsch sein sollte, bitte ich um Richtigstellung.

    Zum Problem:

    Unser alter Fernseher, Anbindung an die Grafikkarte des VDR über HDMI, brauchbare interne Lautsprecher, hat den Geist aufgegeben.

    Ein Sony KD-43XE7005 wurde gekauft und über HDMI angeschlossen. Soweit ok, aber der Ton über die Lautsprecher ist einfach nur grauenhaft.

    Daher kam eine Sony Soundbar HT-CT290 hinzu.

    TV über den Sat-Tuner des Fernseher und das Abspielen von DVDs mit einem DVD-Player sind in Ordnung.

    Bei der Nutzung des VDRs sind Bild und Ton bei manchen Sendern oder auch zeitweise asynchron.

    Ich habe noch kein System erkennen können. Mal ist der Unterschied minimal und man merkt es nicht, mal ist es so schlimm, dass ich die Soundbar ausschalten muss.


    Zunächst mal grundsätzlich die Frage:

    Ist das Problem überhaupt zufriedenstellend lösbar?

    Das HDMI-Signal des VDR scheint ja grundsätzlich ok zu sein. Es hat jahrelang mit dem alten Fernseher funktioniert.

    Der Fernseher alleine und in Verbindung mit einem DVD-Player am HDMI-Eingang funktioniert auch.

    Wo muss ich da suchen?

    Für Hinweise und Tipps wäre sehr dankbar. (Die Familie ist bereits recht ungehalten.)


    Vielen Dank im voraus,

    Norbert

  • Hi,

    dazu musst du noch mal deine Verkabelung beschreiben:

    Geht das HDMI direkt in den TV und von da in die Soundbar oder wie kommt das Signal in die Soundbar?


    Betrifft es Live-TV und/oder Aufnahmen? Was nutzt du? pulseaudio oder alsa mit welcher Config? Welches Ausgabeplugin?


    Welchen Grafiktreiber nutzt du an der GT630?


    Szeht beim Ruckeln was im log?


    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
    VDR5: Gigabyte
    GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
    VDR-User #1068 
    www.easyvdr.de 

  • Hallo Stefan,

    vielen Dank für die schnelle Antwort.


    HDMI geht von der Grafikkarte direkt zum TV. Vom TV gehen HDMI/ARC und optischer Ausgang zur Soundbar.


    Bei Live-TV sind Bild und Ton meistens recht synchron, bei VOX jedoch hinkte eben der Ton deutlich hinterher.

    Bei Aufnahmen scheint es eher schlimmer zu sein.

    Leider kann ich noch nicht sicher sagen, ob immer bestimmte Sender oder welche Sender betroffen sind.


    Die Ausgabe erfolgt über Softhddevide.


    Einstellung Audio: HDA NVidia - HDMI 1 (device: 7 - hw:CARD=NVidia,Dev=7)


    Es handelt sich nicht um Ruckeln. Im Fehlerfall ist der Ton dauerhaft gleichbleibend hinter dem Bild zurück.


    zum Treiber:

    Code
    1. myvdr@HD-VDR:~$ cat /proc/driver/nvidia/version
    2. NVRM version: NVIDIA UNIX x86_64 Kernel Module 367.57 Mon Oct 3 20:37:01 PDT 2016
    3. GCC version: gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3)

    Den VDR habe ich seit ca. einem Jahr nicht aktualisiert, es war ja mit dem alten TV alles bestens. (never touch .....)


    Ich hoffe die nötigen Infos aufgeführt zu haben.


    Gruß,

    Norbert

  • Hi,

    Hast du die Lautstärkeanpassung im softhddevice an? Also, dass du die Lautstärke am VDR ändern kannst? Oder geht nur an oder aus?


    Was nutzt du? alsa oder pulseaudio???


    Kanst du mal die easyvdr 3 LiveDVD testen?


    MfG,

    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
    VDR5: Gigabyte
    GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
    VDR-User #1068 
    www.easyvdr.de 

  • Ich habe die Sony HT-CT790 am VDR. Allerdings habe ich das HDMI vom VDR in den HDMI1 der Soundbar und den Ausgang der Soundbar dann mit einem HDMi-Kabel in den ACR/HDMI vom Fernseher. Ich habe keinerlei Tonverschiebung. Allerdings kann man an der Sony Soundbar eine Tonverschiebung einstellen, zumindest bei meiner. Schau mal in der Bedienungsanleitung.


    Bye, Klaus

    Alt:ASRock ION 330HT, 2xAverMedia Volar Black HD, yaVDR-0.2.0
    Neu:ASRock H61M,Celeron 530, 4GB Kingston RAM, ASUS GT610, 750GB, Silverstone Milo ML3,CIR mit Harmony 300i, yaVDR 0.5, Sundtek MediaTV Digital Home (DVB-C)

  • Hallo,


    stefan :

    Ich verwende die Lautstärkeeinstellung des TV, ein Foto der Einstellungen in softhddevice habe ich angefügt.

    HDA NVidia - HDMI 1 ist gewählt, d.h. kein Pulseaudio.

    Da der Fernseher ständig genutzt wird, kann ich im Moment nicht mit easyvdr testen.


    @Klaus:

    Bei der HT-CT290 handelt es sich um eine einfachere Ausführung, sie hat nur einen HDMI und einen optischen Eingang. Da habe ich bei der Verkabelung keine Wahl.


    Ohne VDR, d.h. Fernsehen mittel SAT-Tuner des TV und Audio über die Soundbar funktioniert fehlerfrei. Daher vermute ich, dass ich nur am VDR (Hardware oder Einstellungen) ansetzen kann.

    Mein Motherboard hat zwar einen optischen Ausgang, aber der scheint nicht aktiv zu sein. Weil eine Grafikkarte eingesetzt ist?

    Die Bedeutung der Audioeinstellungen in softhddevice sind mir ehrlich gesagt unklar. Damit habe ich mich bisher nicht beschäftigt, mit dem alten TV war ja alles in Ordnung.


    Ich hoffe, jemand kann mir einen Tipp geben.


    Gruß,

    Norbert

  • Hi,

    Äh, aber Lautstärkesteuerung Software heißt doch, dass er den kompletten Stream recodieren muss dafür, das kann das Problem schon sein!

    Wenn du es eh nicht nutzt. Stell mal um.

    MfG Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
    VDR5: Gigabyte
    GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
    VDR-User #1068 
    www.easyvdr.de 

  • Hallo,


    ich bein erst jetzt dazu gekommen, mich mit meinem Problem zu befassen.


    Das Umstellen der Lautstärkesteuerung von Software auf Hardware hat nichts verbessert.

    Auch habe ich versuchsweise an den anderen Audio-Einstellungen wie Pass-Through, PCM, AC3 usw. geändert, ohne Erfolg. Leider sind mir Hintergrund und Zusammenhänge der einzelnen Einstellungen nicht klar. Daher wäre es Zufall, wenn ich die richtige Kombination finden würde.


    Folgendes ist mir bei den Videoeinstellungen aufgefallen:

    Wenn ich den Fernseher neu erkennen lasse, wird eine Auflösung von 3480 * 2160 bei 24 Hz gewählt. Das führt zu massiven Bild- und Tonstörungen.

    Eigentlich klar, dir GT630 kann nur 2560 * 1600,

    Einzig die Einstellung 1920 * 1080 bei 50 Hz führt zu einem brauchbaren Bild.

    Fragen:

    Muss / sollte die Grafikkarte die Auflösung des TV beherrschen?

    Gibt es eine aktuelle Empfehlung für den VDR? (GT 730 oder GT 1030?)


    Gruß,

    Norbert

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von noppi59 ()

  • Hi,

    4K TVs sind derzeit einfach nur sinnloses Hype-Zeug mangels 4K Quellen... Also muss der TV alles hochskalieren... Damit ist die Bildqualität, die ja besser sein soll, wahrscheinlich dank schlechterer Hw Skaler eher schlechter statt besser als ein normaler Full-HD TV. Aber das nur am Rande...


    Die Einstellung Full-HD ist schon ok.

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 512MB PCIe x1 | v2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 750GB F1, GT730, 2x TT DVB-S2-3200) easyVDR 2.3
    VDR5: Gigabyte
    GA-G31M-S2L (Intel E2140, Zotac GT220 512MB + Zalman VNF100, Digitainer2-Geh., t6963c 6 " gLCD, 750GB F1, Sundtek DVB-C + Satelco DVB-C) easyVDR 1.0
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT 3200 | easyVDR 2.3 64bit
    VDR-User #1068 
    www.easyvdr.de 

  • Hallo,

    leider habe ich mein Problem noch nicht beseitigen können.

    4K TV mag vielleicht wenig sinnvoll sein, aber nun steht er da und mit dem SAT-Tuner des TVs und der Wiedergabe von DVDs oder Blurays gibt es keinen asynchronen Ton.

    Daher möchte ich nochmals fragen, welche Einstellungen in softhddevice oder an anderen Stellen des VDR richtig sind.

    Das Umstellen der Lautstärkesteuerung von Software auf Hardware hat nichts verbessert.

    Auch habe ich versuchsweise an den anderen Audio-Einstellungen wie Pass-Through, PCM, AC3 usw. geändert, ohne Erfolg. Leider sind mir Hintergrund und Zusammenhänge der einzelnen Einstellungen nicht klar. Daher wäre es Zufall, wenn ich die richtige Kombination finden würde.

    Durch Veränderung der Einstellung Audio/Video Verzögerung (ms) ist es kurzfristig möglich, Bild und Ton synchron zu bekommen. Das ist dann leider nur für eine Sendung oder einen Spielfilm korrekt. Mal ist eine Einstellung von -700 passend, dann sind es +300.


    Da der Unmut der Familie steigt, hoffe ich, dass mir jemand weiterhelfen kann.


    Vielen Dank im voraus,

    Norbert

  • Habe dazu mal ne frage, Softwaresteuerung durch Software, wer kodiert das dann, die GPU oder die CPU?

    Ich nutze das auch, ggf könnte das ja bei mir abhilfe der UnSyncronität schaffen.

    Gruß Martin (linuxdep)

  • Hallo Martin,


    ich habe deinen Beitrag gerade erst gelesen. Welcher Art sind denn deine Probleme mit der Synchronität von Bild und Ton?


    Ich habe aufgegeben, mir sind die Zusammenhänge und die Bedeutung der Einstellungen leider unklar.


    Hier noch einmal mein aktueller Stand:

    TV und Soundbar werden vor dem VDR eingeschaltet.

    Nach dem Einschalten des VDR sind Bild und Ton bei einem Drittel dieser Vorgänge mehr oder weniger asynchron.

    Mit Einstellungen zwischen -900 und +500 kann der Fehler berichtigt werden.

    Dieser Zustand bleibt bis zum nächsten Ausschalten erhalten.


    Der VDR ist auf aktuellem Stand.

    Durch das vor mehr als einem Monat vorgenommene Update ist das OSD, wie an anderer Stelle im Forum beschrieben, extrem langsam geworden.


    Ich bin völlig ratlos.


    Gruß Norbert