[Gelöst] rpihddevice & Raspbian Stretch - EGL/OpenVG Fehler

  • Hallo,


    ich habe neulich auf Raspbian Stretch aktualisiert und seit dem Probleme mit der OSD Darstellung des rpihddevice - es kommt keins. Im syslog ist folgendes dazu zu finden:



    Die Videoausgabe funktioniert jedoch prima. Offenbar hat sich was an den EGL/OpenVG libs geändert!?? Gibt es dafür schon eine Lösung?


    Danke & Gruß, ollo

  • Hast du das Plugin nach der Aktualisierung mal neu gebaut?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Problem erkannt und gebannt :strike1


    Ich habe hier 2 verschiedene libEGL installiert. Eine kommt aus dem libegl1-mesa package (libEGL.so) und eine aus dem libraspberrypi0 package (libbrcmEGL.so). Im Makefile des rpihddevice wird bei LDLIBS "-lEGL" verwendet. Das habe ich auf "-lbrcmEGL" geändert und neu gebaut - schon funzt es wieder :strike2 Offenbar kommen sich die 2 libs sonst in die Quere.


    Gruß, ollo