epgd: Crash nach "Ignoring unexpected season line"

  • Bei mir stürzt epgd zwar nicht ab, aber nach dem einen Update behauptet er

    Code
    1. Sep 13 19:19:14 banana epgd[2045]: 45 series to update in db, 9 episodes to update in db
    2. Sep 13 19:19:27 banana systemd[1]: epgd.service: main process exited, code=killed, status=11/SEGV


    Doch doch, Seg-Fault an der exakt gleichen Stelle...
    Mach in /etc/egpd.conf das epg scrapen aus, dann fängt er sich erstmal wieder.

    Stefan

  • Alles muß man selber machen...


    Code
    1. 1505584995.015 523 127.0.0.1 TCP_MISS/200 1165 GET http://thetvdb.com/api/E9DBB94CA50832ED/series/281470/actors.xml - HIER_DIRECT/104.16.227.14 text/xml
    2. 1505584995.351 204 127.0.0.1 TCP_MISS/301 367 GET http://thetvdb.com/banners/fanart/original/281470-23.jpg - HIER_DIRECT/104.16.227.14 -
    3. 1505584996.474 1120 127.0.0.1 TCP_MISS/200 216807 GET https://www.thetvdb.com/banners/fanart/original/281470-23.jpg - HIER_DIRECT/104.16.231.14 image/jpeg


    Bibliotheken (gegen libcurl4-openssl-dev gelinkt), sollte man vor der Verwendung auch initialisieren, das vermeidet "Out of Memory" Fehler ...



    Grüße,
    Stefan

  • Alles muß man selber machen...

    Du hast nicht zufälligerweise Lust auch noch die Umstellung auf die Version 2 der API zu machen, damit das Ding über den 1. Oktober hinaus nutzbar ist (vgl. dezenter Hinweis auf https://www.thetvdb.com/wiki/index.php/Programmers_API)? :saint:

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • @Fourty2


    Merci,Merci! :tup


    Gruss

    Wolfgang

  • Cool, danke für den Patch, bei mir gehts auch wieder.

    SAT Hardware: Gibertini SE75 | DuraSat Dur-Line UK-24 | DD OctopusNET V2 Rack (Firmware 1.0.80 Beta) mit MaxS8
    Server: Asus M5A78L-M/USB3 | Sempron 145@2Cores | 8GB ECC RAM | PicoPSU | Debian Jessie 64Bit | Linux Kernel 4.4 | VDR 2.2.0 mit SAT>IP, epgsearch, streamdev, epg2vdr, vdr-epg-daemon
    Clients: RaspberryPI 2/3 | Yocto Poky Linux (Openembedded) 2.2+git | Linux Kernel 4.9+git | VDR 2.2.0 mit SAT>IP, RpiHDDevice, SkinDesigner, Remote, Graphlcd-ax206dpf, RemoteTimer, Extrecmenu, NeutrinoEPG, Femon, Mlist


    R.I.P: Gigaset M740 mit VDR von open7x0.org

  • Alles muß man selber machen...

    Super, vielen Dank! Seit zwei Tagen läuft's wieder.:]


    Stefan

  • Da mein epgd auch abstürzt habe ich die Source von Frodo main heruntergeladen den Patch eingespielt.


    Aber es kommt dieser Fehler (mit oder ohne Patch.)


    Wie bekomme ich den Fehler weg?

    Code
    1. Copy failed: No such file or directory at /usr/share/dh-exec/dh-exec-install-rename line 28, <> line 2.
    2. dh_install: problem reading debian/mysql-plugin-epglv.install:
    3. make[1]: *** [override_dh_install] Error 127
    4. make[1]: Leaving directory `/usr/src/vdr-epg-daemon-1.1.122'
    5. make: *** [binary] Error 2
    6. dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
    7. root@VM-Ubuntu-Trusty:/usr/src/vdr-epg-daemon-1.1.122#
  • Hi,


    Paket liegt doch im main PPA!

    https://launchpad.net/%7Eyavdr…ield.series_filter=trusty


    Gruss

    Wolfgang

  • der Patch hilft bei Frodos PPA nur wenn man auch auf libcurl4-openssl-dev wechselt.


    von daher Vorsicht bei "apt-get build-dep vdr-epg-daemon", das installiert dir wieder das installiert dir wieder das nss Paket

     CKone: yavdr 0.6.1/2.3.8 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr 0.6.1/2.3.8 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.3.8 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, Digital Devices MaxS8, Samsung 840 EVO 120GB, 3x WD Red WD30EFRX 3TB in SW Raid5