xinelibout plugin klemmt (cXinelibServer::Play Buffer overflow ()

  • Hallo,


    seit einiger Zeit (leider weiß ich nicht genau seit wann), habe ich das Problem, dass das xinelibout plugin (meistens) hängt. VDR meldet dann die folgenden Fehler:


    Aug 20 02:05:12 xxx vdr[18788]: [18801] [xine..put] cBackgroundWriterI initialized (buffer 2048 kb)
    Aug 20 02:05:12 xxx vdr[18788]: [18801] [xine..put] cTcpWriter initialized (buffer 2048 kb)
    Aug 20 02:05:12 xxx vdr[18788]: [18801] [xine..put] Pipe open
    Aug 20 02:05:21 xxx vdr[18788]: [18804] [xine..put] cXinelibServer::Play Buffer overflow (TCP/PIPE)
    Aug 20 02:05:21 xxx vdr[18788]: [18804] [xine..put] cXinelibServer::Play Buffer overflow (TCP/PIPE)
    ... (viele, viele Wiederholungen der Fehlermeldung)
    Aug 20 02:05:21 xxx vdr[18788]: [18804] [xine..put] cXinelibServer::Play Buffer overflow (TCP/PIPE)
    Aug 20 02:05:25 xxx vdr[18788]: [18804] [xine..put] cXinelibServer: Too many TCP buffer overflows, dropping client
    Aug 20 02:05:25 xxx vdr[18788]: [18804] [xine..put] cXinelibServer::Play Write/Queue error (TCP/PIPE)
    Aug 20 02:05:25 xxx vdr[18788]: [18804] [xine..put] Closing connection 0


    VDR version 2.3.8 (auch mit 2.3.2, 2.2.0 )
    xine-lib: 1.2.8 (also 1.2.6)

    (current gentoo distribution, Hauppauge DVB-T2 adapters)


    Meistens dauert es mehrer Minuten, bis sich der Player (vdr-sxfe) dann doch eine Verbindung aufbauen kann. Den Sender aufzeichnen und die Aufzeichungen wiedergeben funktioniert sofort.


    Hier nochmal als Bugreport: https://sourceforge.net/p/xineliboutput/bugs/88/


    Irgendeine Idee, woran das liegen könnte?


    Vielen Dank für jede Hilfe

    Joachim

  • ... ich würde vielleicht mal mit den Parametern im Config-File des vdr-sxfe spielen ...

    das File liegt bei mir im Home-Verzeichnis

    vim /home/ulrich/.xine/config_xineliboutput

    soweit ich mich erinnere, kann man Buffer dort einstellen, aber ob der Fehler im Plugin oder im vdr-sxfe liegt, weiß ich nicht genau ....


    Grüße

    Ulrich

  • Danke, genau das war das Problem. Mit diesen Settings geht es: (in config_xineliboutput):

    Code
    1. # number of audio buffers
    2. # numeric, default: 230
    3. engine.buffers.audio_num_buffers:750
    4. # number of video buffers
    5. # numeric, default: 500
    6. engine.buffers.video_num_buffers:500