softhddevice <> 4k Auflösung <> skindesginer - OSD Problem

  • Hallo,


    ich versuche gerade, meine neue GT1030 mit 4k-Auflösung unter MLD 5.4 Testing zum Laufen zu bekommen. Dabei stelle ich einen merkwürdigen Effekt im OSD fest:


    Unter HD funktioniert alles bestens. Ich nutze erfolgreich Skindesigner, alles sieht gut aus:




    Wenn ich dann aber den Screen auf 4k umschalte (alles andere sonst bleibt gleich), sieht das OSD SO aus:




    Kommt vielleicht softhddevice nicht mit der 4k-Auflösung klar - oder woran könnte es liegen...?


    Gruß...


    ...Hagen

  • Hi,


    wie sieht es mit LCARS aus?


    Gruss

    Wolfgang

  • Man muss im Source von softhddevice den OSD Puffer vergrößern. Ansonsten wird nichts mit 4k.

    Vielleicht ist deine Version schon gepatcht?


    Code
    1. static const uint8_t OsdZeros[1920 * 1200 * 4]; ///< 0 for clear osd

    und

    Code
    1. if (OsdWidth * OsdHeight > 1920 * 1200) {
    2. Error(_("video/vdpau: osd too big: unsupported\n"));
    3. return;
    4. }


    Ansonsten OSD fest auf 1920x1080 stellen und dann auf 4k skalieren.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Guter Hinweis - führt direkt zum Erfolg. Ich hab das OSD auf 1920x1080 gestellt - danach sah alles wieder ok aus :-). Danke!


    Jetzt muss ich nur noch rausfinden, wieso ein initialer Start unter 4k-Auflösung immer zu einem schwarzen Bildschirm im Softhddevice führt... Der Ton ist zu hören - nur das Bild bleibt schwarz. Nach einem VDR-Neustart ist alles wie gewünscht...

  • Was steht denn dabei im Log?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Na ja - eher nicht so ergiebig: