Yavdr Neuinstallation mit kompletten Frodo testing-vdr-dev

  • Hi,
    ich möchte einen neuen Yavdr aufsetzen, als Basis das aktuelle 0.6.1 und gleich sauber auf frodos ppa vdr-testing-dev wechseln.
    Ich weis das es viele Probelem geben soll wenn sich packages aus verschiedenen Quellen mischen.
    Wie kann ich das am besten verhindern?
    Wie ist das beste vorgehen um von Anfang an auf ein anderes PPA zu wechseln? Sicherslich hat Frodo auch nicht das ganze Yavdr in seinem ppa, zb. die yavdr-utils...


    Hintergrund ist, das ich zwingend eine VDR Version > 2.3.4 wegen meinen beiden CAM´s benötige. Ausserdem gibts erst ab dieser version die MTD Unterstützung

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Per apt Pinning, kannst Du das Problem lösen.


    Zum Beispiel die folgende Datei anlegen:
    vi /etc/apt/preferences.d/testing-vdr-dev.pref

    Code
    1. Package: *
    2. Pin: release o=LP-PPA-frodo-vdr-main
    3. Pin-Priority: 1004
    4. Package: *
    5. Pin: release o=LP-PPA-frodo-vdr-testing-vdr-dev
    6. Pin-Priority: 1400


    Das hinzufügen der beiden PPAs ist natürlich auch nötig:

    Code
    1. add-apt-repository ppa:frodo-vdr/main
    2. add-apt-repository ppa:frodo-vdr/testing-vdr-dev


    Ich möchte aber darauf hinweisen, dass das meine Test PPAs sind und ich diese sehr häufig ändere und auch in Zustände versetze in den diese nicht funktionieren.
    Das heißt wenn bei einem Update auf einmal alles kaputt ist nicht wundern.


    Oder Patches nicht mehr im VDR enthalten sind wodurch dann einige Plugins nicht mehr gehen.


    Ich werde demnächst alle für mich nicht nötigen Patches entfernen, da diese nicht gepflegt werden und / oder die Stabilität des VDRs beeinträchtigen könnten.


    Im speziellen betrifft das:

    Code
    1. # vdr-2.3-patch-for-permashift.diff
    2. # opt-61_dynamite.patch
    3. # vdr-2.3.4_zapcockpit.patch

    Gruß
    Frodo

  • Nur zur Info:
    Ich bin jetzt wieder (fast) aktiv am Entwickeln und nehme mir meine beiden Patches (hide-first-recording-level und dynamite) vor, damit sie mit vdr 2.3.x wieder laufen.


    Lars.

  • ich möchte einen neuen Yavdr aufsetzen, als Basis das aktuelle 0.6.1 und gleich sauber auf frodos ppa vdr-testing-dev wechseln.


    vorher habe ich noch von stable auf testing gewechselt, da sonst das softhddevice-openglosd nicht funktioniert.

  • bin diese und nähste Woche noch im Urlaub. Danach setze ich mich hier ran und hoffe das es alles glatt läuft. Mein VDR ist nämlich kurz vor dem Urlaub irgendwie kaputt gegangen - keine DVB Karte wurde auf einmal mehr erkannt. Egal, mit den CIs hat es sowiso nicht sauber funktioniert.

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Hi,
    ich nehme jetzt das Projekt "VDR Upgrade auf 2.3.7 von Frodo testing-vdr-dev" in Angriff.
    Beim dist-upgrade ist mir folgendes aufgefallen, ist das normal? ICh habe aktuell ein yavdr-stable installiert, die preferences habe ich wie oben gesetzt. Ich setze gerade anstatt von einer Neuinstallation auf mein bestehendes System auf. Ist das ein Problem?


    Code
    1. Die folgenden Pakete werden durch eine ÄLTERE VERSION ERSETZT (Downgrade):
    2. libplatform1 libxine1-xvdr vdr-addon-avahi-linker vdr-plugin-avahi4vdr
    3. vdr-plugin-dbus2vdr vdr-plugin-dvbhddevice vdr-plugin-dvbsddevice
    4. vdr-plugin-menuorg vdr-plugin-pvr350 vdr-plugin-softhddevice vdr-plugin-xine
    5. vdr-plugin-xineliboutput

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Ja, das kann durchaus vorkommen, wenn die Build-Nummern in Frodos PPA niedriger sind.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,
    habe bis auf das Paket yavdr-utils alles suber aktualisiert bekommen. Dieses aber macht probleme. Habt ihr einen Hinweis wie ich das lösen kann damit das Konfigurationsfrontend hinterher immer noch läuft?


    Edit: ich habe die beiden tntnet Dateien gelöscht, vorher aber gesichert.
    Hbe auch gerade gesehen das die in Frodos PPA nicht vorhanden ist. Wird die nicht mehr benötigt? Hängt da nicht das Konfig-Webfrontend dran?

    Code
    1. rm /etc/tntnet/tntnet.xml*

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von Tobias ()

  • Hi,
    ich muss nun doch eine Neuinstallation auf Basis des aktuellen 0.6.1 ISO´s durchführen - und danach mit Apt-Pinning und Dist-Upgrade von Frodos testing-vdr-dev PPA weiter machen
    Probleme nach dem DistUpgrade waren:
    * ich konnte mich nicht mehr remote per SSH einloggen, Connection refused
    * nach dem booten blieb er im im Login Screen hängen. Probleme mit softhddevice, obwohl ich die neue softhddevice.conf ohne den -D Parameter installiert hatte.

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Schau dir mal an, welche Abhängigkeit die Installation von yavdr-utils verhindert - ohne das hast du keinen X-Server und keine aus Templates generierten Datein.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ausser yavdr-essential habe ich nichts angepasst und dieses Paket liegt in meinem PPA.


    Wenn ssh und andere Dinge nicht funktionieren ist was an der Grund Installation im argen.


    Beim Update mit meinen PPAs kann es durchaus auch dazu kommen das die Basis Pakete von yavdr entfernt werden - das sollte zwar nicht passieren...


    Durch ein beherztes installieren der beim Update entfernten yavdr Pakete wurde bei mir aber immer alles wieder korrigiert.


    Zum Beispiel:

    Code
    1. apt-get install yavdr-essential yavdr-utils

    Gruß
    Frodo

  • Hi,
    nach einer Neuinstallation und ein dist-upgrade von frodos ppa funktioniert alles perfekt mit meinen CAMs, MTD und mit einem VDR 2.3.7 :)
    Zwischendurch wollte er zwar immer wieder "veraltete" Pakete, zb. yavdr-utils, deinstallieren, da habe ich aber aufgepasst nichts zu löschen :)


    Jetzt muss ich nur noch feintunen. Der Wechsel zwischen meinen Cams mit MTD und und ddci funktioniert mit diesem VDR nun perfekt :)

    :vdr1 VDR User #626:fans
    VDR II: YeongYang A106, Fusi D1522, Celeron 2GHz, Frontend per DVB-s FF, 2xDVB-c, ATRIC-IR, YaVDR 0.3a
    VDR III HDTV: Inter-Tech 2008V mit iMonLCD, Atric, ASRock Extreme3 770 AM3, AMD Sempron 140 1x 2.70GHz AM3, 1,5TB WD15EADS, 2TB WD20EARS, 2x4GB DDR3-1600, NVidia GT520 passiv, 3x DVB-c, YaVDR 0.5 @ Samsung PS-50B550

  • Hallo,

    habe ebenfalls über den Weg unter Posting #2 auf vdr 2.3.8 geupdatet. Passt soweit auch alles. Allerdings habe ich nun keine EPG-Daten mehr.

    Ich habe zuerst per


    Zitat

    svdrpsend CLRE

    alte EPG-Daten gelöscht, da unvollständig, nun erhalte ich jedoch keine neuen EPG-Daten.

    Grundsätzlich würde mir das Standard-EPG der 0.6.1 genügen. Wie erhalte ich das wieder zurück?

    Danke

    GT


    P.S.:

    Falls zu sehr OT bitte Info. Dann mache ich einen eigenen Thread auf.


    EDIT:

    Problem gelöst, habe epg2vdr und scraper2vdr deaktiviert, nun kommen auch die EPG-Daten!

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von GT86 () aus folgendem Grund: Problem gelöst

  • Hallo Frodo,


    macht es sehr viel Umstände das skinflatplus Plugin mit in dein ppa aufzunehmen?

    Ich habe gesehen, dass vdrmanager neuerdings mit dabei ist.

    Vielen Dank dafür.

    Seitdem Streamdev mit dem ddci2 harmoniert und der vdr die Timer zum server schickt, habe ich mal auf 2.4.0 upgedatet.

    Es war wirklich noch nie so einfach für mich mit dem yavdr als Grundlage und deinem ppa ein sehr aktuelles System zu erhalten.

    Mir reicht als Oberfläche der skinflatplus.

    Er ist einfach aufgebaut und ich kann die Wörter noch aus der Ferne erkennen.

    Im Hauptmenu zeigt er mir meine Timer und verfügbare Updates an.

    Mehr brauche ich nicht.

    Noch besser als das deb in dein ppa zu stellen, wäre für zukünftige Anfragen eine Anleitung, wenn es nicht zuviel Mühe macht.

    Hardware: Zotac D2550ITXS-B-U / DD Max S8 / LCD Phillips 47 PFL8404H | Soft: yavdr 0.62 mit frodo-vdr/main, testing-vdr-dev

  • gp2000

    Ich habe das Plugiin skinflatplus in mein PPA vdr-testing-dev kopiert, es baut gerade.


    Mit einem eigenen PPA im Launchpad kannst Du dir ganz einfach Deinen eigenen VDR basteln, vorrausgesetzt die Pakete lassen sich bauen.

    Einfach das VDR Paket als erstes bauen lassen und dann alle von dir benötigten Plugins hinzufügen. Wenn Du aber den yaVDR als Grundlage verwendest mußt Du noch alle Pakete hinzufügen welche für yaVDR nötig sind.


    In kurzen Worten zu erklären wie man Pakete baut und ein eigenes PPA erstellt ist nicht so einfach. Da mußt Du dich schon selbst mit beschäftigen.


    Gruß
    Frodo

  • Das Paket ist fertig gebaut funktioniert aber nicht, ich bekomme damit einen segfault.

    Ich fürchte da mußt Du mir eine Quelle nennen die das Paket für VDR 2.4 und Trusty funktionierend gebaut hat.

    Gruß
    Frodo

  • Danke ,

    der Fehler könnte in Zusammenhang mit softhddevice-openglosd auftreten.

    Mit dem softhddevice startet der vdr bei mir und läuft im Moment beschwerdefrei.

    Das es mit dem ppa nicht so einfach ist, habe ich mir schon gedacht.

    Deshalb werde ich noch lange ein treuer Kunde deines ppa's sein.

    Jetzt aber erst die WM schauen.


    Gruß

    gp2000

    Hardware: Zotac D2550ITXS-B-U / DD Max S8 / LCD Phillips 47 PFL8404H | Soft: yavdr 0.62 mit frodo-vdr/main, testing-vdr-dev

  • Hallo,


    ich hänge mich mal hieran.

    Ich habe gestern auch mal auf obige PPAs gewechselt. Installation lief auch problemlos durch.

    Nun habe ich aber einen segfault im skindesigner

    Code
    1. [ 52.810115] vdr[1273]: segfault at 0 ip 00007f334957f992 sp 00007ffc9c5e9fc0 error 4 in libvdr-skindesigner.so.2.4.0[7f3349508000+15d000]

    Irgendeine Idee? Wie man die Ursache herausfinden kann und den Fehler beseitigen?


    EDIT: segfault ist verschwunden, habe das Plugin nochmal neu installiert.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von ofenheizer ()

  • Hallo Frodo,


    da ich Anzeigeprobleme mit dem shady_kiss habe, hat mich Tomas darauf aufmerksam gemacht, dass in Deinem testing-dev eine veraltete Version des skindesigner liegt. Aktuell ist die 1.2.7.

    Kannst Du das evtl. auf den neuesten Stand bringen?


    Danke.


    Markus

  • Woran erkenne ich das die Version veraltet ist bzw. woher soll eine neuere kommen?

    Soweit ich weis habe ich bei mir die aktuelle Version skindesigner (1.2.7) - Skin Designer.

    Welches PPA und welches Ubuntu verwendest Du von mir?

    Gruß
    Frodo