[gelöst] VDR-Live zeigt seit einiger Zeit keine Bilder mehr von epgd an

  • Hallo Leute,


    seit einigen Monaten zeigt VDR-Live keine Bilder mehr. Nun hab ich mich mal drann gemacht und nach dem Fehler gesucht. Schaut alles gut aus, nur das vdr selbst mit dem Liveplugin die Option für die Bilder nicht mehr kennt. Hab das nämlich mal manuell aufgerufen:

    Code
    1. /usr/bin/vdr --watchdog=60 --device=0 --cachedir=/var/cache/vdr --log=1 --video=/vdr-aufnahmen --record=/usr/share/vdr/bin/vdrrecord-gate.sh --plugin=sc --plugin=streamdev-server -r /usr/share/vdr/streamdev/externremux.sh --plugin=live --epgimages=/var/cache/vdr/epgimages --cert=/etc/vdr/plugins/live/live.pem --key=/etc/vdr/plugins/live/live-key.pem -i 0.0.0.0 --plugin=vnsiserver --plugin=epgsearch --plugin=vdrmanager -p6420 -Pgeheim -k /etc/vdr/plugins/vdrmanager/vdrmanager.pem -c --plugin=epg2vdr


    Dann sieht man die Meldung:
    /usr/bin/vdr: Unbekannte Option »--epgimages=/var/cache/vdr/epgimages«



    Auch ein -e /var/cache/vdr/epgimages hilt da nichst, es kommt zwar keine Fehlermeldung, der VDR startet dann aber gar nicht mehr. Also Option habe ich die Images in der Datei "/etc/conf.d/vdr.live" gesetzt.

    Code
    1. # directory for epgimages LIVE_EPGIMGDIR="/var/cache/vdr/epgimages/"



    Wa kann denn hier der Fehler liegen? Ich hab schon sehr viel herum gesucht und Beiträge gelesen. Aber dieses Problem scheint niemand zu haben. Hier noch ein paar Systeminfos:

    • Gentoo
    • vdr 2.2.0-r1
    • vdr-live 0.3.0_p20130504-r1


    lg
    looking111

    System: Gentoo VDR auf Proxmox virtualisiert im LXC
    Digital Devices Cine S2 V6.5

    Kodi 18.x mit VNSi

    The post was edited 1 time, last by looking111 ().

  • Wa kann denn hier der Fehler liegen?

    Bei deinem manuellen VDR-Aufruf hast du vergessen den Pluginnamen und die Argumente per Quoting zusammenzufassen - statt

    Code
    1. /usr/bin/vdr --watchdog=60 --device=0 --cachedir=/var/cache/vdr --log=1 --video=/vdr-aufnahmen --record=/usr/share/vdr/bin/vdrrecord-gate.sh --plugin=santaclaus --plugin=streamdev-server -r /usr/share/vdr/streamdev/externremux.sh --plugin=live --epgimages=/var/cache/vdr/epgimages --cert=/etc/vdr/plugins/live/live.pem --key=/etc/vdr/plugins/live/live-key.pem -i 0.0.0.0 --plugin=vnsiserver --plugin=epgsearch --plugin=vdrmanager -p6420 -Pgeheim -k /etc/vdr/plugins/vdrmanager/vdrmanager.pem -c --plugin=epg2vdr


    Musst du den Plugin-Namen und die Argumente für das Plugin so verpacken, dass sie als Wert von --plugin= aufgelöst werden (zur besseren Lesbarkeit habe ich es mal auf mehrere Zeilen verteilt):

    Code
    1. /usr/bin/vdr --watchdog=60 --device=0 --cachedir=/var/cache/vdr --log=1 \
    2. --video=/vdr-aufnahmen \
    3. --record=/usr/share/vdr/bin/vdrrecord-gate.sh \
    4. --plugin=santaclaus \
    5. --plugin="streamdev-server -r /usr/share/vdr/streamdev/externremux.sh" \
    6. --plugin="live --epgimages=/var/cache/vdr/epgimages --cert=/etc/vdr/plugins/live/live.pem --key=/etc/vdr/plugins/live/live-key.pem -i 0.0.0.0"
    7. --plugin=vnsiserver \
    8. --plugin=epgsearch \
    9. --plugin="vdrmanager -p6420 -Pgeheim -k /etc/vdr/plugins/vdrmanager/vdrmanager.pem -c" \
    10. --plugin=epg2vdr

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Wow cool, du hast ja sogar mehr als ein Bild in Live, hatte immer nur eins.


    Update: Hab nun die neueste Liveversion die es in Portage gibt installiert: 0.3.0_p20130504-r2
    Danach wurde Config ein wenig abgeändert, die Option heist jetzt EPGIMAGES_DIR und es wurde nun auch richtig mit gestartet. Nur leider gibt es jetzt kein Webinterface mehr, weder am am SSL Port noch am normalen. Supa.


    Nachtrag: Anscheinend ist die Version faul. Auch wenn ich alles auskommentiere, kann ich vdr-live nicht mal am VDR selbst aufmachen. Toll. Ich mach ein Downgrade und versuch die Dinge manuell aufzurufen.

    System: Gentoo VDR auf Proxmox virtualisiert im LXC
    Digital Devices Cine S2 V6.5

    Kodi 18.x mit VNSi

  • Also im Moment hab ich keine Ahnung was bei mir abgeht... ich habe jetzt sämtlich VDR Pakte neu kompiliert. Alle Plugins deaktiviert die sich deaktivieren lassen. Und trotzdem geht jetzt auch die alte vdr-liveversion nicht mehr. Ich wusste ich hätte es einfach nicht angreifen dürfen. Das Zeug ist einfach zu empfindlich. Nach jedenfalls habe ich im Log dann diese Meldung aufgeschnappt:

    Code
    1. /usr/lib64/vdr/plugins/libvdr-live.so.2.2.0: undefined symbol: _ZNK3tnt9Urlmapper7mapCompERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEES8_


    Also ich schätze mal das mich das sowieso irgendwann getroffen hätte.


    Nachtrag: Nachdem ich diese Lib vom Backup zurück gespielt hatte, funktionierte das Interface sofort wieder, sehr krass, das sich beim Kompiliervorgang was geändert hat. Der Manuelle Aufruf zeigte auch sofort in Bilder an. Ich teste mal weiter.


    lg

    System: Gentoo VDR auf Proxmox virtualisiert im LXC
    Digital Devices Cine S2 V6.5

    Kodi 18.x mit VNSi

    The post was edited 1 time, last by looking111 ().

  • So läuft :)


    Hab nun wieder die aktuelle Version in Portage gebaut und die Lib vom Backup drüber kopiert. Nun wird auch die Variable von der Configdatei (EPGIMAGES_DIR) erkannt.


    @3PO


    Darf man fragen was du gemacht hast das du mehr wie ein Bild in Live siehst? In EPGD sehe ich mind. 2. Schätze mal da musst man die Anzahl in der egpd.conf noch weiter erhöhen? Hab dort "GetEPGImages = 4"


    lg :)

    System: Gentoo VDR auf Proxmox virtualisiert im LXC
    Digital Devices Cine S2 V6.5

    Kodi 18.x mit VNSi

  • Siehst Du, damit hast Du Deine Frage, weshalb bei Dir nur ein Bild angezeigt wird, schon selbst beantwortet. ;)

    Ja gut, ich stell jetzt wirklich mal auf epgdata.com um. Die 18 Euro im Jahr sind auf jeden Fall ok wenn die Leistung passt.


    lg

    System: Gentoo VDR auf Proxmox virtualisiert im LXC
    Digital Devices Cine S2 V6.5

    Kodi 18.x mit VNSi

  • Moin,
    laut Screenshot [EPG: DVB/TVSP], also sind die Daten von TV Spielfilm.


    Cheers,
    Ole

    The post was edited 1 time, last by OleS ().

  • Moin,
    laut Screenshot [EPG: DVB/TVSP], also sind die Daten von TV Spielfilm.


    Cheers,
    Ole

    Ja das hatte ich überlesen. Also Epgdata ist voll der Schrott. Hab das bezahlt, ist aber nicht mal nen Euro Wert. Da ist TVM viel besser. Da gibt es viel Daten wie z.B. die Sternchen für Spannung/Action usw. Hätt ich mir jetzt eigentlich nicht gedacht. Das es für TV Spielfilm ein Plugin gibt ist mir noch garnicht aufgefallen. Werd ich mal das Internet rüber befragen und dann wohl nen neuen Thread aufmachen wenns nicht tut.


    Danke und lg

    System: Gentoo VDR auf Proxmox virtualisiert im LXC
    Digital Devices Cine S2 V6.5

    Kodi 18.x mit VNSi

  • Nur mal so ein Tipp am Rande...


    Da Du ja Gentoo verwendest, könntest Du ja mal einen Blick in mein Overlay werfen. ;)

    Ja Danke. Dein Overlay hatte ich natürlich schon eingebunden. Irgendwo muss ja schließlich auch der epgd her ;)
    TVSP ladet bereits... mal sehen, wird wohl ein wenig dauern. Datenbank hab ich mir einfach nicht zu löschen getraut, das letzte mal hab ich dann fast 4 Tage gebraucht bis das Teil wieder lief. Passt dann irgendwas mit der Codierung nicht mehr. Naja, theoretisch sollten ja innerhalb der Frist (17 Tage) alle alten Daten verschwunden sein.


    Nachtrag: Hab den Cache gelöscht und die Zeit auf 3 Tage heruntergesetzt. Hab jetzt auch 4 Bilder :) :) :) Super geil!
    Man merkt die Unterschiede. Bei epgd sehr wenig Info, bei TVM viel Info nur ein Bild dafür riesiges DVD Cover, bei tvsp: viele Bilder dafür klein. Hat eben alles sein vor und Nachteile.


    lg
    und noch nen schönen Abend

    System: Gentoo VDR auf Proxmox virtualisiert im LXC
    Digital Devices Cine S2 V6.5

    Kodi 18.x mit VNSi

    The post was edited 2 times, last by looking111 ().