WiFi-Calling bei Drillisch mit iPhone 6S

  • Ich versuche seit Wochen, mit meinem iPhone 6S (iOS 10.3.1) "WiFi-Calling" zum Laufen zu bringen, leider ohne Erfolg.


    Das WiFi-Calling ist auf dem iPhone aktiviert und ich habe auch einen Tarif, bei dem das (ohne die "Message+Call WiFi" App) gehen soll (https://www.discoplus.de/tariffs/discoplus-flat-l1000).


    Es werden auch IP-Pakete auf den Ports 500 und 4500 gesendet (in beiden Richtungen):


    aber weder erscheint in der Statuszeile oben "Wi-Fi" neben dem Namen des Providers, noch kann ich telefonieren, wenn ich keinen Handy-Empfang habe (zum Testen auf "Flugzeugmodus" geschaltet und dann WLAN wieder eingeschaltet).


    Weiß hier vielleicht jemand, was da schiefläuft?
    Der Support meines Providers ist, gelinde gesagt, unterirdisch (auf jede Antwort muß man eine Woche oder länger warten - und dann kommen doch nur Standard-Textbausteine...).


    Klaus

  • Dort steht "...die UDP-Ports 500 und 4500 müssen ausgehend erlaubt werden". Das ist der Fall, und es gehen ja offensichtlich auch Paket hin und her. Ich weiß echt nicht, was ich sonst noch machen sollte.


    Klaus

  • Benutzt hier vielleicht jemand (erfolgreich) WiFi-Calling (egal mit welchem Handy bzw. Provider) und könnte mal an geeigneter Stelle ein

    Code
    1. tcpdump -i wlan1 port 500 or port 4500


    ("wlan1" natürlich durch das entsprechende Interface ersetzen)
    machen und das Handy einschalten (ohne einen Anruf zu tätigen), um zu sehen, ob da mehr kommt als das hier


    Klaus

  • Hallo Klaus,


    ich habe ein iPhone 6s und als Provider O2. Flugmodus an,Wlan an und ich habe oben Wlan stehen und Wifi calling geht.


    Kenne mich jetzt mit tcpdump nicht aus.


    Habe hier einen Mac der im gleichen Wlan ist. bei tcpdump -i en1 port 500 oder tcpdump -i en1 port 4500 tut sich nichts ... (wenn das so richtig ist ?!?)



    Code
    1. tcpdump -i en1 port 500
    2. tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    3. listening on en1, link-type EN10MB (Ethernet), capture size 262144 bytes



    Imac -> Wlan -> Fritz Box 7490
    iPhone 6s -> Wlan -> Fritz Box 7490

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D

  • Im gleichen WLAN zu sein reicht da leider nicht. Es müsste schon ein Rechner sein, durch den die Pakete durchlaufen, etwa der Router (also die FritzBox).


    Aber zumindest schon mal gut zu wissen, daß es bei jemandem mit iPhone 6S und O2 geht.


    Klaus

  • Kann zwar inhaltlich nicht weiterhelfen, auf eine Fritzbox existiert aber die Servicefunktion Paketmitschnitt, erreichbar unter folgender URL im Browser http://fritz.box/support.lua



    Zum Auswerten wird dann Wireshark benötigt...

  • Ich schau mir das mal an. Würde dir eine pm schicken Klaus falls Bedarf ?

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D

  • mail ist raus

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D

  • Was lange währt wird endlich gut!

    Nachdem das Problem nun zu einer Lösung gekommen ist, möchte ich das Ganze hier kurz zusammenfassen - vielleicht ist es ja für den einen oder anderen interessant.


    Ich habe inzwischen ein halbes Jahr lang immer wieder beim Drillisch-Support nachgehakt (wie üblich im14-Tage-Takt zwischen Frage und Antwort). Immer wieder wurde mir gesagt, daß bei denen alles OK sei und der Fehler bei mir liegen würde. Schlußendlich hieß es dann, daß bei meinem Tarif Wifi-Calling grundsätzlich nicht möglich ist - was mir anfangs aber ausdrücklich zugesagt worden ist.


    Eine per Email erhaltene Aufforderung, ich solle doch den Support bewerten, habe ich erstmal ignoriert, denn ich dachte mir "das wollt ihr nicht!" ;-). Als die Email dann aber nochmal kam, habe ich ihnen den Gefallen getan - "Sechs! Setzen!".


    Einige Tage danach kam dann ein Anruf der Hotline (war wohl eine höhere Eskalationsstufe ;-) mit der Frage, warum ich denn so unzufrieden mit dem Support gewesen sei. Nachdem ich der netten Dame am Telefon dann die Geschichte erzählt hatte, rief mich ein Kollege von ihr an und offerierte mir einen anderen Tarif. Bei dem geht jetzt Wifi-Calling, und zusätzlich habe ich auch noch LTE, Flatrate in alle deutschen Netze, SMS-Flatrate, und statt 1GB Freivolumen satte 3GB! Und das Beste: er kostet nur halb so viel wie mein bisheriger! Und er ist ebenfalls monatlich kündbar!


    Falls jemand so einen Tarif sucht: https://www.premiumsim.de, nennt sich LTE2000 und hat normalerweise 2GB Freivolumen, aber bis 1.10. gibt es 1GB gratis dazu. Kostet 9.99 Euro. Gibt's auch als LTE3000 (bis 1.10. mit 4GB) für 12.99.


    Disclaimer: ich habe keinerlei Beziehung zu diesem Anbieter (ausser, daß ich dort Kunde bin) und poste das hier nur, weil mir der Tarif als sehr günstig erscheint und damit definitiv Wifi-Calling funktioniert. Vielleicht ist es ja für jemanden interessant.


    Klaus

  • Ich habe eben LTE3000 geordert und teste dann mal die Anbindung in unseren Gefilden... Kann man ja nicht allzu viel falsch machen bei monatlicher Kündigung. Sollte es zufriedenstellend sein, spare ich auch eben mal die Hälfte!


    Danke für den Tip!

  • Welches netz nutzen die denn? Ich hab versucht, das auf den Seiten zu finden, ohne Erfolg. Bei uns funktioniert nämlich nur D1 richtig.

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert) 

  • Welches netz nutzen die denn? Ich hab versucht, das auf den Seiten zu finden, ohne Erfolg. Bei uns funktioniert nämlich nur D1 richtig.

    Die Drillisch Online AG nutzt nur Telefonica, also O2. Siehe hier: https://www.premiumsim.de/ueber_uns

  • Dann kommt das für mich nicht in Frage, bei uns wechselt O2 tagsüber in das e-Netz, somit habe ich keinen Empfang ca. von 9-21.00 Uhr.

    Schöne digitale Welt.

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)