Gerüchte um GT1030 mit HEVC (30W TDP)

  • Hi,
    läuft softhddevice, mit 1030 und Treiber 381 ?


    Unter mld bekomme ich kein Bild. Bildschirm wird nichtmal erkannt.


    Mit log:
    MLD 5.3 / 5.4 stable/testing/unstable Nvidia 1030 kein Bild



    http://www.minidvblinux.de/forum/index.php?topic=8452

    yavdr 0.61 testing SilverStone GD04S, Intel DH77EB, Intel G1610 CPU, 4GB RAM, Zotac Nvidia GTX-630 ,Corsair 4GB, Be quiet! BN140 System Power7, Samsung 830 SSD
    4 DVB-C Tuner L4M-Flex + Twin CT. Qnap TVS-873 per NFS als Aufnahmefreigabe.Per HDMI an Denon AVR-4300H/LG OLED 65B6D

  • Bei mir tut es das in der Kombination aus ffmpeg 3.3.1, softhddevice-vpp und dem NVidia Treiber 381.22 unter xenial mit dem Kernel 4.8.


    Was mich bei deiner Logsammlung wundert ist, dass die xorg.conf nur eine einzige Zeile mit einem Kommentar enthält - kann man bei der MLD eventuell mal nvidia-xconfig laufen lassen?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi!


    läuft softhddevice, mit 1030 und Treiber 381 ?

    Ja, User(Maw) von uns - easyVDR-3.0(trusty), Kernel 4.11.2, gcc-5, ffmpeg-3.3.0, patched dkms & bbswitch, softhddevice-vpp und nvidia-381.22 ...Empfang nur DVB-T2!
    Ich selbst warte auch meine 1030!


    Gruss
    Wolfgang

    TT S2-6400 - saa716x kompilieren unter 20.04(Focal)

  • Keiner mitm 3.16ner Kernel unterwegs ;/ schade ...


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO 860 Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 11 + Kodi 19 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 500 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Lenovo T430 |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info | www.bike2change.de

  • Debian 9 mit dem Kernel 4.9 ist doch frisch rausgekommen, damit besteht kein Grund auf einem alten Kernel zu hocken ;)

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • naja, für mich schon, da ich mein debian 8 ziemlich umgebaut habe und mit dem update noch ein wenig warten wollte ( kostet mich bestimmt 3-4 Tage bis alles wieder so läuft wie jetzt mit D8 ) und nicht bei dem wetter 4 Tage mitm Keyboard am Server gefesselt sein wollte ...


    Nun gut dann gibs im herbst das D9 Update mit der GT 1030 - sollte bis dahin auch etwas günstiger worden sein ;)


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO 860 Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 11 + Kodi 19 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 500 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Lenovo T430 |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info | www.bike2change.de

  • ich suche nun schon ne ganze zeit nach infos ob der nvidia 381ger Treiber zwingend einen linux kernel 4.X vorausetzt oder ob der Treiber noch mit den 3.16ner läuft ?! Hat da jmd Infos zu ?


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO 860 Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 11 + Kodi 19 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 500 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Lenovo T430 |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info | www.bike2change.de

  • Bitte nicht gleich lynchen, aber ich stecke nicht drin: Kann man mit der GT1030 4K-Sender über den VDR empfangen? Falls ja, sind noch weitere Bedingungen zu erfüllen?

    Intel NUC 10 NUC10i3FNH, Digital Devices Octopus NET V2 Max M4, 1000 GB Samsung 970 Evo M.2 2280 PCIe 3.0 x4 NVMe, LG OLED 77CX9LA

  • 4k Empfang ist sogar ohne Grafikkarte mölich :D


    Wiedergabe soll aber mit der GT 1030 ebenfalls gehen.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Davon würde ich lieber nicht ausgehen, für UHD ist meines Wissens nach bei den Pascal-GPUs kein HEVCMain10 Decoding freigeschalten bzw. in VDPAU erst gar nicht implementiert. Und VDPAU scheint ja laut sämtlichen Quellen (zB phoronix) ohnehin nicht weiterentwickelt werden.
    Keine Ahnung wie es momentan bei AMD aussieht, mit Intel klappts jedenfalls sowohl unter Softhddevice und Kodi per VAAAPI, leider noch nicht mit yavdr oder easyvdr, da die Ubuntubasis zu alt ist.

    VDR
  • Hallo speefak,


    inux yavdr-oben 3.13.0-125-generic #174-Ubuntu SMP Mon Jul 10 18:51:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    root@yavdr-oben:/home/xbmc# nvidia-smi
    Thu Jul 27 19:55:03 2017
    +-----------------------------------------------------------------------------+
    | NVIDIA-SMI 384.47 Driver Version: 384.47 |
    |-------------------------------+----------------------+----------------------+
    | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
    | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
    |===============================+======================+======================|
    | 0 GeForce GT 1030 Off | 00000000:02:00.0 On | N/A |
    | 45% 45C P8 ERR! / 30W | 135MiB / 1996MiB | 16% Default |
    +-------------------------------+----------------------+----------------------+


    +-----------------------------------------------------------------------------+
    | Processes: GPU Memory |
    | GPU PID Type Process name Usage |
    |=============================================================================|
    | 0 1216 G /usr/bin/vdr 56MiB |
    | 0 1392 G /usr/bin/X 76MiB |
    +-----------------------------------------------------------------------------+


    Gruß/Bongo-007



    VDR-Server: yaVDR 0.6/Softdevice ,ASRock Q1900M,RAM: 4Gb,HDD:5Tb SATA,
    Digital Devices Cine S2 5.5 + DuolFlex,Zotac GeForce GT 1030,Ton über HDMI->AV Receiver Marantz 1506 (HDMI 2.0) ,MS TECH 1200,Sony KD-65XD8505 (UHD)
    Client1: Libreelec,Zotac GeForce GT 630, RAM: 4Gb, HDD 2Tb SATA, ACER Beamer +Samsung TFT,
    Ton über SPDIF->AV Receiver Yamaha
    Client2: Libreelec;HP-Rechner
    Client3: Libreelec;NoName-Rechner
    Client4: Android-Tablet, Kodi

  • Bongo 007, das sieht ja super aus, jetzt lässt mich nc17 Post aber wieder zweifeln was die Darstellung von UHD Empfang angeht, die gt 1030 läuft mit netflix 4K aktuell wohl auch nicht. Ist die Frage ob es nur an der Software liegt oder die Hardware da Probleme macht.


    Angesichts der Speicherersparnis mit dem HEVC Codec gegenüber h264 würd ich gerne jetzt schon mein VDR mit ner gt 1030 aufrüsten, und dann könnt ich nativ 4K schauen. Hat jmd folgende Karte im Einsatz : https://de.msi.com/Graphics-ca…-LP-OC.html#hero-overview ? DP 1.4 HDMI 2.0 und kein DVI kommt mir sehr gelegen :]


    Server : Debian 10 + VDR 2.4.0 on | HP Gen8 Microserver G1610T | 8 GB EEC DDR 1600 | 1 x EVO 860 Pro 240GB, 2x6TB HGST, 2x3 TB WD Red | TBS 6981
    Client : Debian 11 + Kodi 19 (deb.multimedia Quellen) on | Intel DH77EB | i3 2100T | 16 GB 1600 DDR3 | GF GT 520 | 1 x 850 EVO 500 GB | BQ 300W L7 | X10 Remote | in Zalman HD 160 | Sedu Ambilight |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Asus Z87 Pro | I5 4660 | 16 GB 1600 DDR3 | GF GTX770 | 1 x 850 EVO 500 GB | BQ 450 W L8 | in Chieftech CS 601 |
    Client : Debian 10 + Kodi 19 (deb.multimedia Quellen) on | Lenovo T430 |


    Websites | speefak.spdns.de | www.itoss.org | cc-trade.info | www.bike2change.de

  • Ich habe die Karte in meinem Testsystem mit DVB-T2 Empfang, mit den aktuellsten Treibern läuft die im TV-Betrieb unauffällig. Bei Netflix hängt es soweit ich das mitbekommen habe an DRM-Geschichten - ob sich da in Zukunft etwas für KODI ergeben wird, bleibt abzuwarten.
    Die Wiedergabe von 10-Bit 4k HEVC-Material (z.B. von http://www.4ktv.de/testvideos/ ) mit VDPAU-Unterstützung klappt bekanntermaßen nicht, mit mpv und cuvid/cuda als Decoder ist es kein Problem (wenn man aktuelle Softwarestände statt uralten Debian-Paketen verwendet):

    Code
    1. mpv --hwdec=cuda --vo=opengl ok_Sony_4K_HDR_Camp.mp4

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    The post was edited 1 time, last by seahawk1986 ().

  • cuvid/cuda als Decoder


    Das ist der Grund, warum ich erst einmal auf die Intel Apollo Lake GPU gesetzt hab, wer weiß ob und wann Softhddevice und Kodi cuvid unterstützen. ?(

    VDR
  • Keiner mitm 3.16ner Kernel unterwegs ;/ schade ...


    Grundsätzlich geht ein 3.16-Kernel mit den 381er Treibern von NVIDIA. Habe es in einer VM mit einer GTX1050 TI getestet.

    HD-VDR 1&2 : Asrock N68C-S UCC, ASUS EN210 Silent, Boot IDE CF-Card, /srv auf SATA Samsung 3TB
    HD-VDR 1 : Sempron145, yavdr 0.4, TeVii S480 V2.1 DVBs2 Dual
    HD-VDR 2 : Sempron140, yavdr 0.5, DD Cine S2 V6.5 + DuoFlex S2
    Server (im Aufbau): Asrock B75M R2.0 mit i5-3470T sowie Zotac GT970 & DD Cine S2 V6.5 für Gastsysteme
    - Host: Manjaro-XFCE mit 4.4er Kernel mit qemu und virt-manager

  • Die Wiedergabe von 10-Bit 4k HEVC-Material mit VDPAU-Unterstützung klappt bekanntermaßen nicht, mit mpv und cuvid/cuda als Decoder ist es kein Problem (wenn man aktuelle Softwarestände statt uralten Debian-Paketen verwendet):

    Wenn ich das jetzt richtig verstehe, dann ist das kein spezielles Problem der GT1030 sondern ein generelles Problem von VDPAU!
    Sehe ich das so richtig?


    Weiß denn jemand, ob seitens Nvidia oder wem auch immer, daran gearbeitet wird, dass zukünftig auch VDPAU mit 10bit-HEVC umgehen kann?


    @seahawk,
    gibt es in deinem Beispiel mit dem 4k-10bit-HDR-Demo von Sony über VDPAU überhaupt kein Bild, oder wird dann auf 8bit runtergerechnet?


    Paul

  • Wenn ich das jetzt richtig verstehe, dann ist das kein spezielles Problem der GT1030 sondern ein generelles Problem von VDPAU!
    Sehe ich das so richtig?

    Ja, und NVidia scheint da nicht mehr allzu viel Energie reinzustecken, nachdem VDPAU nur mit X, aber nicht mir Wayland funktioniert.

    gibt es in deinem Beispiel mit dem 4k-10bit-HDR-demo von Sony über VDPAU überhaupt kein Bild, oder wird dann auf 8bit runtergerechnet?

    Ich habe keinen 4k Fernseher, der 10 Bit darstellen kann, aber KODI fällt in dem Fall generell auf den Software-Decoder zurück, was bei einer zu schwachen CPU dann eben ein stark ruckelndes Video bedeutet.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • @seahawk,
    hhhmm, dann ist also für 4k und HDR alles was VDPAU ist nicht zukunftssicher. X(


    Mit den von Dir genannten anderen Treibern "cuvid/cuda" bin ich momentan gar nicht vertraut und habe davon noch nicht viel gehört.
    Besteht denn in Zukunft die Wahrscheinlichkeit das diese Treiber dann in Ubuntu respektive yaVDR etc. eingebaut werden?


    Paul

  • Mein Testsystem läuft aktuell mit Ubuntu 16.04 und mpv hatte ich aus diesem PPA: https://launchpad.net/~mc3man/+archive/ubuntu/mpv-tests - die Pakete in dem PPA scheint es auch für trusty zu geben.


    Ob sich die KODI-Entwickler oder jemand für Softhddevice die Mühe machen wird cuvid/cuda zu integrieren, kann ich nicht abschätzen - ffmpeg beherrscht es prinzipiell.


    Interessanterweise soll die GT 1030 unter Windows nicht für Netflix in 4k genügen: https://nvidia.custhelp.com/ap…ix-content-on-nvidia-gpus

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)