[wieder da] [skindesigner] syslog quillt über mit "detacher thread thread started/ended"

  • Hallo!


    Mir fällt seit längerer Zeit auf, dass mein Syslog alle paar Minuten mit Meldungen wie "detacher thread thread ended (pid=1230, tid=11792)" oder "detacher thread thread started (pid=1230, tid=11804, prio=high)" geflutet wird.
    Ich kann zwar keinerlei Beeinträchigungen im VDR-Betrieb feststellen, aber es "nervt" halt.


    Hier ein beispielhafter syslog-Auszug:

    Weiß jemand was diese Meldungen verursacht?
    Und wie ich das abstellen kann, ohne auch andere wichtige Meldungen im syslog zu verpassen?
    Oder deuten die Meldungen auf ein Problem hin, das eigentlich nicht ignoriert, sondern behoben werden sollte?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von davie2000 ()

  • Und wie ich das abstellen kann, ohne auch andere wichtige Meldungen im syslog zu verpassen?

    In der rsyslog-Dokumentation findest du unter anderem Filter, um Meldungen vom Log auszuschließen:

    Code
    1. man rsyslog.conf


    Ich denke, die Meldung könnte vom skindesigner-Plugin stammen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Heute bist du aber wieder mal extra schnell, mit guten Antworten am Start :tup


    Skindesigner? Interessant! Werde mal mit verschiedenen Logleveln experimentieren, um das herauszufinden.
    Danke für den Tipp mit rsyslog.conf - werd ich mir anschauen, wenn ich die Meldungen nicht "sauber" loswerde.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Skindesigner? Interessant! Werde mal mit verschiedenen Logleveln experimentieren, um das herauszufinden.

    Die Meldung selbst kommt vom VDR, aber der "detacher thread" scheint vom Skindesigner zu kommen: https://projects.vdr-developer…coreengine/animation.c#n8

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Alles klar.
    ==> Kann bitte ein Mod den Thread nach "Skins" oder "Plugins" verschieben? Bin mir nicht sicher, wo mein Thread besser aufgehoben ist. Danke!


    Update:
    Die Meldung wird mittlerweile erfolgreich ignoriert durch Anlegen einer neuen Datei /etc/rsyslog.d/51-detacher.conf mit folgendem Inhalt:
    :msg,contains,"detacher thread thread" ~

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von davie2000 ()

  • Mir ist gerade aufgefallen, dass ich leider das gleiche Problem wieder habe :-(

    Das Ignorieren der Meldung (via /etc/rsyslog.d/51-detacher.conf siehe oben) funktioniert offenbar nicht mehr.


    Hat jemand eine Idee, wie ich die Meldung dauerhaft loswerde? Idealerweise direkt in den skindesigner-Einstellungen.

    Bzw. weiß viell. jemand, was mir die Meldung sagen will?

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

  • Ich habe jetzt regex etwas weiter gefasst, aber die Meldungen tauchen nach wie vor (regelmässig) im syslog auf.


    /etc/rsyslog.d/51-detacher.conf:

    :msg, contains, "thread thread started" ~


    /var/log/syslog (Auszug):

    Feb 9 07:36:05 myVDR vdr: [2333] animator thread thread started (pid=31291, tid=2333, prio=high)

    Feb 9 07:36:07 myVDR vdr: [2336] detacher thread thread started (pid=31291, tid=2336, prio=high)

    ...

    Feb 9 07:36:23 myVDR vdr: [2369] detacher thread thread ended (pid=31291, tid=2369)

    Hätte mir erwartet, dass nur mehr die "ended"-Meldunge stehen bleiben - ist aber leider nicht so.


    dann kommt aber auch das vor (uhrzeitlich etwas später):

    Feb 9 07:38:02 myVDR vdr: [2622] detacher thread thread ended (pid=31291, tid=2622)

    Feb 9 07:38:02 myVDR vdr: [2623] detacher thread thread ended (pid=31291, tid=2623)

    Feb 9 07:38:02 myVDR vdr: [2612] detacher thread thread ended (pid=31291, tid=2612)

    Da schauts wieder so aus, als wären die "started"-Meldungen erfolgreich ignoriert worden - ich kenn mich nimma aus :-(


    Was mache ich falsch?


    Danke schon jetzt für eure hilfreichen Antworten!

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD