MLD 5.3 testing, Kein Fernbedienungsempfänger "rpi on gpio" mit installiertem Paket dvb-mb möglich.

  • Hallo Gemeinde,


    Leider drehe ich mich hier im Kreis mit der Einrichtung einer Fernbedienung.


    Da die Fernbedienung meines MyGica USB DVB_C/DVB-T2 Sticks nicht so schick ist (und vom im Moment noch nicht so toll vom Treiber unterstützt wird) dachte ich mir -- nichts ist einfacher als einen TOSP an den Pi hängen, beliebige FB nehmen und schon läuft es.


    Nur leider schließen sich die Pakete dvb-mb (für den USB-DVB-C/DVB-T2 - stick nötig) und rc-core (für rpi on gpio nötig) aus irgendeinem Grund gegenseitig aus. (Bei Installation des einen Pakets wird automatisch das andere gelöscht.


    gibt es eine Möglichkeit, das MLD System zu überlisten und beide Pakete zu Installieren ? Oder hat jemand andere Zielführende Ideen ?


    Vielen Dank


    pc-medusa

  • Hallo pc-medusa,


    für die Fernbedienung in der MLD musst du das Paket mld-remote installieren.Das zieht noch einige abhängige Pakete nach. Anschließend kannst du die Fernbedienung über das Webinterface über System/Konfiguration/Fernbedienung konfigurieren. Als Lirc-Treiber musst du dort "rpi on GPIO" wählen. Falls du eine funktionsfähige lircd.conf hast, kannst du diese nach /etc kopieren. Dann brauchst du im Webinterface nichts weiter auswählen. Falls nicht, schau mal unter LIRC Fernbedienung, ob deine in der Liste dabei ist.


    Viel Erfolg und viele Grüße skippy

  • Hallo Skippy,


    Mit dem Paket mld-remote hatte ich es zuerst versucht. Leider wird da nach installation der "rpi on gpio" nicht im WebIF angeboten bei Einstellungen, Fernbedienung. Meine Vermutung der Treiber wird jetzt als Kernelmodul über das rc-core geladen.


    Jedenfalls hat der "rpi on GPIO" nach der Installation von rc-core funktioniert. Nur eben mein DVB-Stick nicht mehr, da dvb-mb automatisch deinstalliert wurde


    pc-medusa

  • Hm, sorry, da kann ich dir leider nicht helfen. Hier muss sich ein Entwickler der MLD äußern, was da schief läuft und wie das bereinigt werden kann.


    Viele Grüße skippy

  • Hi,


    so wie es ausschaut hat der Treiber im dvb-mb Paket einen anderen Namen. Ich habe das lirc Paket entsprechend angepasst, dass es auch diesen nutzen kann.
    Du kannst es also nach einem Update noch mal mit dem dvb-mb Paket versuchen.


    Claus

    MLD 5.4 mit vdr 2.4.1 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.4 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT

  • Hallo Claus,


    Leider funktioniert es immer noch nicht mit dem Paket dvb-mb.


    Im WebIF wird zwar jetzt der "rpi on gpio" angeboten, und offensichtlich auch der korrekte Eintrag in der /boot/config.txt gemacht. Laut lsmod wird gpio_ir_recv geladen. Ab da hört es aber auch schon auf.


    Anscheinend wird der gpio-ir nicht korrekt eingebunden. Start lirc bringt "Starting lirc for GPIO failed"


    Alles getestet mit frischer "Netzwerkinstallation Client" IR ging bis zur Installation von bvb-mb.


    pc-medusa

  • Hallo Claus,


    Hatte mal wieder etwas Zeit mich mit dem Problem zu beschäftigen.


    Die Lösung ist eigentlich ganz trival -- Da sich der Treiber geändert hat muß auch der Eintrag in der /boot/config.txt angepasst werden.
    Bei mir steht jetzt statt (bei rc-core) dtoverlay=lirc-pi (dvb-mb) dtoverlay=gpio-ir


    pc-medusa

  • Hi,


    Danke für die Recherce. Ich hab unser Setup so angepasst, das dies in Zukunft gleich richtig gesetzt wird.


    Claus

    MLD 5.4 mit vdr 2.4.1 - lirc yaUSBir - Octopus NET S2 - SCR - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - WD Green 12TB HDD - SanDisk 64GB SSD - Lian Li PC-C37B - Samsung LE40A559
    MLD 5.4 mit vdr 2.4 - Raspberry Pi 3 - rpihddevice
    MLD 5.4 mit Squeeze Play - Raspberry Pi 2 - 32GB SD - 7" Touch TFT