[gelöst] yavdr 0.6.1 - SSD & NVIDIA Chipsätze (hier C51PV)

  • Hi,


    nachstehend ein paar Informationen, falls noch jemand das Problem mit der Nachrüstung einer SSD und einem älteren NVIDIA Chipsatz (hier C51PV) hat.


    Ziel war der Einsatz einer SSD auf einem Fujitsu Esprimo E5615 (mit dem besagten/betagten NIVIDIA Chipsatz).
    Die Neu-Installation von yavdr 0.6.1 lief ohne Schwieigkeiten durch.
    Die spezifischen Einstellungen konnten alle über die Web-Oberfläche eingestellt werden. Bild und Ton waren sofort verfügbar.


    Schnell fiel auf, das die Schreibgeschwindigkeit auf das per NFS angeschlossene NAS-System nicht mehr ausreichte, eine HD Sendung aufzuzeichnen (FTA).
    Die Beobachtung der Netzwerklast mittels nload (nload -u M) ergab, dass mit der SSD keine gleichmäßige sondern eine eher unregelmäßige Last auf der per NFS angebundenen Neztwerkstrecke erzeugte wurde.
    Im syslog tauchten dann die folgenden Fehlermeldungen auf:


    Code
    1. ...
    2. vdr: [9133] i/o throttle activate
    3. ...
    4. vdr: [9133] buffer usage: 70% (tid=9132)
    5. vdr: [9133] buffer usage: 80% (tid=9132)
    6. vdr: [9133] buffer usage: 90% (tid=9132)
    7. vdr: [9134] buffer usage: 100% (tid=9133)
    8. vdr: [9133] ERROR: 1 ring buffer overflow (177 bytes dropped)
    9. ...


    Ein Wechsel zurück auf die alte HDD zeigte, dass mit der HDD locker 4 HD Sendungen parallel aufgezeichnet werden konnten.
    Die Netzwerklast (nload) zeigte eine durchgehende konstante Last, die mit jeder zusätzlichen Aufnahme entsprechend stieg.


    Recherchen ergaben, dass der NVIDIA Chipsatz bei Anschluss von SATA III (6Gbps) Laufwerken auf SATA I (1.5Gbps) zurückschaltete.
    Allerdings sollten auch 1.5 Gbps ausreichen, um den Datenstrom auf dem NAS-LW abzulegen.
    Laut 'dmesg'und dem syslog wurde die SSD auch automatisch mit 1.5 Gbps angesteuert.


    Die Lösung war, den Linux Kernel explizit dazu aufzufordern, die SSD nur mit 1.5 Gbps anzubinden.
    Der Kernel Bootparameter hierzu lautet "libata.force=1.5G, noncq".

    Der Zusatz 'NONCQ' ist bei unserem System erforderlich, um sporadische Bootverzögerungen der SSD auf grund vermeintlicher Lesefehler (err=0) abzustellen.


    Interessant war, dass der Fehler erst bei den ersten Aufnahmen auf das per NFS angeschlossenen NAS-System sichtbar wurde.
    Einzelne Aufnahmen auf der SSD selbst, zeigten dieses Verhalten nicht (vielleicht auch Zufall).
    Zuerst vermutete ich einen Defekt (Kabelbruch, etc.) auf der Netzwerkseite oder einen NFS Konfigurationsfehler.
    Erst der Vergleich mit zwischen SSD und HDD führte dazu, den vermeintlichen NFS Fehler auf die Systemanbindung der SSD und damit den NVIDIA Chipsatz zurückzuführen.


    Viele Grüße
    Bernhard

    yaVDR 0.6.1
    FSC Esprimo E5615 (SSD, DVD Writer)
    Mystique SaTIX S2 Dual v1 - PNY Quadro 410
    Logitech Harmony One - Profil VDR-1.6-KLS - serieller Empfänger