[gelöst]mplayer keine Lautstärkeregler

  • Hallo Gemeinde,


    nach fast abgeschlossenen Umstieg meiner yavdr 6.1 mit neuer Hardware. ist noch ein Punkt offen.


    Mplayer Plugin läuft nur ist keine Lautstärkeregelung möglich.(konstante Lautstärke).
    D.h Vdr und dvd Player klappen ohne Probleme (interner Regler).


    Es handelt sich wahrscheinlich um eine Einstellung dieser Parameter??


    /usr/share/vdr-plugin-mpayer/mplayer


    Code
    1. export DISPLAY=:1
    2. CMDLINE="/usr/bin/mplayer -osdlevel 1 -vo vdpau -vc ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau,ffodivx, -fs -monitoraspect 16:9 -ao alsa:device=hw=NVidia.7 -cache 8192 -slave -nolirc -ontop yes -v -noconfig all -idx"AUDIOSET="/usr/bin/iecset audio 1"FILE="$1"$AUDIOSET$CMDLINE "$FILE"



    Meine Sound / Videokarten


    Code
    1. root@yavdrns:/home/ns# aplay -Lnull Discard all samples (playback) or generate zero samples (capture)pulse PulseAudio Sound Serverhdmi:CARD=NVidia,DEV=0 HDA NVidia, HDMI 0 HDMI Audio Outputhdmi:CARD=NVidia,DEV=1 HDA NVidia, HDMI 1 HDMI Audio Outputdmix:CARD=NVidia,DEV=3 HDA NVidia, HDMI 0 Direct sample mixing devicedmix:CARD=NVidia,DEV=7 HDA NVidia, HDMI 1 Direct sample mixing devicedsnoop:CARD=NVidia,DEV=3 HDA NVidia, HDMI 0 Direct sample snooping devicedsnoop:CARD=NVidia,DEV=7 HDA NVidia, HDMI 1 Direct sample snooping devicehw:CARD=NVidia,DEV=3 HDA NVidia, HDMI 0 Direct hardware device without any conversionshw:CARD=NVidia,DEV=7 HDA NVidia, HDMI 1 Direct hardware device without any conversionsplughw:CARD=NVidia,DEV=3 HDA NVidia, HDMI 0 Hardware device with all software conversionsplughw:CARD=NVidia,DEV=7 HDA NVidia, HDMI 1 Hardware device with all software conversionsroot@yavdrns:/home/ns#
    2. root@yavdrns:/home/ns#root@yavdrns:/home/ns# cat /proc/asound/devices 1: : sequencer 2: [ 0- 7]: digital audio playback 3: [ 0- 3]: digital audio playback 4: [ 0- 0]: hardware dependent 5: [ 0] : control 33: : timerroot@yavdrns:/home/ns#





    Beim abspielen (verschiedener mkv Filme) wird der Ton konstant über HDMI zum TV ausgegeben.
    Werden die vdr internen Regler zur Lautstärkeänderung betätigt so bleibt die Lautstärke konstant.
    Ich sehe dann nicht die SKIN Lautstärkeregler sondern eine Balkendiagramm.


    Alsamixer zeigt nur pcm und SPDIF Regler.




    Verschiedene Parameter ausprobiert -mixer-channel. Ich weiß nicht ob es überhaupt eine Möglichkeit gibt.


    Falls es nicht geht muß ich dann komplett auf Lautstärkeregelung vom TV umstellen??


    Hat jemand eine Idee? Vielen Dank.

    YAVDR 0.6.1 Testing Softhddevice mit


    Board ASRock H61M, Intel Celeron G530 2,4 GHZ und 4 GB Speicher


    Video – Karte GeForce GF 119,
    TV Karte Dual Octupus SAT
    2TB Festplatte und DVD Brenner

    The post was edited 1 time, last by nosch ().

  • So schaut's bei mir aus.


    ..."-softvol"...


    Gruß
    Stefan


    Code
    1. CMDLINE="/usr/bin/mplayer -aspect 16:9 -vo vdpau -vc ffh264vdpau,ffmpeg12vdpau,ffvc1vdpau,ffwmv3vdpau, -ao alsa:device=hw=0.7 -softvol -cache 8192 -slave -quiet -idx -fs"
  • Hallo, Super Super das wars.


    Vielen Dank ;-))


    :] :] .

    YAVDR 0.6.1 Testing Softhddevice mit


    Board ASRock H61M, Intel Celeron G530 2,4 GHZ und 4 GB Speicher


    Video – Karte GeForce GF 119,
    TV Karte Dual Octupus SAT
    2TB Festplatte und DVD Brenner