[gelöst] Fehler im syslog: "... saa7146 ... vpeirq: used x times >80% of buffer (xxx bytes now)"

  • Seit dem letzten update & dist-upgrade habe ich immer wieder solche Fehler im Syslog:

    Code
    1. Feb 14 09:18:41 myVDR kernel: [24970.989655] saa7146 (0) vpeirq: used 9 times >80% of buffer (65612 bytes now)


    Ich habe daraufhin schon den Audiopuffer übers OSD in den Plugineinstellungen zu softhddevice von 50 ms auf 150 ms erhöht,
    aber das bringt leider keine Veränderung.


    Was mir noch aufgefallen ist:

    • Der vdr-Prozess ist CPU-hungriger geworden: jetzt sehr oft > 12 %; früher max. 5-10% (mit top)
    • Noch eine neue FM im Syslog (einmal beim Start): pulsecontrol: error on reading script /var/lib/vdr/plugins/pulsecontrol/startup.script


    Habt ihr eine Idee, woher der Fehler kommt?
    Bzw. was ich ändern kann, damit er wieder verschwindet?
    Braucht ihr noch irgendwelche Logs oder sonstigen Infos, um die Sache einzugrenzen?


    Vielen Dank schon jetzt für eure Hilfe!

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

    The post was edited 1 time, last by davie2000 ().

  • Habe den Audiobuffer von softhddevice auf 600 ms erhöht, bringt aber keine Verbesserung.
    btw: Was ist eigentlich der Defaultwert für den Parameter softhddevice.AudioBufferTime?


    Ich habe jetzt im Verzeichnis /etc/modprobe.d eine Datei namens budget_core.conf angelegt mit folgendem Inhalt:
    options budget_core bufsize=1410 (lt. heise ganz unten)


    Ich werde das syslog weiter beobachten und hier rückmelden ...


    Update:
    ... das scheints gewesen zu sein: die Fehlermeldung ist Geschichte.

    MyVDR: yaVDR-Ansible - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

    The post was edited 1 time, last by davie2000 ().