CT 2017-2 Artikel SATIP Megasat SAT to IP Server 3 - Erfahrungen?

  • Hi,


    ja danke. das scheint zu helfen, bis jetzt läuft er wieder stabil.
    Ich habe zunächst nur den "offensichtlichen Müll" aus der Kanalliste entfernt => keine Besserung
    Dann habe ich noch großzügig noch weitere Kanaäle entfernt => keine Besserung.


    Erst als ich wirklich nur noch die benutzten Sender ( ~30) drin gelassen habe läuft er wieder stabil.


  • Wäre nett wenn du in ein paar Tagen nochmal Info gibst ob das Teil mit eingeschränkter Kanalliste problemlos läuft. Wenn dem so ist würde ich mir dann so ein Teil bestellen. Bei mir schaut das Szenario eh so aus das ich nur die Kanäle in der Liste habe die ich auch schaue.

  • Moin,


    also mit der stark reduzierten Liste läuft er länger, haängt sich aber immer wieder auf. Wobei dass der falsche Ausdruck zu sein scheint, denn er ist weiter per Putty und WEB erreichbar und reagiert. Und auch in der Frontendanzeige ändertsich was. Aber das Bild ist schwarz. Auch wenn ich es per App oder Windows versuche.


    Ich habe jetzt den VDR-Rechner abgeschaltet um zu schauen was passiert. Und siehe da: Keine Aussetzer mehr, er läuft jetzt seit fast einer Woche.



    ABER: Ich würde mir das Teil kein zweites mal kaufen. Am liebsten würde ich den los werden.


    Ich hänge gleich mal meine Kanalliste dran, vielleicht ist da ja immer noch ein Fehler drin ... oder Du schickst mir Deine dann versuch ich es damit. oder ich mach mal nur 3 Programme rein ...


    EDIT:
    Also die liste ist vielleicht gar nicht das problem, ich habe channel scan abgeschaltet, das hatte ich vergessen. Und bis jetzt läuft er wieder.


    EDIT2:
    Ohne Kanal-scan und mit kastrierter Channels.conf läuft es gerade immer noch ohne störung


    The post was edited 2 times, last by Barracuda ().

  • Servus,


    jetzt muss ich auch mal meinen Senf dazugeben. Ich habe den Server 3 (aktuelle Firmware) jetzt seit ca. 4 Wochen im Produktiveinsatz. Probleme gab es nur kurzzeitig am Anfang und die waren vermutlich auch nicht dem Server 3 zuzuschulden.


    Ich habe eine etwas "andere" Konstellation in meinem Rechnerpark, vieles ist virtualisiert und das war auch, neben den 8 Tunern für diesen Preis, der Hauptgrund, weshalb ich mir den Megasat angeschafft habe. Seit ~4 Jahren hatte ich eine Digital Devices 6.5 mit zusätzlichen Doppeltuner im Einsatz, durchgereicht zuerst in eine virtuelle Maschine mit yaVDR, zuletzt in ein virtuelle Maschine mit MiniDVBLInux 5.1. Basis waren verschiedene Proxmox Versionen, mit dem Umstieg auf den SatIPServer und der Verbannung der Digital Devices aus dem Rechner ist jetzt die 4.4 drauf. Neben dem VDR laufen noch ein paar andere virtualisierte Linux-Kisten (u.a. OpenMediaVault, welches die vom Host direkt durchgereichten SATA Platten verwaltet und den restlichen Windows Clients SMB Dienste sowie den virtualisierten und physikalischen VDRs per NFS die Aufnahmeverzeichnisse zur Verfügung stellt) sowie ein Windows 10.


    Der 24/7 (virtualisierte) VDR Server greift nicht direkt auf den SAT2IP Server zu, sondern holt sich die Datenstreams von einem (für hellere Bilder gepatchten) MiniSatIP Server (ebenfalls virtualisiert auf Basis von MLD 5.3). Bislang hatte in Anfangs 2x den Effekt, dass der VDR Server keine Stream mehr empfangen hat. Das lies sich mit einem Neustart des MiniSatIP Server beheben. Ob das Problem am Megasat lag (der ohne Restart etc. auskam) oder am MiniSatIPServer (der danach wieder brav alles lieferte, was der VDR verlangt hat) weiß ich noch nicht. Aber nachdem der Megasat weiterhin reagiert hat und auch nicht neu gestartet werden musste... Neben dem VDR gibt es auch noch 2 RasPi mit MLD 5.1 als Clients sowie 2 Laptops, die sich das Bild noch per StreamdevServer Plugin vom VDR holen.


    Das ganze Gespann läuft seit 14 Tagen (da gab es eine Zwangspause wegen Umbau mit Stromabschaltung) ohne Ausfall oder Probleme, täglich werden mehrere Aufnahmen gemacht und parallel dazu noch LiveTV geschaut. Ich bin also mit dem Gerät zufrieden und kann bisher nichts negatives berichten. Einzip den EPG Scan habe ich deaktiviert, da das über EPGd läuft.


    Mahlzeit

  • Hallo,


    das klingt sehr interessant. Das würde ja bedeuten, greift man mit einem MiniSatIP Server auf den Megasat SAT2IP Server 3 zu, könnte das die bisher beschriebenen Probleme ggf. umschiffen?! Eine weiter Frage die offen bleibt ist der EPG Scan.


    TheOe

  • das klingt sehr interessant. Das würde ja bedeuten, greift man mit einem MiniSatIP Server auf den Megasat SAT2IP Server 3 zu, könnte das die bisher beschriebenen Probleme ggf. umschiffen?! Eine weiter Frage die offen bleibt ist der EPG Scan.


    Wo genau die Probleme am Anfang waren, weiß ich nicht. Ich hatte mir die Logfiles nicht gesichert (Log2Ram) und seitdem ist es nicht wieder aufgetreten. Aber es reichte aus, den MiniSatIP Server neu zu starten. Die Tuner des Megasat können es nicht gewesen sein, die wurden nicht neu gestartet, es muss etwas mit dem Netzwerk zu tun haben. Ob das jetzt eine Schwäche der Sat2IP Implementierung auf Seiten des Megasat oder auf Seiten des MinisatIp ist, kann ich nicht beurteilen.


    Mahlzeit

  • so nach einer Woche, kurzer Kanalliste und abgeschaltetem Channel-scan, heute morgen: Kein Bild
    Nur noch reboot des *+~# MEG-8000 hilft.


    das nervt, aber was mich wirklich irritiert ist dass der MEG-8000 nicht abstürzt. Sondern "nur" kein Bild mehr liefert. Aber auf Kanal-wechsel offensichtlich noch korrekt reagiert.


    Sollte ich nochmal EPGSCAN abschalten, und nur externe Quellen nutzen?


    hier noch meine Kanalliste


  • Mich würde mal interessieren da ich ein ähnliches Problem mit meine Octonet habe, ob deine MEG direkt am LNB hängt oder an einem MultiSwitch

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • Mich würde mal interessieren da ich ein ähnliches Problem mit meine Octonet habe, ob deine MEG direkt am LNB hängt oder an einem MultiSwitch

    Direkt am LNB


  • Weiß du auch den Typ ?

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • Für den genauen Typ müsste ich aufs Dach (nach dem nächsten Sturm) das müsste aber ein Wisi sein.


  • Kurz zum Hintergrund meiner Frage.


    Wie gesagt habe ich ein ähnliches Problem mit meiner Octopus. Mein Aufbau ist ein headless in dem eine CineS2 5.4 und zwei Satip Kanäle aktiviert sind. Die Octopus sowie die CineS2 hängen an eine SCR LNB von Inverto mit 32 Kanälen. Am Anfang hatte ich sehr viele VDR Abstürze, verschiedenster Art. Dann hab ich angefangen die Octopus nochmal neu zu Konfigurieren, danach waren die Abstürze gefühlt weniger. Anschließend habe ich meine Fritzbox auf Werkseinstellungen gestellt und von Grund auf neu konfiguriert. Bisher immer nur Updates aufgespielt. Danach sind die Abstürze auf 1 max. 2 pro Tag zurückgegangen.
    Jetzt kommt nur noch einer, wenn ein Fehler auftritt "Video Stream Broken". Egal ob Cine oder Satip. Worauf ich den Verdacht habe das dies der LNB ist. Da bei mir der Notausgang aktiv ist, startet bei mir der VDR neu. Ich habe noch eine 10 sec. Pause zum Neustart mit eingebaut, worauf das Signal anschließend wieder da ist. WIchtig ist das, kein anderer Teilnehmer aktiv am Satip oder LNB hängt . Wodurch der LNB wahrscheinlich kurz Stromlos ist und neu gestartet wird.
    Ich hab mir den gleichen LNB nochmal bestellt, und ihn gestern verbaut. Jetzt bin ich gespannt ob er immer noch abstürtzt, bis jetzt allerdings noch nicht


    rookie

    VDR 3: ASUS AT3IONT-I Deluxe , Cine S2, Atric , Harmony 515 (schon wieder im Umbau)
    VDR 4: AMD Kabini 5310, Asrock AM1H-ITX, Gen2Vdr V6, Cine S2, Atric , Harmony 515 , Streacom ST-F7CB EVO

  • Da ich leider vergessen habe, meinen Megasat zu retournieren, liegt dieser momentan hier rum, da ich ja die Octopus NET im Einsatz habe. Allerdings habe ich festgestellt, dass 4 Tuner doch nicht reichen für mein Setup, hätte ich Interesse daran, das Teil zum laufen zu bekommen.


    Hat jemand von den Entwicklern Interesse daran, dass ich ihm das Gerät zusende zu Testzwecken? Insbesondere rofafor wäre glaube ich dazu in der Lage.


    rofafor: Are you interest in getting the Megasat IP Server 3 to work with your plugin? I could send you the Server for testing purpose.

  • Hallo,
    ich habe seit Dezember mit der MEG-8000 immer wieder ähnliche Erfahrungen gemacht, wie Ihr sie hier auch beschrieben habt! Leider bin ich dem erst heute tiefer nachgegangen, weil ich nach Mirko's Artikel meine gesamt Infrastruktur von All In One auf Meg-8000 + VDR-Backend + Raspi-VDR-Frontends ungebaut habe und plötzlich viele Systeme aber wenig Zeit hatte.
    Als Resumee aus meinen Beobachtungen und Euren Hinweisen werde ich nun folgendes versuchen:
    a) Channel-Liste stark gekürzt und Channel-Update abgeschaltet
    b) EPG-Suche abgeschaltet und via crontab / svdrsend nur einmal am Tag früh morgens eingestellt
    c) falls das nicht zieht, werde ich auch noch den MEG-8000 jeden morgen autom. durchstarten lassen.


    Aber eigentlich wollte ich mich an dieser Stelle einmal bedanken. Über 13-14 Jahre betreibe ich einen VDR. Nun in 4 Generation! Meine Frau hat sich so daran gewöhnt, daß sie keine 'OpenElec'-Oberfläche haben wollte. Also vielen Dank für die Hinweise zum MEG-8000 und insbesondere für die vielen Informationen in den letzten Jahren.


    Gruß Wolfgang

  • Hi, ich habe mit dem Megasat Server 3 die Erfahrung gemacht, dass ich eine Trasnponder nicht empfangen kann
    Es geht um Transponder
    DVB-S2 11347Mhz, V, Symbolrate 22000 FEC 2/3 ==> 3sat HD, Kika HD und ZDFinfo HD


    unter SAT-Input, kein Problem, aber mit Sat-IP weder im easyVDR, bei andoid-App tivizen oder SatIP_DVBViever bekomme ich die Sender gescannt.


    Kann dies jemand verifizieren?


    #update
    auch BBC und CNBC auf 11597 V fehlen ??

    easyVDR2.2.0-64bit-stable
    es ist traurig, wenn alles für die Katz ist, aber nicht's für die Katze

    The post was edited 1 time, last by riverphoenix ().

  • Hallo,


    ich wurde auch durch den c't-Artikel auf den Megasat aufmerksam und habe ihn mir gekauft. Allerdings läuft der bisher nur im Test-Betrieb, weil ich erst noch die SAT-Empfangstechnik anpassen muss (im Moment ein Quad-LNB, den ich mit meinen Nachbarn teile).


    Am WE bin ich aber auf einen neuen Artikel der c't gestoßen, der sich mit Sicherheitsproblemen im SmartHome beschäftigt (Ausgabe 8/2017, Seite 72). Und da taucht der Megasat wieder auf, diesmal aber mit einer extrem negativen Eigenschaft. Wie fadi2013 schon schrieb, gibt es einen ssh-Zugang mit root-Rechten:

    Noch zur Info:


    ssh ist auf den Geräten freigeschaltet.


    Login: root
    Password: admin

    Leider ist es aber egal, welches Passwort man eingibt, man wird immer als root angemeldet :wow. Auch gar kein Passwort funktioniert... :wand Das Passwort läßt sich auch nicht setzen und der ssh-Zügang ist nicht deaktivierbar. Damit hat man eine riesen Sicherheitslücke im eigenen Netz! Hier ein paar Zitate aus dem c't-Artikel:



    "... Der offenbar gepatchten Variante von Dropbear ist das Passwort völlig egal. ..."
    "... dank eingebautem wget hätten wir auch bequem zusätzliche Programme aus dem Internet nachladen ... können. ..." (!!!)
    "... Der Server ist geradezu eine Einladung für Angreifer, ..., er benutzt außerdem auf sämtlichen produzierten Geräten den selben SSH Host Key. ..." (!!!)
    "... Doch selbst ein Betrieb im Heimnetz ist verantwortungslos, genügt doch eine einzige gehackte App auf einem Mobilgerät, um den Sat-IP-Server zu übernehmen. ..."


    Ich habe das bei mir genau so nachvollziehen können und das Gerät jetzt erstmal vom Netz genommen. Aus meiner Sicht ist das Teil so verpfuscht, dass es erst wieder ans Netz geht, wenn der Hersteller ein Firmware-Update bereitstellt, dass diesen "Fehler" behebt. Den Hersteller schreibe ich entsprechend an. Wenn Euch die Sicherheit in Eurem Netz auch wichtig ist: schreibt den Hersteller auch an, je mehr sich dort melden desto wahrscheinlicher ist es, dass der kurzfristig reagiert. Ich setze ihm und dem Lieferanten eine Frist von 4 Wochen für die Behebung des Mangels, sonst geht das Gerät auf Gewährleistung zurück. Das ist schließlich ein gravierender Mangel, der von vorneherein im Produkt steckte.

    Server HW: Intel DH67BL | Celeron G530 | 4GB RAM | 60 GB SSD | 1 TB HDD | DVBSky S592; SW: EasyVDR 3.0
    Client HW: Intel NUC DN2820FYK; SW: EasyVDR 3.0

  • ..na ja, jetzt übertreibst du ein wenig.


    Für diese CPU Architektur kann man nicht einfach etwas aus dem Netz laden, man müsste das schon speziell für diese CPU compilieren.
    Normaler Code für x86 oder ARM läuft darauf nicht, die CPU ist selten. Maximal shell scripte laufen und das Linux drauf hat
    nur das allernötigste.



    >> dank eingebautem wget hätten wir auch bequem zusätzliche Programme aus dem Internet nachladen ... können. ..." (!!!)


    Hätten sie dann mal versuchen sollen, statt es nur zu schreiben.
    Das Dateisystem ist readonly, es gibt nur einen einzigen Ordner der schreibbar ist. Und der fasst max 5MByte.


    Und normalerweise sollte das Ding im abgeschotteten Heimnetz sein. Port 22 zu blockieren sollte ssh unmöglich machen.

  • Ich darf da nochmal auf meinen Kommentar bezueglich c't aus dem Januar verweisen.
    Die c't war mal "alternativlos" und in voellig anderen Sphaeren als die anderen Blaettchen. Heute macht sie Mainstream und biedert sich mit reisserischen, billigen und sensationsheischenden Aufmachern bei Hein Bloed an.
    Schade drum. Ich fand's einfach nur noch Zeit- und Geldverschwendung und habe nach 27 Jahren ohne verpasste Ausgabe meine Konsequenzen gezogen.


    Ich seh die "Problematik" von einer anderen Seite:
    man kann sein eigenes Netz zur Not segmentieren und dann kommt niemand mehr in die "gefaehrlichen" Bereiche (nein, Hein Bloed ist da ueberfordert)
    wenn die Devices alle zu sind, besteht keine Chance irgendwas ausserhalb von dem zu machen, was der Hersteller vorgesehen hat (minisatip z.B. waere nicht moeglich)


    uwe

    server: yavdr trusty testing, 2 * L5420, 32GB, 64TB RAID6 an OctopusNet (DVBS2- 8 ) + minisatip@dsi400 (DVBS2- 4 )
    frontends: kodi und xine