VDR Crash: Streamdev-Server + IPTV-Plugin / easyVDR 2.5

  • Hallo Leute,


    ich nutze easyVDR 2.5 als Streaming Server inkl. DVB Karte mit dem Streamdev-Server plugin und als Client
    mit dem iptv plugin (v2.2.1).


    Mit dem Client emfpange ich per IPTV-Plugin die TS Streams vom StreamDev-Server. Das funktioniert soweit auch sehr gut. Die Umschaltzeiten sind sehr gut.
    Als VDR-Frontend nutze ich das Softhddevice-plugin. Eine DVB-Karte ist nicht im Client verbaut.


    Leider gibt es ein Problem das nur während des Umschaltens der Kanäle auftritt. Der VDR wird aufgrund eines
    Fehlers mit dem IPTV-Plugin beendet und neu gestartet. Das Problem tritt sporadisch auf.
    Das bedeutet, dass ich manchmal 10 oder 15 Kanäle weiterschalten kann, ein anderes Mal dann aber
    nur zwei oder nur ein Kanal. Ist immer unterschiedlich.


    Auszug /var/log/syslog:


    Code
    1. Jan 5 20:46:09 easyvdr vdr: [3220] IPTV streamer thread ended (pid=2932, tid=3220)
    2. Jan 5 20:46:09 easyvdr vdr: [3219] device 1 receiver thread ended (pid=2932, tid=3219)
    3. Jan 5 20:46:10 easyvdr vdr: [2932] IPTV-ERROR: Expected HTTP header not found
    4. Jan 5 20:46:10 easyvdr vdr: message repeated 7 times: [ [2932] IPTV-ERROR: Expected HTTP header not found]
    5. Jan 5 20:46:10 easyvdr vdr: [2932] IPTV-ERROR: Header wouldn't fit into buffer
    6. Jan 5 20:44:28 easyvdr lircd-0.9.0[2424]: accepted new client on /var/run/lirc/lircd
    7. Jan 5 20:46:11 easyvdr lircd-0.9.0[2424]: removed client
    8. Jan 5 20:46:11 easyvdr easyvdr-runvdr: Restarting VDR and DVB by error level 134


    Auszug aus Channels.conf:


    Code
    1. Das Erste;IPTV:1:S=0|P=0|F=HTTP|U=192.168.4.23/TS/1|A=3000:I:1:101=2:102=deu@3,103=mis@3;106=deu@106:104;105=deu:0:28106:1:1101:0
    2. ZDF;IPTV:2:S=0|P=0|F=HTTP|U=192.168.4.23/TS/2|A=3000:I:1:110=2:120=deu@3,121=mis@3,122=mul@3;125=deu@106:130;131=deu:0:28006:1:1079:0
    3. NDR FS NDS;IPTV:3:S=0|P=0|F=HTTP|U=192.168.4.23/TS/3|A=3000:I:1:2601=2:2602=deu@3,2603=mis@3:2604:0:28226:1:1073:0


    Folgendes habe ich versucht:


    1. Deaktivierung der sid scan in channels.conf (Tipp aus einem Forum http://openelec.tv/forum/71-pv…pvr-http-streams?start=36).
    2. Statt Softhddevice habe ich Xinelibout probiert, was die Sache noch verschlimmerte.
    3. Änderung der Auflösung des OSD-Panels (Tipp aus einem Forum).


    Leider hat es nicht geholfen. Ich weiß nicht mehr weiter und im Netz finde ich keine weiteren Infos zu diesem Problem.


    Deshalb möchte ich gerne hier um Rat fragen. Danke.


    Grüße


    XPMaster

  • Hi.
    Darf ich mal fragen warum du nicht streamdev-Client nutzt anstatt iptv?

    Gruß Patrick


    [size=8]* Meine NeverEndingProjects ;-)*


     vectra --- glasslike ---

  • Hi,


    oh sorry. Das hätte ich dazu schreiben sollen. ;-)


    Ich nutze das ganze über ein VPN-Netzwerk über das Internet. Für den StreamDev-Client ist die
    Latenz zu hoch. Ich erhalte immer die Fehlermeldung:


    Code
    1. ERROR: streamdev-client: Couldn't connect to 192.168.4.23:2004: Die Wartezeit für die Verbindung ist abgelaufen


    Deshalb wechselte ich zum IPTV-Plugin.


    Grüße