softhddevice with hevc and UHD

  • Bin wohl Alleinunterhalter hier :-)


    So nun ist der Support von libplacebo komplett. Man kann nun im Menue den Scaler auswählen und auch Kontrast Sättigung und Hue sollten nun einstellbar sein. Es werden alle scaler von libplacebo angeboten, Man sollte für jede Auflösung einen Scaler einstellen. ewa_lanczos ist sehr gut.


    PS: der skindesigner geht noch nicht mit placebo. Liegt aber wohl am skindesigner weil er nie die Oberflächen löscht die er benutzt. Da muss ich mal schauen was ich da tun kann.

  • Bin wohl Alleinunterhalter hier

    SIcherlich nicht, läuft halt grad so schön ;)

  • Bin wohl Alleinunterhalter hier :-)


    Das hoffe ich nicht, es gibt aber einige (stille) Beobachter, wie ich z.B., die sehr froh sind, dass die Entwicklung in Richtung 4K weitergeht.


    Vielen Dank an jojo und alle diejenigen, die dazu beitragen :].


    Ich habe leider nicht das KnowHow, um einen Beitrag leisten zu können.


    Gibt es schon Planungen, dass die neuesten Entwicklungen in eine Distri einfließen?

  • Bin wohl Alleinunterhalter hier

    Das kommt mir sehr bekannt vor ;D


    vdr-User-# 755 to_h264 chk_r

  • Ich bekomme beim compilieren folgende Meldung:


    Code
    1. video.c:163:29: fatal error: SDL2/SDL_vulkan.h: No such file or directory
    2. #include <SDL2/SDL_vulkan.h>

    Installiert habe ich:

    * dev-util/vulkan-headers

    Latest version available: 1.1.82.0

    Latest version installed: 1.1.82.0

    Size of files: 462 KiB

    Homepage: https://github.com/KhronosGroup/Vulkan-Headers

    Description: Vulkan Header files and API registry


    * media-libs/vulkan-loader

    Latest version available: 1.1.82.0

    Latest version installed: 1.1.82.0

    Size of files: 1.311 KiB

    Homepage: https://github.com/KhronosGroup/Vulkan-Loader

    Description: Vulkan Installable Client Driver (ICD) Loader


    nicht installiert:


    * dev-util/vulkan-tools [ Masked ]

    Latest version available: 9999

    Latest version installed: [ Not Installed ]

    Size of files: 0 KiB

    Homepage: https://github.com/KhronosGroup/Vulkan-Tools

    Description: Official Vulkan Tools and Utilities for Windows, Linux, Android, and MacOS


    * media-libs/vulkan-layers [ Masked ]

    Latest version available: 9999

    Latest version installed: [ Not Installed ]

    Size of files: 0 KiB

    Homepage: https://github.com/KhronosGroup/Vulkan-ValidationLayers

    Description: Vulkan Validation Layers



    vdr-User-# 755 to_h264 chk_r

  • Bin auch so ein stiller Beobachter, der hofft, das irgendwie auch mal selber realisieren zu können. Es wäre in der Tat toll, wenn die Entwicklung in eine Distri einfließen würde.


    Ansonsten: guter Job, den Ihr da macht!

    Silverstone LC 16-MR, P5N7A-VM , Cine S2 Dual DVB-S2 V5.5, E5200, 64 GB Crucial CT064M4, 2 TB WD 20EARX

  • Es fehlten:


    media-libs/libsdl2

    media-libs/sdl2-image


    compiliert aber immer noch nicht.


    Im Anhang die Fehler.

    Dateien

    • compile.txt.gz

      (3,34 kB, 8 Mal heruntergeladen, zuletzt: )


    vdr-User-# 755 to_h264 chk_r

  • Ich habe


    Es wird CUDA 10 gebraucht und der NVIDIA Treiber mindestens 410.48.

    natürlich nicht beachtet.


    vdr-User-# 755 to_h264 chk_r

  • Jetzt habe ich den Nvidia Treiber 410.78 installiert.


    Es kommt immer noch:


    Code
    1. video.c: At top level:
    2. video.c:1597:5: error: unknown type name 'CUexternalMemory'
    3. CUexternalMemory mem;
    4. ^~~~~~~~~~~~~~~~

    Edit:


    emerge: there are no ebuilds to satisfy ">dev-util/nvidia-cuda-sdk-9.2.88".


    mal sehn, wo ich das herbekomme.


    vdr-User-# 755 to_h264 chk_r

  • Ich habs jetzt compiliert bekommen.


    vdr-User-# 755 to_h264 chk_r

  • jsffm danke für deine Mühe. Die SDL2 Header brauche ich gar nicht mehr die waren nur zum test drin. Habe sie wieder entfernt.

    Das CUexternalMemory sollte aus CUDA 10 befriedigt werden.


    Noch etwas zu den neuen Konfig Parametern. Ich habe einige genutzt die es schon im ursprünglichgen softhddevice gab und die ich aber

    von 0...1000 auf 0..100 reduziert habe. Wenn es also Probleme geben sollte dann prüft mal in setup.conf ob folgende Werte richtig sind:

    Code
    1. softhdcuvid.Saturation = 100
    2. softhdcuvid.Gamma = 100
    3. softhdcuvid.Contrast = 100
  • softhdcuvid.Gamma = 100

    Der Wert "Gamma" bzw. "Gamma-Korrektur" ist ja bei einem TV ein Wert von 0 ... 4, wobei Gamma = 2.2 der Normwert sein sollte, auf den die TVs kalibriert sind, um eine farbgetreue Abbildung zu geben.


    Was bedeutet nun hier der Wert softcuvid.Gamma = 100 ?

    Wäre es hier nicht auch besser einen Wert 0.0 ... 4.0 anzugeben?


    Paul

  • So sieht das ohne Korrektur aus :)


    vdr-User-# 755 to_h264 chk_r

  • Paulaner der Gamma Paramter kommt von libplacebo und ist dort von 0.0 bis 1.0 definiert. Wobei 1.0 der default ist. Es ist wohl ein Korrekturwert zum bestehenden Gamma des Bildes wobei mir die Einheit hier nicht klar ist. Im Moment ist es wohl nur sinnvoll das auf 100 zu setzen.


    Bei mir ändert sich auch nix am Bild wenn ich den Wert verändere.....


    jsffm sieht cool aus. Dachte ich mir schon das das mit dem alten Werten nicht sinnvoll ist. Nur weiss ich nicht wie ich die beim einlesen erzwingen kann.

    Wenn sie mal richtig gesetzt sind dann tun sie auch was sie sollen.


    Ich habe auch mal nach dem Skindesigner geschaut. Der hat einen Fehler und flushed das OSD immer bevor er es löscht. Das ist leider falsch und führt dazu das der openglosd das OSD aktiviert und es dauernd angezeigt wird. Da muss der Entwickler vom Skindesigner mal nach schauen. Nach einen OSdClose darf kein Flush mehr kommen.

  • Paulaner , der Gamma Paramter kommt von libplacebo und ist dort von 0.0 bis 1.0 definiert. Wobei 1.0 der default ist.

    Es ist wohl ein Korrekturwert zum bestehenden Gamma des Bildes wobei mir die Einheit hier nicht klar ist.

    Okay, das könnte eine Erklärung sein.


    Da ich das softhdcuvid-Plugin über das yavdr-asible auf meinem Test-VDR laufen habe, muss ich noch etwas warten, bis es dafür die neuen Updates gibt, um es selbst einmal testen zu können.

    Vermutlich wird das aber etwas länger werden, da ja hier ein aktuellerer nvidia-Treiber-41x und auch CUDA10 gebraucht werden, welche ja momentan noch nicht in yavdr-ansible enthalten sind.

  • Für yavdr-ansible habe ich mal eine Anleitung geschrieben, wie man sich das Plugin bauen kann: Anleitung für softhdcuvid mit libplacebo - leider habe ich noch keine gute Idee, wie man das als fertiges Paket in ein PPA bekommt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich versuche die Version mit libplacebo auf meinem Prod-System zu installieren (vdr3), libplacebo, CUDA 10 und ffmpeg 4.1 sind installiert.


    Ich bekomme folgende Meldungen:



    vdr-User-# 755 to_h264 chk_r