softhdcuvid with hevc and UHD

  • Der NUC ist mit einem SATIP-OctopusNet verbunden.

    Ich versuche das mit dem backtrace hinzubekommen.

    Ich war bis dato eigentlich sehr zufrieden auch ohne libplacebo daher wäre es gut wenn das auch ohne wieder stabil laufen würde.

    Hatte vorher auch mit verschlüsselten Sender usw keine Probleme es lief wie gesagt stabil.


    Ich habe heute die Abstürze erneut provoziert mit dem NUC8.

    Dazu einen plain VDR genommen nur mit aktuellem softhddrm und satip.

    jojo61 Ich schicke Dir den Backtrace per PN.


    Hoffentlich findest Du was.

  • ich versuche softhddrm auf Ubuntu 22.04 zu erstellen und bekomme folgenden Fehler


    Code
    1. cc -g -O3 -Wall -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/local/include -I/usr/local/include/libdrm -I/usr/include/valgrind -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I./opengl -I./ -DPLUGIN_NAME_I18N='"softhddrm"' -D_GNU_SOURCE -DDEBUG -DHAVE_GL -DAV_INFO -DAV_INFO_TIME=3000 -DUSE_MPEG_COMPLETE -DH264_EOS_TRICKSPEED -DUSE_VDR_SPU -DUSE_OPENGLOSD -DUSE_GLX -DUSE_DRM -DVAAPI -DUSE_SCREENSAVER -DGIT_REV='"25f70cd"' -g -W -Wextra -c -o ringbuffer.o ringbuffer.c
    2. g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/local/include -I/usr/local/include/libdrm -I/usr/include/valgrind -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I./opengl -I./ -DPLUGIN_NAME_I18N='"softhddrm"' -D_GNU_SOURCE -DDEBUG -DHAVE_GL -DAV_INFO -DAV_INFO_TIME=3000 -DUSE_MPEG_COMPLETE -DH264_EOS_TRICKSPEED -DUSE_VDR_SPU -DUSE_OPENGLOSD -DUSE_GLX -DUSE_DRM -DVAAPI -DUSE_SCREENSAVER -DGIT_REV='"25f70cd"' -g -W -Wextra -Werror=overloaded-virtual -Wno-unused-parameter -c -o openglosd.o openglosd.cpp
    3. g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/local/include -I/usr/local/include/libdrm -I/usr/include/valgrind -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu -I./opengl -I./ -DPLUGIN_NAME_I18N='"softhddrm"' -D_GNU_SOURCE -DDEBUG -DHAVE_GL -DAV_INFO -DAV_INFO_TIME=3000 -DUSE_MPEG_COMPLETE -DH264_EOS_TRICKSPEED -DUSE_VDR_SPU -DUSE_OPENGLOSD -DUSE_GLX -DUSE_DRM -DVAAPI -DUSE_SCREENSAVER -DGIT_REV='"25f70cd"' -g -W -Wextra -Werror=overloaded-virtual -Wno-unused-parameter -shared softhdcuvid.o softhddev.o video.o audio.o codec.o ringbuffer.o openglosd.o -lfreetype -lEGL -lgbm -ldrm -lEGL -lswresample -lavutil -lswscale -L/root/ffmpeg_build/lib -lavcodec -lavfilter -lasound -lxcb-screensaver -lxcb-dpms -lrt -lX11-xcb -lX11 -lxcb-icccm -lxcb -L/usr/lib64 -lGLEW -lGLU -ldl -lglut -o libvdr-softhddrm.so
    4. /usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/11/../../../x86_64-linux-gnu/libX11.a(OpenDis.o): warning: relocation against `_Xdebug' in read-only section `.text'
    5. /usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/11/../../../x86_64-linux-gnu/libX11.a(OpenDis.o): relocation R_X86_64_PC32 against symbol `_XFreeDisplayLock_fn' can not be used when making ein gemeinsames Objekt; recompile with -fPIC
    6. /usr/bin/ld: final link failed: schlechter Wert
    7. collect2: error: ld returned 1 exit status
    8. make: *** [Makefile:352: libvdr-softhddrm.so] Fehler 1

    jemand eine Idee

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • aber das gibts doch bereits im ppa von Alexander, vllt kannst du ja da mal schauen was er gemacht hat damit das baut? https://launchpad.net/~seahawk…shed&field.series_filter=

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Da wird versuch die libX11 statisch zu linken. Dir fehlt da wohl die dazugehörige .so lib.

    Danke das war es --> Jetzt ist alles fein

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • NUC11PAHi


    ich habe mal wieder diese Problem angenommen.

    Quote

    Versuch mal das Plugin mit -w alsa-no-close-open oder -w alsa-close-open-delay zu starten.

    Das Plugin braucht die unterstützten Formate und muss deswegen testen was das AudioDevice kann. Ich kann den Test nicht einfach rauswerfen.

    der Test ist raus aus softhddrm und das Starten mit  -w alsa-no-close-open oder -w alsa-close-open-delay  bringt keine Änderung des Ergebnis, der Ton bleibt stumm. -a hdmi:CARD=PCH,DEV=0 kann man nicht aktivieren ohne Tonverlust. Jemand eine Idee zu diesem Problem was den Ton abschießen könnte beim Start mit -a hdmi:CARD=PCH,DEV=0

    Damit steht die Entwicklung der Ausgabe Plugins für die Intel Chipsätze

    Tiger Lake/Panther Canyon, Alder Lake, Raptor Lake etc...still und kann zur Zeit nicht mit dem VDR native genutzt werden.

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Das könnte ein Problem der Audio Mixer sein. Schau doch mal mit alsamixer nach wie die Kanäle eingeschaltet sind wenn der vdr läuft.

    Evtl. steht da etwas auf Mute oder auf Level 0. (z.b: das SPDIF oder

    Ich sehe da keinen Unterschied

    Da sind nur Master und PCM, habe ich beide auf 100. Und dann noch S/PDIF ohne Zahl und von 1 bis 11. Keiner gemutet.

  • Dann müsstest du mal den DEBUG in audio.c aktivieren. Evtl. sieht man da dann etwas.

    reicht hierzu

    CONFIG := -DDEBUG im Makefile?


    wenn man -a wieder deaktivieren möchte in der conf muß man die Alsa-Treiber auf der Konsole neu laden


    Code
    1. root@BM2LTS64nDD:~# lsof | grep pcm
    2. root@BM2LTS64nDD:~# sudo alsa force-reload
    3. Unloading ALSA sound driver modules: snd-hda-codec-hdmi snd-sof-pci-intel-tgl snd-sof-intel-hda-common snd-sof-intel-hda snd-sof-pci snd-sof-xtensa-dsp snd-sof snd-sof-utils snd-hda-codec-realtek snd-soc-hdac-hda snd-hda-ext-core snd-hda-codec-generic snd-soc-acpi-intel-match snd-soc-acpi snd-soc-core snd-compress snd-pcm-dmaengine snd-hda-intel snd-intel-dspcfg snd-intel-sdw-acpi snd-hda-codec snd-hda-core snd-hwdep snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-pcm snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-hdmi snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-timer).
    4. Loading ALSA sound driver modules: snd-hda-codec-hdmi snd-sof-pci-intel-tgl snd-sof-intel-hda-common snd-sof-intel-hda snd-sof-pci snd-sof-xtensa-dsp snd-sof snd-sof-utils snd-hda-codec-realtek snd-soc-hdac-hda snd-hda-ext-core snd-hda-codec-generic snd-soc-acpi-intel-match snd-soc-acpi snd-soc-core snd-compress snd-pcm-dmaengine snd-hda-intel snd-intel-dspcfg snd-intel-sdw-acpi snd-hda-codec snd-hda-core snd-hwdep snd-seq-midi snd-seq-midi-event snd-rawmidi snd-seq snd-pcm snd-seq-device snd-timer.

    dann ist der VDR ohne Ton aber MPV und Kodi geben dann wieder Ton aus.

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

    The post was edited 6 times, last by cinfo ().

  • Ja das und dann im File audio.c am Anfang //#undef DEBUG editieren.

    anbei das Log-File --- > mit options snd-intel-dspcfg dsp_driver=3 & alsamixer -c0


  • anbei das Log-File --- > OHNE options snd-intel-dspcfg dsp_driver=3 & alsamixer -c1

  • Das war mit dsp-driver=3 und ich denke das geht nicht. In dem Log ohne dsp-driver=3 sieht es eigentlich gut aus. Da wir ein Device geöffent und es sieht so aus als ob das Audio auch ausgegeben wird. Was sagt denn aplay -L welche devices es denn gibt. Mit und ohne dsp-driver=3.

  • ohne dsp-driver=3

    speaker-test war mit hdmi:CARD=PCH,DEV=0erfolgreich aber softhddrm leider ohne Ton

    speaker-test war mit hw:CARD=PCH,DEV=3erfolgreich aber softhddrm leider ohne Ton (siehe Log im Anhang)

    sieht für mich soweit gut aus nur leider möchte ALSA immer default im Mixer öffnen und das kann leider nicht geöffnet werden?

    Code
    1. Aug 26 09:53:21 BM2LTS64nDD vdr: audio/alsa: mixer default - PCM open
    2. Aug 26 09:53:21 BM2LTS64nDD vdr[1903]: ALSA lib dlmisc.c:337:(snd_dlobj_cache_get0) Cannot open shared library libasound_module_ctl_pipewire.so (/usr/local/lib/x86_64-linux-gnu/als>
    3. Aug 26 09:53:21 BM2LTS64nDD vdr: audio/alsa: can't open mixer 'default'

    mit dsp-driver=3


    speaker-test war mit hw:CARD=sofhdadsp,DEV=3 erfolgreich aber softhddrm,MPV & Kodi leider ohne Ton !

    Files

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

    The post was edited 8 times, last by cinfo ().

  • sieht für mich soweit gut aus nur leider möchte ALSA immer default im Mixer öffnen und das kann leider nicht geöffnet werden?

    Der Mixer kann in der environment Variablen ALSA_MIXER gesetzt werden. Wenn es die nicht gibt dann nimmt er default als Mixer device.


    Du könntest in audio,c auch mal die Funktion "AlsaInitMixer" tot legen. Das wird nur bei Hardware Volume gebraucht.


    Du kannst auch mal andere Devices ausser "hdmi:CARD=PCH,DEV=0" versuchen. Wer weiss wie er die hdmi Ports durchnummeriert. Also DEV=1 usw.

  • Quote

    Du könntest in audio,c auch mal die Funktion "AlsaInitMixer" tot legen. Das wird nur bei Hardware Volume gebraucht.

    ok werde ich versuchen

    Quote

    Du kannst auch mal andere Devices ausser "hdmi:CARD=PCH,DEV=0" versuchen. Wer weiss wie er die hdmi Ports durchnummeriert. Also DEV=1 usw.

    hatte ich schon weiter oben gemacht und auch ein Log angehängt

    Quote


    speaker-test war mit hw:CARD=PCH,DEV=3erfolgreich aber softhddrm leider ohne Ton (siehe Log im Anhang)

    ist aber das gleiche Ergebnis , wenn softhddrm geladen wird gibt es kein ALSA-Funktion mehr

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • Quote
    Zitat Du könntest in audio,c auch mal die Funktion "AlsaInitMixer" tot legen. Das wird nur bei Hardware Volume gebraucht.

    ok werde ich versuchen

    habe ich gemacht -- leider keine Änderung - softhddrm schweigt

    Files

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

  • In AudioInit wird getestet welche Kanaloptionen die Karte hat. Evtl. hängt sie sich dabei auf. Das hatte ich schon einmal. Das habe ich in der softhdodroid Version raus genommen. NImm doch mal die AudioInit Funktion aus der softhdodroid alsa.c Datei. Die mach dann zwar nur Stereo aber wenn das klappt dann kann ich das anpassen.


    Sorry kann leider nicht mehr helfen weil ich keinen NUC 11 habe. Ich hatte einen vor ein paar Wochen, aber der hat nicht mal Linux gebootet und dann habe ich ihn zurück geschickt.

  • Hm,


    wenn ich das versuche bekomme ich ein Problem mit der audio.c für softhddrm


    Code
    1. - int freq;
    2. - int chan;
    3. + //int freq,chan;

    könntest Du mir mir mal bitte eine audio.c als( txt) hier anhängen wo mit ich es testen kann .


    ALSA lib pcm.c:8650:(snd_pcm_set_params) Channels count (1) not available for PLAYBACK: Das Argument ist ungültig


    Mein Bsp. mal das LOG als Anlage

    Files

    (VDR) NUC11PAHi5 * BM2LTS * DD NET S2 Max * NC * (Sound) Cinebar Lux Set * (Stream) Apple TV 4K (2021)* (Light) PHILIPS Hue Play HDMI Sync Box & Gradient Lightstrip * (OLED TV) LG OLED65GX9LA

    The post was edited 1 time, last by cinfo ().