Geeignetes Mainboard für einen Neubau

  • Moin,


    erster Zwischenbericht: Nix geht!


    Die Onboard-Grafik reicht gerade für die Installation, anschließend hängt das Ganze (probiert mit yaVDR und MLD)
    Die Kombination der MSI 730 Nvidia Grafikkarte führt zu besonders lustigen Effekten: Ist sie eingesteckt, werden
    zwar die Festplatten erkannt, aber die Bootpartitionen im BIOS nicht als solche angeboten (auch der USB-Stick für
    die Installation bleibt unerkannt). Bild kommt nicht.


    Ich kenne mich zugegebenermaßen nicht besonders mit UEFI usw. aus, habe aber versucht, Secure Boot abzuschalten.
    Das scheint auch gelungen, allerdings gibt die Nvidia Karte trotzdem absolut kein Bild.


    Hört sich alles etwas konfus an... Ich muss mir erst mal den ein oder anderen Gedanken zur weiteren Strategie machen.
    Im Augenblick bin ich "etwas" enttäuscht.


    Bis in Kürze
    J.

    Tuner: Digibit R1 Sat>IP (4fach Tuner)
    Rekorder: TvHeadEnd 4.0.9 (auf OpenSUSE Tumbleweed)
    Player: Wetek Play mit LibreELEC 7.0.2
    sonstiges: AV-Verstärker: Yamaha RX-V775,TV: LG irgendwas

  • Welches Mainboard hast Du nun?


    Das HDMI Kabel ist am richtigen Ausgang dran?


    Regards
    fnu

    HowTo: APT pinning

    The post was edited 1 time, last by fnu ().

  • Die Hardware sieht so aus:


    Mainboard AsRock J3355M-Atx
    RAM 2x 4GB Corsair
    Graka 2GB MSI GeForce GT 730 Passiv PCIe 2.0 x16


    Wenn ich das richtig sehe, kann man nur die Priorität der
    Grafikarten ändern. Die habe ich entsprechend geändert.


    Und ja, das Kabel habe ich auch im richtigen Ausgang - die
    Frage ist berechtigt - mir passiert dauernd sowas :-)


    Ich versuche gerade, eine andere Geforce in meinem Fundus
    zu finden, um damit mal zu testen. Habe leider nur welche mit
    DVI-Ausgang. Müsste mal beim lokalen Elektronikmarkt nach einem
    Adapter auf HDMI fragen - wen es sowas gibt.


    Ist meine Annahme eigentlich richtig, das UEFI/SecureBoot zu deaktivieren?
    Oder können Distris wie yaVDR oder MLD damit umgehen?


    Jürgen

    Tuner: Digibit R1 Sat>IP (4fach Tuner)
    Rekorder: TvHeadEnd 4.0.9 (auf OpenSUSE Tumbleweed)
    Player: Wetek Play mit LibreELEC 7.0.2
    sonstiges: AV-Verstärker: Yamaha RX-V775,TV: LG irgendwas

  • Wenn ich das richtig sehe, kann man nur die Priorität der
    Grafikarten ändern. Die habe ich entsprechend geändert.

    Korrekt, in der Regel kann man nur einstellen, welche GPU das Mainboard zuerst versucht zu initialisieren. Bei den meisten Mainboards ist da als Standard der PEG Slot (16x PCIe) definiert.


    Adapter auf HDMI fragen - wen es sowas gibt.

    Gibt es, sollte kein Problem sein zu bekommen.


    Ist meine Annahme eigentlich richtig, das UEFI/SecureBoot zu deaktivieren?

    UEFI und SecureBoot sind zwei paar Schuhe, wobei SecureBoot nicht ohne UEFI geht. Bei den meisten aktuellen Boards kann man UEFI eigentlich nicht mehr abschalten, die haben einen "Dual-Mode" der beides beherrscht, MBR als auch UEFI. SecureBoot kann man IIRC bei allen abschalten.


    Es gibt da einen sogenannten "Windows 7 Modus" im BIOS einzustellen (ein/aus). Das Problem ist, das viele Nvidia OEM Karten den nötigen GOP Modus nicht beherrschen und das dann zu Problemen kommt. Kannst Du das mal prüfen?


    Oder können Distris wie yaVDR oder MLD damit umgehen?

    IIRC sollte yaVDR 0.6.x mit UEFI umgehen können.


    Regards
    fnu

    HowTo: APT pinning

  • Quote

    Es gibt da einen sogenannten "Windows 7 Modus" im BIOS einzustellen
    (ein/aus). Das Problem ist, das viele Nvidia OEM Karten den nötigen GOP
    Modus nicht beherrschen und das dann zu Problemen kommt. Kannst Du das
    mal prüfen?

    Ähhmm, ehrlich gesagt - der Wille ist da, allein es fehlt das Know How.
    Ich habe bei MSI gegraben und in der Spec nichts gefunden. In diversen Internetforen herrscht die Meinung vor, die Grafikarte wäre "UEFI-geeignet".
    Welche MEthoden gibt's noch, das zu prüfen?


    Sorry, dass ich da nicht erfolgreicher war.


    Jürgen

    Tuner: Digibit R1 Sat>IP (4fach Tuner)
    Rekorder: TvHeadEnd 4.0.9 (auf OpenSUSE Tumbleweed)
    Player: Wetek Play mit LibreELEC 7.0.2
    sonstiges: AV-Verstärker: Yamaha RX-V775,TV: LG irgendwas

  • In der Regel ist das egal ob die Karte UEFI fähig ist, sind vmtl. viele in den VDRs nicht, die Maschine startet aber trotzdem und behandelt die Grafik in einer Art UEFI Kompatibilitäts Modus ...


    Was aber bei diesen Karten nicht funktioniert ist dieser "UEFI Grafikmodus", wo BIOS Splash ind OS Splash übergeht, weil das Mainboard mangels GOP Support keine Kontrolle über die Grafikkarte bekommt. Das kann zu komischen Ausgaben beim Boot führen. Du must da auch nix nachforschen, in den BIOS Settings einfach "Windows 7 Support" o.ä. prüfen und mal ausschalten.


    Mir ist kein Weg bekannt zu prüfen ob eine NVidia Karte GOP unterstützt, ausser das empirisch zu ermitteln ...


    Regards
    fnu

    HowTo: APT pinning

  • Hehe, die werbeaussage fuer die Intel CPU motherboards mit 48 * SD video streams (surveillance) in parallel sind schon verlockend: http://asrock.com/mb/Intel/J3455M/


    Ich will ja nicht 48 Ueberwachungskameras, aber mit den 4 Tunern in meinem VDR koennte ich eigentlich 16 sinnvolle SD Kanaele (das SD-GEMA buoquet ;-) auf einem 4K Display gleichzeitig darstellen. Dass waere schon witzig, und vielleicht sogar nuetzlich. Mal ein anderer Grund auf 4K aufzuruesten, gerade bei einem Projektor (wo man genug sichtbare Flaeche fuer die volle 4K Aufloesung hat). Gibt aber ja wohl bloss keine GUI fuer Darstellung mehrerer Bider im Raster, oder ? Denke nicht das bei VDR oder KODI gesehen zu haben. Wahrscheinlich am einfachsten mit einer Surveillance App der man die "Kameras" mit streamdev URLs konfiguriert.


    Aber Spass beiseite, auf dem VA-API thread ([Announce] VA-API/VPP Patch for vdr-plugin-softhddevice - updated "v9") ist ja nicht viel los, befuerchte mal, das man mit Intel GPU nicht so leicht ein problemloses VDR hinbekommt als wie mit NVidia. Fuer Mobos in "normalen" PCs stoert das ja nicht, kann man ja immer NVidia nachruesten. Aber so fuer NUC waers toll. Gerade die Beebox sieht guenstig/interessant aus.

  • Moin,


    hier die Zusammenfassung der Boot-Problematik


    Szenario #1

    • onBoard-Graka hat Prio 1
    • alle Einstellungen auf default (s.u.)
    • Bootmedium per USB + Bootpartiton auf /dev/sdaX

    Ergebnis #1

    • Booten führt ins BIOS-Setup
    • Im BIOS werden die beiden SATA-Platten als Platten erkannt
    • Es wird keinerlei Bootmedium angeboten


    Szenario #2

    • onBoard-Graka hat Prio 1
    • CSM: Enabled (die 3 Unterpunkte bieten ausserdem noch "Do not launch" und "UEFI only")

      • Launch PXE OpROM Policy: Legacy only (ist hier vermutlich völlig uninteressant)
      • Launch Storage OpROM Policy: Legacy only
      • Launch Video OpROM Policy: Legacy only
    • Bootmedium per USB + Bootpartiton auf /dev/sdaX

    Ergebnis #2

    • Booten führt ins BIOS-Setup
    • Im BIOS werden die beiden SATA-Platten als Platten erkannt
    • Im BIOS werden die interne SATA-Platte, sowie das externe Bootmedium (USB oder CD) als Bootmedien angeboten


    Szenario #2 scheint mir am vielverspechendsten. Das Problem hierbei ist, sobald ich die GT 730 auf Prio 1 setze,
    bekomme ich auf keinem der beiden HDMI-Ausgänge mehr eine Meldung und komme nur über CMOS-Clear wieder in einen
    brauchbaren Modus.


    hier die default Einstellungen:

    • Primary Graphica Adapter: Onboard
    • Security Boot: Disabled
    • CSM: Disabled


    "Windows 7 Support" o.ä. habe ich in den BIOS-Einstellungen und Hilfetexten nicht gefunden.
    Vermutlich ist das die CSM Einstellung?


    Leider liege ich im Augenblick mit ner dicken Erkältung flach, den ein oder anderen
    Aussetzer beim Posten bitte ich zu entschuldigen...


    Hilft es, wenn ich Screenshots von den BIOS-Seiten mache?


    Ciao
    Jürgen

    Tuner: Digibit R1 Sat>IP (4fach Tuner)
    Rekorder: TvHeadEnd 4.0.9 (auf OpenSUSE Tumbleweed)
    Player: Wetek Play mit LibreELEC 7.0.2
    sonstiges: AV-Verstärker: Yamaha RX-V775,TV: LG irgendwas

  • Mal ein anderer Grund auf 4K aufzuruesten, gerade bei einem Projektor (wo man genug sichtbare Flaeche fuer die volle 4K Aufloesung hat). Gibt aber ja wohl bloss keine GUI fuer Darstellung mehrerer Bider im Raster, oder ?

    VLC kann sowas mit dem Mosaic-Modul: https://wiki.videolan.org/VLC_HowTo/Make_a_mosaic/ (Bei vielen in dem Artikel verlinkten Dateien muss man die Wayback-Machine des Internet Archive bemühen) - über das Lua-HTTP Interface kann man sich das mit einem Assistenten aus Streams zusammenstellen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)


  • "Windows 7 Support" o.ä. habe ich in den BIOS-Einstellungen und Hilfetexten nicht gefunden.
    Vermutlich ist das die CSM Einstellung?


    Leider liege ich im Augenblick mit ner dicken Erkältung flach, den ein oder anderen
    Aussetzer beim Posten bitte ich zu entschuldigen...


    CSM = Compatibility Support Module bzw. Emulation eines herkömmlichen Bios.
    Benötigt z.B. für 32bit OS. Willst du Secure-Boot schließt das CSM aus, willst du CSM schließt das Secure Boot aus.
    CSM benötigt zusätzlich die Festlegung ob als Boot Mode "Legacy" oder "UEFI" willst, da geht kein auto.


    Du hast nicht verraten wie groß deine Platte ist. Ab 2TB brauchst du GPT statt MBR. Oder halt eine Bootpartition unterhalb der ersten 2TB auf der Platte.

  • Quote

    Du hast nicht verraten wie groß deine Platte ist

    Stimmt, sorry, bis auf das Mainboad, die CPU und das RAM hat sich an der Hardwareausstattung nichts geändert (das TV ist ein anderes...)
    D.h., die Bootplatte ist eine kleine SSD (jetzt zum Testen 64...256GB), die Datenplatte hat 1.5TB. Beide hängen an den einzigen SATA-Ports des Boards.
    Bootmedien werden über USB 2.0 angekoppelt. Probiert habe ich Sticks (8...16GB) und ein ext. CD-Laufwerk. Im Ergebnis macht das aber keinen Unterschied.


    Mir ist eigentlich egal ob UEFI oder nicht. Die Konstellation der Platten (kl. Bootplatte, große Datenplatte) soll so bleiben.
    Und ich möchte die GT 730 betreiben (scheint mir risikoärmer).
    Die Frage ist also: Worauf müssen die CSM-Untereinträge
    Launch Storage OpROM Policy und Launch Video OpROM Policy
    stehen ("Legacy only", "Do not launch" und "UEFI only")?


    Vielleicht bin ich ja etwas begriffsstutzig, aber für mich ist das nicht klar geworden...


    Schon mal vielen Dank


    Ciao
    Jürgen

    Tuner: Digibit R1 Sat>IP (4fach Tuner)
    Rekorder: TvHeadEnd 4.0.9 (auf OpenSUSE Tumbleweed)
    Player: Wetek Play mit LibreELEC 7.0.2
    sonstiges: AV-Verstärker: Yamaha RX-V775,TV: LG irgendwas

  • Werd dir darüber klar, ob du ein UEFI System haben willst.
    Falls ja:
    - select UEFI only bei diesen Einstellungen
    falls nein:
    - select Legacy only



    Falls dein Bios beides anbietet, wäre UEFI and Legacy die langsamste aber sicherste Einstellung.

  • Da du ja Probleme mit dem Platten finden hast, würde ich mal auf die Platte ein UEFI Loader installieren.


    Sieht so aus als ob das BIOS nicht immer legacy boot Modus kann.


    Gedankt sei dem Erfinder von UEFI und die Einfachheit von X86 Biosen.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • jgrete:


    1. Was haengt denn da fuer ein monitor an der GT 730 dran ? Ich habe mit Projektoren und TVs schon haeufiger das Problem, dass die nicht alle Aufloesungen anzeigen koennen, und dann beim booten bild schwarz blieb, bis dann mal X open war und eine supported Aufloesung anzeigte. Ich glaube auch mich erinnern zu koennen, dass details der aufloesung auf die graphikkarte ankommen, also bloss weil man bootbild bei der onboard intel sieht heisst das nicht dass die GT 730 genau dieselben bildeinstellungen machen wuerde. Also am besten das ganze erst mal mit einem PC monitor ausprobieren statt mit TV oder projector.


    2. Schliess mal keine SATA oder GT 730 an und versuch das system mit einem linux USB stick zu booten im default BIOS setup. Evtl. gucken dass der USB stick entweder GPT drauf hat (was UEFI ist), oder einfach ein ISO per dd drauf (CD-ROM kompatibel) Auch probieren, beim booten den boot-hotkey druecken um zur auswahl zu gelangen, da gibts bei BIOS'es haeufig verschiedene modi, wie ein USB angesprochen werden kann, ich hab nie versucht die zu verstehen, sondern bloss solange probiert bis ich eine option gefunden have die funktioniert.


    3. Sobald Du da ein linux am laufen hast, die GT 730 reinstecken, aber nicht BIOS aendern, sondern bloss im linux per lspci gucken, dass die karte erkannt wird, evtl. auch mal xorg auf der karte starten (passende config setzen etc). Was dann erstmal sagt, dass die karte funktioniert.


    4. Versuch mal rauszufinden ob deine GT 730 UEFI unterstuezt. Scheint vom verwendeten Chip oder wie alt die karte ist, abzuhaengen:
    http://forums.evga.com/Do-they…0-and-GT740-m2200753.aspx. Wenn Die Karte UEFI kann, dann solltest Du da auch im BIOS output kriegen, indem du im BIOS bloss die booprio auf diese PCIe Karte setzt. Wenn die karte kein UEFI kann, dann musst Du dich mit CFM rumquaelen wenn Du beim booten BIOS output auf der GT730 willst.


    5. Fuer die Beschreibung der "OpROM Policy" im Handbuch hat sich ASrock Waterboarding verdient. Ich habe keine Ahnung was das heissen soll. Da wird ja noch nicht mal die "do not launch" option erwaehnt die du beschreibst. Frage mich was der Unterschied zwischen "do not launch" und "UEFI Only" sein soll. Die hoffnung ware ja, dass "do not launch meint, dass sowohl UEFI also auch legacy BIOS devices "gebootet" werden sollen. Das macht verbal aber auch wenig sinn.


    6. Du hast nicht beschrieben, ob Du im Szenario 1 BIOS ausgabe bekommst.

  • 4. Versuch mal rauszufinden ob deine GT 730 UEFI unterstuezt. Scheint vom verwendeten Chip oder wie alt die karte ist, abzuhaengen:

    Selbst das ist kein 100% Indiz dafür. Der gleiche Chip in Karten gleichen Typs von verschiedenen OEM Herstellern können sowohl als, als auch nicht UEFI sein. Es hängt nicht an der HW, sondern an der BIOS Implementation der VGA Karten ... es gibt auch keinen einfachen Weg rauszufinden ob die Karte GOP unterstützt ...


    In der Regel laufen die Karten trotzdem, UEFI sieht da einen Kompatibilitäts Modus vor. Die GT630 in meinem Q1900M unterstützt auch kein GOP, VDR bootet schon immer UEFI und läuft seit, naja, seit dem Review den ich hier zum Mainboard geschrieben hatte ...


    Schon seltsam, alle aktuellen Mainboards die ich in letzter Zeit hier hatte, haben ohne Änderung sowohl MBR als auch UEFI gebootet. Ist halt schwierig zu helfen wenn man das Mainboard nicht vor sich hat ...


    Regards
    fnu

    HowTo: APT pinning

    The post was edited 1 time, last by fnu ().

  • Mir hat hat vor allem das Manual von dem Motherboard den Rest gegeben. Auf den Bildern kann man sehen, dass die Entwickler Monate in die graphische Aufbereitung der GUI gesteckt haben, und aus dem Text wird dann klar, dass da dann kein Geld mehr war um vernuenftige Funtionialitaet reinzubringen oder die existierende Funktionalitaet sinnvoll zu erklaeren. Stattdessen die klassische zero-use self referential explanations:


    "foobar: Enable foobar to enable the foobar function"


    Erinnert mich an KODI. Da wird auch immer 90% auf GUI Arbeit verschwendet. Die dann am besten nochmal mit jeder Release neu gemacht werden muss. Und die Komplexitaet der GUI dient nur dazu die Entwicklung von echter Funktionalitaet zu erschweren. *motz* *mecker* *beschwer*


    Eigentlich finde ich ASrock ja prima, hatte auch lange deren Motherboards gekauft, aber die sind ja wohl Sklaven ihrer Kunden. Naja, meine beiden letzten Motherboards waren ASrockRack. Leider teurer, aber gutes SnR.

  • Ist mir heute zugespielt worden:


    - http://www.technikaffe.de/anle…t_hdmi_2.0_und_hevc_10bit


    Da steht auch was zu CSM.


    Regards
    fnu

    HowTo: APT pinning

  • Moin,


    da habe ich ja ne Menge Hausaufgaben bekommen... einiges steht noch aus.
    Ich habe mir jetzt erstmal die beiden CSM-Optionen für "Storage OpROM" und "Video OpROM" vorgenommen und systematisch alle Kombinationen ausprobiert ("getestet" wäre an dieser Stelle nicht angebracht).
    Dabei kam dies heraus (DNL="Do Not Launch")



    wirbel : Da bin ich flexibel. Mir ist nämlich völlig egal, ob UEFI oder nicht. Wenn die Kiste läuft, wird für die nächsten Jahre der Deckel drauf gemacht und das Ding genutzt. Ich habe nicht vor, größere Experimente anzustellen (verdammt, was mach ich eigentlich gerade...).
    Leider scheint das Einfache aber nicht am einfachsten zu sein...


    te36 :
    zu 1. : Das TV-Gerät ist ein LG und ist recht tolerant gegenüber div. Modi. Es wird also auf jeden Fall auch das BootBIOS-Menü ("Press DEL or F2 for Setup, F11 for Bootmenu" etc) angezeigt.
    Da ich Geräte durchs Haus schleppen muss, um diesen Punkt abzuhaken, hab ich erstmal zurückgestellt.
    zu 2. und 3.: Der Punkt wird weitgehend durch die obige Testreihe Probierreihe abgedeckt. Die Bootmedien waren MLD 5.1 oder yaVDR 0.6.1 USB-Sticks oder CDROMs . Ein lspci steht noch aus,
    muss mir noch einen Kubuntu-Stick braten. Mit xorg.conf möchte ich mich eigentlich nicht auch noch auseinandersetzen (meine Linux-Server arbeiten samt und sonders im Textmode)
    zu 4.: Aus den Infos des von Dir genannten Links und meiner Rumprobiererei schließe ich, dass die Karte UEFI nicht unterstützt.
    zu 5.: Einen 5jährigen Aufenthalt im schönen Guantanamo-Resort mit wunderbarem Ausblick auf die Karibik und nettem Personal für die Jungs fände ich noch besser... :D
    zu 6.: Habe ich nicht beschrieben, weil alle Ausgaben über die OnBoard-Graka liefen.


    fnu : Hab den Bericht gelesen, danke. Spendet nicht viel Trost :]


    Aufgefallen ist mir noch, dass es bei der Bedienung des BIOS immer mal wieder Hänger gab, bis hin zum Einfrieren der Oberfläche.Ohne Reset-Taster war da kein Rauskommen.
    Ich werde jetzt noch kucken, ob die Karte überhaupt erkannt wird (lspci). Anschliessend baue ich dieGrafikarte in einen anderen PC ein mit einem GigaByte (?) Mainboard und versuche,
    einen MLD Live-Betrieb hinzubekommen (per SATIP).


    Bis später
    Jürgen

    Tuner: Digibit R1 Sat>IP (4fach Tuner)
    Rekorder: TvHeadEnd 4.0.9 (auf OpenSUSE Tumbleweed)
    Player: Wetek Play mit LibreELEC 7.0.2
    sonstiges: AV-Verstärker: Yamaha RX-V775,TV: LG irgendwas

  • Wenn du CSM (Bios kompatibilität, also *Legacy* ..) willst, dann willst du sicherlich auch Grafik und SATA, dann wirst du beide wohl auch auf Legacy stellen.


    Ohne CSM sollten dagegen diese Einstellungen ignoriert werden.