Welche vdr Version benutzen? (Linux)

  • Hallo zusammen,


    obwohl ich schon seit Jahren den vdr benutze bin ich mir immer noch unsicher, welche der vielen verfügbaren Versionen die richtige ist.


    Aktuell habe ich auf dem Homeserver (Ubuntu 14.04) einen vdr aus den yaVDR Quellen. Das ist das Backend.
    Auf meinem Hauptrechner läuft ubuntu 16.04, für das es aber (noch?) keine yaVDR Quellen gibt.


    Deshalb läuft wegen Versionsunterschieden der vdr-sxfe nicht (der reagiert je bekannt zickig auf unterschiedliche Versionen von xineliboutput-sxfe und vdr-plugin-xineliboutput)


    Wenn ich auf dem Server die yaVDR-Quellen entferne und vdr neu installiere geht's aber leider immer noch nicht (die Versionen sind auch immer noch unterschiedlich, nur anders). Nun geht auch Kodi auf dem Client nicht mehr, weil sich auf dem Server vdr-plugin-vnsiserver nicht mehr installieren lässt.


    Insgesamt bin ich ziemlich ratlos, was mit wem zusammen passt.


    Weiß hier jemand Rat?



    Der vdr-sxfe auf dem Client startet, spielt für 1-2 Sek den Ton ab und hängt dann.
    Nachdem ich wie empfohlen die engine.buffers.audio_num_buffers auf 750 erhöht habe kommt auch gar kein Ton mehr.
    Vielleicht zur Info: Es handelt sich um ein System mit Skylake Grafik (was ja auch nicht so ganz ohne Probleme ist)


    Hier mal die Ausgabe von vdr-sxfe -v


    Nachtrag: Gerade sehe ich: vdr-sxfe meldet sich mit "2.0.0-cvs (build with xine-lib 1.2.6, using xine-lib 1.2.6)"
    Im Paketmanager steht allerdings: "xineliblutput-sxfe Version 1.1.0+cvs20150907-3"
    Da werde ich auch nicht wirklich schlau draus.


  • OK, das Problem ist wohl eher das Grafiksystem (also die Intel Skylake Grafik) als der vdr.
    Wenn ich vdr sxfe mit dem Parameter --video=xshm starte, also genau genommen

    Code
    1. vdr-sxfe --video=xshm --post tvtime:method=Greedy,pulldown=0,use_progressive_frame_flag=1,Cheap_mode=1 xvdr+tcp://192.168.222.10


    dann klappt es, wenn auch mit ordentlich CPU-Last (8% bei SD und > 30% bei HD auf einem Intel i3-6100)


    Ich weiß nicht wirklich, was xshm ist, aber ich vermute, dass da keine Grafikbeschleunigung benutzt wird.
    Ich weiß, dass auch der vlc rumspinnt, wenn vdpau aktiviert ist. Deswegen habe ich alle vdpau-Pakete bis auf libvdpau-va-gl1 deinstalliert.


    Für den vdr habe ich testhalber vdpau-driver-all auch mal wieder installiert, aber ohne Erfolg.


    Ein weiteres bizarres Phänomen:
    Wenn ich vdr-sxfe aus dem "Startmenü" starte erscheint das Fenster kurz und verschwindet sofort wieder. Von der Kommandozeile aus geht's. Die Befehlszeile ist beide male genau gleich (nämlich die von oben)


    Kann das jemand erklären? Ich benutze Kubuntu 16.04


    Unter Kubuntu14.04 mit einem I5-2500 hat das alles noch perfekt funktioniert