[Gelöst] MP3 Plugin in yaVDR 0.6 spult nur durch

  • Hallo zusammen,


    wie schon mit yaVDR 0.5 will ich meine Musiksammlung mit dem Plugin MP3 (vdr-plugin-mp3) abspielen. Ich bekomme das aber irgendwie nicht ans Rennen.
    An den Berechtigungen scheint es nicht zu liegen:

    • Alle Verzeichnisse in der Hierarchie gehören vdr/vdr und haben für owner, group und other read, write und execute Berechtigung.
    • Alle Dateien gehören vdr/vdr und haben für owner, group und other read, write und execute Berechtigung, ohne execute habe ich es auch probiert.

    Das Plugin lässt sich starten, es zeigt die MP3-Dateien an.
    Die ID-Tags lassen sich anzeigen.
    Für Dateien sowie Verzeichnisse kann die Abspielfunktion aufgerufen werden.
    Die Fortschrittsanzeige zeigt die Länge und Abspielposition der Musikstücke an und es sieht so aus, als ob die Stücke mit der Vorspulfunktion ablaufen.


    Ich habe derzeit keine FB, stattdessen nutze ich eine USB Funktastatur von Logitech (K 400 Plus).


    Hat jemand eine Idee wo es klemmt? Gibt es alternative Plugins für den Zweck?


    -- Edit --
    Vermutliche Ursache:
    Es gibt einen Konflikt mit der Audio-Ausgabe. Der VDR verwendet lt. yaVDR Configurator "pulse" für die Soundausgabe, in der Plugin-Konfiguration ist DVB als Ausgabe eingestellt und kann nicht geändert werden. In Syslog wird ALSA bei der MP3-Wiedergabe genannt.
    Irgendwas passt da nicht.


    Alternative: vdr-plugin-music verwenden. Das sieht klasse aus und funktioniert mit ALSA als Ausgabe.
    -- Edit --


    Dank und Gruß,
    Klaus

    yaVDR 0.6.1 - Lenovo ThinkCentre A58 - Intel Pentium E5200 - 2 GByte RAM - 2TByte Disk - Gigabyte Geforce GT 630 - L4M-Twin S2 ver. 6.5 DUAL PCIe

    The post was edited 1 time, last by guckinsland ().

  • Steht eventuell etwas brauchbares in den Logdateien? Wie hast du die Audioausgabe konfiguriert (pulseaudio, alsa)?


    Für die Medienwiedergabe kann man allgemein KODI nutzen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo seahawk1986,


    KODI ist mir etwas zu mächtig, den möchte ich nur als letzten Ausweg nutzen.


    Meinen VDR habe ich out of the box installiert und so wenig wie möglich angefasst (getreu dem Motto "lass die Finger von den Dingen die Du nicht verstehst!").
    Im Dashboard vom yaVDR Configurator steht im Kasten "System" "Sound: pulse" ich setzt also vermutlich pulseaudio ein.


    Aus syslog habe ich das folgende aufgefunden (da wird alsa genannt?!?!):


    Das wars was ich augraben konnte.


    Grüße,
    Klaus

    yaVDR 0.6.1 - Lenovo ThinkCentre A58 - Intel Pentium E5200 - 2 GByte RAM - 2TByte Disk - Gigabyte Geforce GT 630 - L4M-Twin S2 ver. 6.5 DUAL PCIe

  • Hi,


    KODI ist mir etwas zu mächtig, den möchte ich nur als letzten Ausweg nutzen.


    ...oder man nutzt vdr-plugin-music - nur darauf achten das im Setup des Plugins als ausgabe "DVB" gewählt ist.



    Gruss
    Wolfgang

    Images

  • wolfgang : sieht ja GEIL aus - und funzt - aber nur mit ALSA ?!?! als Ausgabe.


    seahawk1986 : Das wird vermutlich auch das Problem mit dem MP3 Plugin sein. Dort ist ein den Einstellungen ebenfalls DVB als Ausgabe eingestellt, das kann ich aber nicht ändern X(.


    Jetzt muss ich mich wohl mit der Bedinung vom Music Plugin anfreunden, das Ding ist ja Mächtig. Irgendwo im Menü bin ich über einen Hilfe-Eintrag gestolpert. Ist der ausführlich?
    Gescheitert bin ich schon mal damit das Plugin während dem Abspielen zu beenden - das habe ich nur mit einem VDR Restart hinbekommen.


    Soweit erst mal vielen Dank an Alle,
    Klaus

    yaVDR 0.6.1 - Lenovo ThinkCentre A58 - Intel Pentium E5200 - 2 GByte RAM - 2TByte Disk - Gigabyte Geforce GT 630 - L4M-Twin S2 ver. 6.5 DUAL PCIe