[gelöst] DVB nicht 100%ig funktionsfähig nach Aufwachen aus S3 ...

  • Hallo!


    Seit der Neuinstallation von v 0.6 hatten wir standardmässig "Herunterfahren" im WFE eingestellt.
    Da der Start bis zur Benutzbarkeit (also Umschalten zuverlässig möglich) gerne mal knappe 3 Minuten braucht, haben wir im WFE jetzt auf "Suspend to RAM" umgestellt.
    Das klappt auch sehr gut - nach max. 30 Sekunden ist der yaVDR wieder bedienbar.


    ABER:
    Bei manchen Sendern steht dann "Kanal nicht verfügbar".
    Erst nach einem VDR-Neustart übers OSD (Menü - 7 System - 1 Befehle - 3 VDR neu starten) klappt - nach weiteren
    ca. 10 Sekunden - alles wieder wie am Schnürchen!


    Ich habs schon mit /etc/yavdr/force-reload-services.list bzw. ...-modules.list
    und dem Zusatz "usbcore.autosuspend=-1" in der /etc/default/grub versucht, aber das hilft alles nichts.


    Im Moment habe ich alle drei Maßnahmen wieder zurückgenommen und mache den Workaround übers OSD.
    Aber das ist äußerst lästig und der WAF ist stark gefährdet ...


    Gibt es eine Möglichkeit nach erfolgreichem Aufwachen aus dem S3 "automatisch" den "VDR neu zu starten" (analog zum OSD-Befehl)?
    Oder das/die Module bzw. Services zu finden, die das Aufwachen nicht überleben?


    Danke schon jetzt für eure Antworten und Tipps!


    greetz
    davie2000

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 3 times, last by davie2000 ().

  • Könnte ein timing-Problem sein, ein sleep an der richtigen Stelle könnte helfen.


    vdr-User-# 755 to_h264 chk_r

  • Naja, vmtl. sollten die anderen nötigen Dienste einfach nach dem S3 resume neu gestartet werden. Aber das können wir hier leider nicht vertiefen, sorry.


    Regards
    fnu

    HowTo: APT pinning

    The post was edited 1 time, last by fnu ().

  • Danke für eure Antworten!


    jsffm :
    Hmmm ... habe ich auch schon vermutet, weil es anderen bei ähnlichen Problemen auch geholfen hat.
    Aber WO (an welcher Stelle) sollte ich das sleep einbauen?


    fnu :
    Können wir das per PN vertiefen? (hab mal eine Freundschaftsanfrage geschickt)
    Oder in einem anderen Forum?
    Habe übrigens bereits nvidia (als modul) und ****** (als service) in den "force-reload"-Dateien drin gehabt, hat aber nichts gebracht.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 1 time, last by fnu ().

  • Moin... du musst dir mal mit vdrctl die Reihenfolge der Plugins ansehen...
    Das Böse kommt zuletzt...(99)


    [size=10]nOpacity: Icons
    [size=10]skindesigner: tryoutsglassy

  • Danke für eure gutgemeinten Tipps, aber ich steh irgendwie am Schlauch:
    Ein vdrctl spuckt bei mir das hier aus:


    Alle "disabled" mal ausgeblendet und aufsteigend sortiert ergibt diese Liste:


    Jetzt checks ichs: DU meintest das böse XX-Plugin - ICH benutze aber ****** und #####.
    Mein "böses" ****** wird offenbar als erstes (nach den statics) gestartet.
    Update:
    Habe mal (wieder) die Datei /etc/yavdr/force-reload-services.list angelegt mit einer einzigen Zeile:

    Code
    1. ******

    (natürlich ohne Sternchen)
    Bringt aber keinen Unterschied nach Aufwachen.

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD

    The post was edited 3 times, last by fnu ().

  • Erstmal ein großes Dankeschön an fnu und seahawk1986 für ihre Geduld und Kompetenz! :respekt


    Es hatte nichts mit Bösem zu tun, sondern meine DVB-Karten (TT-3200) waren zu langsam, um
    rechtzeitig vollständig aufzuwachen.


    Das Skript aus diesem Thread löst das Problem zuverlässig und ohne merkliche Verzögerung.
    (Die "reforce"-Dateien ziehen nicht mehr bzw. sind leer.)


    Endlich sind die Kaltstart-Wartezeiten > 2 Minuten vorbei - nach ~ 20 Sekunden gibts ein Bild *freu*
    Der WAF ist wieder auf normalem Niveau ;D


    S3 klappt also jetzt zuverlässig, auch mit meinen besonders langsamen Karten.
    Mal schauen, was bei S4 noch so geht ... :mua

    MyVDR (Hardwareliste) : yaVDR 0.6 - softhddevice-openglosd - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 17.1 - inputstream - amazon prime vod *broken*
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 3 TB HDD