Postfix 2.11/ 3.1 + smarthost (transport) => loop

  • Hallo !


    Ich hab ein wunderschönes Setup am laufen (läuft schon jahrelang so) ich hab das szenario auf ubuntu 14.04 und 16.04 nachstellen koennen (also Postfix 2.11 und 3.1 )
    meine transport sieht so aus:

    Code
    1. andere-domain.de smtp:[vpn-xxx.domain.net]
    2. * :[XX.YY.ZZ.XX]


    Da läuft alles Wunderbar mails an username@domain.tld werden local mit procmail in den account geschrieben
    Jetzt aendere ich die transport (postmap und reload sind ja obligatorisch damit das funktioniert :)

    Code
    1. andere-domain.de smtp:[vpn-xxx.domain.net]
    2. * :[smtp.smarthost.de]:587


    (die namen sind willkuerlich)
    Jetzt nimmt er eine E-Mail von username@domain.tld und schickt sie übern smarthost raus..... die kommt wieder rein und geht wieder raus... der klassiker :)
    die domain steht aber in /etc/postfix/domain (da stehen alle drin die lokal zugestellt werden sollen....


    Warum funktionierts im ersten fall und im zweiten nicht ?



    Gruss Gerd

    vdr => p8b75-m lx / pentium g2020t / 8 GB Ram / zotac gt 630 / cine S2 V5.5 / 60 gb ocz ssd / 640 gb wd scorpio blue / display noritake 256x64-3900 / chenbro PC71023 gehaeuse / yavdr stable / softhddevice


    spielsystem => p8b75-m le / intel core i3 3220T / ubuntu lts 14.04 / 16 GB ram / zotac gt 630 / cine S2 V6.2 / yavdr stable pakete / softhddevice / pulseaudio+alsa


    spielwiese => Zotac Zbox ID45 / 120 GB mSATA / via Satip => Octopus Net / yavdr stable / softhddevice

    The post was edited 2 times, last by gerdh ().

  • Bin zwar kein Postfix-Spezi, obwohl ich es auch verwende - aber die Regel sagt doch,
    daß nur andere-Domain über vpn-*** und ALLES (*) andere, also auch lokales,
    über den Smarthost (der das dann natürlich zurückschickt) gehen soll?


    Beim ersten Beispiel war da eine IP-Adresse, sollte zwar keinen Unterschied lt. Kommentaren im "transport" machen,
    aber die Frage wäre vielleicht in einer Postfix-Mailingliste besser aufgehoben.
    Ansonst halt einfach noch einen Eintrag für username@domain.tld vorher einfügen ...

    --
    vdr User #2022 - hdvdr2: Lenovo SFF M83, Intel(R) Core(TM) i5-4670S, 14 GB Ram, zram-swap/tmp, ubuntu-focal, softhddevice-vdpau
    ddbridge-6.x mit 2xDVB-S2 und (Flex) 2xDVB-C/T Tunern, nvidia-GF1050Ti SFF (nvidia-dkms-470), System SSD btrfs,

    snapper, 8TB HDD XFS/cow /srv/vdr, yavdr-ansible-2.5.6-seahawk, vdr-epg-daemon mit Frodo-plugins, Kernel 5.14.7-xfsscrub

    vdradmin-am, live+webstreaming, vdrmanager (Smartphones als FB), ffmpeg-4.3.1-libfdk_aac, vdr-plugin-hbbtv.