Version 1.2.2 und 1.2.3

  • Moin,


    im Git gibt es die Version 1.2.2 mit Bugfixes und einem neuen Feature.


    Der von Frodo gemeldete Bug, dass es manchmal bei der Anzeige von Timern crasht, ist behoben. Die Crashes im Zusammenhang mit dem Aufzeichnungsmenü insb. zusammen mit dem extrecmenu sollten jetzt hoffentlich auch Geschichte sein.


    Den Crash beim Starten des Plex Plugins konnte ich nachstellen und fixen. Bei mir crasht es jetzt aber an einer anderen Stelle in der poco lib. Ich musste meinem Gentoo eh erst mühsam beibringen, die Version 1.7.3 zu installieren, dann war in dem Overlay ebuild wohl noch ein Bug, dass ein Patch gefehlt hat. Den hab ich dann rausgeschmissen, keine Ahnung, wie relevant der war. Bauen tut das Plex Plugin Problemlos, aber starten tuts net. Bitte mal testen, ob das an mir oder an der poco Version liegt?!


    Wäre prima, wenn das die Betroffenen mal testen könnten...


    Ausserdem gibt es jetzt neue Tokens in "displayreplay", die ermöglichen, eigene Icons bei langsamem Vor- und Rücklauf darzustellen. Die neuen Tokens sind im skinskeleton in der displayreplay.xml beschrieben.


    Ciao Louis

  • Hab mal kurz probiert unter vdr4arch, Plex mit MPlayer lies sich hier starten ;)

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Ergänzend vielleicht noch, ich verwende hier:

    Code
    1. poco 1.7.4-1

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Danke für deine Mühe. Leider zerbröselt es den VDR nach wie vor bei Einsatz von estuary4vdr. Mit metrixhd gehts problemlos.

    Im Serienunterordner schneiden einer Aufnahme mit Button [EDIT] 2 [/EDIT] angestossen, während des Schneidevorgangs Versuch das Hauptmenü mit Back zu verlassen und schon hängt der Kram.

    The post was edited 3 times, last by iNOB ().

  • Hi inob,


    danke fürs testen...ich habe jetzt mal noch eine Kleinigkeit auf Verdacht geändert, kannst du bitte nochmal mit der aktuellen Git Version neu bauen und testen?


    Falls es immer noch crasht, müsstest du mir nochmal genau beschreiben, was du tust. Was genau bedeutet "Mit 0 Schnitt gestartet"? Wenn ich auf einer Aufzeichnung bin und 0 drücke, wird die Sortierreihenfolge geändert. Wenn ich bei laufender Aufnahme mit "2" den Schnitt starte und dann die Wiedergabe beende, kann ich problemlos auch das Menü schließen. Ausserdem wäre ein vollständiges Log (am besten ab VDR start) und ein Coredump vom crash hilfreich ;)


    Ciao Louis

  • Moin,


    wie ich gerade festgestellt habe, war da auch noch ein kleines Speicherloch :D Also auf jeden Fall mal upgraden...wird dann auch bald ne Version 1.2.3 geben.


    Ciao Louis

  • Auf den ersten Blick sieht das schon viel besser aus. Ich teste das mal intensiv mit "Powercutting", einen ganzen Ordner von Serienfolgen zusammenschneiden. Melde mich dann nochmal.

  • Beim Verschieben der Schnittmarken mit 4 + 6 bleibt mir jetzt das Bild inkl. OSD stehen. Nach einer Weile läuft der Ton der Aufnahme weiter. Abstürzen tut er zwar nicht, aber bedienen kann man nix mehr.


    [EDIT]Hab softhddevice jetzt mit "-w still-hw-decoder -w still-h264-hw-decoder" gestartet. Sieht besser aus, ich teste weiter. [/EDIT]

    The post was edited 1 time, last by iNOB ().

  • Mit den o.g. Workarounds für softhddevice scheint das so zu funktionieren, auch mit estuary4vdr. Allerdings verschwindet bei Umstellung des Displayformats in softhddevice (pillarbox, center-cut-out...) das komplette OSD und läßt sich nicht wieder herstellen. Egal mit welchem Skin (metrixhd+estuary4vdr).

    The post was edited 1 time, last by iNOB ().

  • Wäre prima, wenn das die Betroffenen mal testen könnten...


    Mein Crash ist leider noch mit dabei, mit dem Update von heute konnte ich noch nicht testen.


    Auch hier wieder Crash beim direkten Sprung ins recordings-menu, wenn dieses noch nicht vollständig eingelesen ist.


    bt:


    log:


    Die lange Timerliste (warum erscheinen die eigentlich alle als timer 1?) und andere unschöne Dinge habe ich gesnippt.


    Edit: auch mit aktuellem git:


    Christian

  • Drückst du auf Rot, bevor das erste Mal die Einblendung der Kanalinfo beim Starten kommt? Hab das versucht nachzustellen, allerdings immer erst nach der ersten Anzeige der Kanalinfo und anschließendem Drücken der roten Taste. Das hat eigentlich immer funktioniert. Bei mir sind es rund 800 Aufnahmen und ca. 25 Timer (über externen epgd).

  • Moin hopsi,


    hm, aus dem Backtrace kann ich nichts rauslesen...mir scheint, dass der VDR zu dem Zeitpunkt noch in einem leicht undefinierten Zustand ist ;) Was passiert denn, wenn du das gleiche mit einem nativen Skin, z.B. LCARS machst? Kommt dann nur der bereits eingelesene Teil der Aufnahmen oder dauert es erst ein bisschen, bis sich das Menü öffnet?


    Ich frage mich wie ich das nachstellen kann, bei den wenigen Aufnahmen, die ich so habe, geht das Einlesen quasi in Nullzeit. Ich könnte höchstens den VDR patchen, dass er nach jeder eingelesenen Aufnahme 200ms wartet oder so...aber mal schauen ob wir das Problem nicht noch anders in den Griff bekommen ;)


    Ciao Louis

  • Moin,


    wenn's mit dem Nachstellen so leicht wäre. Auch bei mir ist das nur ein 'manchmal'-Fehler und den genauen Zeitpunkt zu treffen, scheint schwierig. Ich habe gerade 15 Neustarts hinter mir, aber konnte den Crash nicht provozieren.
    Ich nutze hier übrigens nicht 'Red', sondern 'Recordings'. Aber auch das dürfte kaum Unterschied machen.


    Ich bin mir allerdings recht sicher, daß zum Zeitpunkt der beiden Crashs die erste Einblendung der Kanalinfo noch aktiv war.


    Christian

  • Hi Hopsi,


    hm...ich dachte bei dir crasht es immer wenn du schnell das Menü öffnest...wenn das auch nur sporadisch ist, macht das die ganze Sache natürlich nicht einfacher. Hab grade auch keine sinnvolle Idee, wie man das weiter eingrenzen könnte. Ggf. könntre ich mal ein paar Debug Ausgaben einbauen, vielleicht sieht man dann da besser, wo es knallt. Muss ich mir mal in Ruhe überlegen, welche Debug Ausgaben da Sinn machen...


    Ciao Louis

  • Moin,


    Mit den o.g. Workarounds für softhddevice scheint das so zu funktionieren, auch mit estuary4vdr.


    Prima, danke fürs testen und das Feedback.


    Allerdings verschwindet bei Umstellung des Displayformats in softhddevice (pillarbox, center-cut-out...) das komplette OSD und läßt sich nicht wieder herstellen. Egal mit welchem Skin (metrixhd+estuary4vdr).


    Das wird wohl mit dem OpenGL OSD zusammenhängen. Da wird aufgrund einer Änderung in der Ausgabe das OSD Surface kaputt gehen. Nach einem VDR Restart ist das OSD aber dann wieder da oder? Sehe ich jetzt nicht als wirkliches Problem, das stellt man ja einmal nach seinem Geschmack ein und lässt es dann so...


    Ciao Louis

  • Richtig. Ist mir gestern nur zufällig aufgefallen beim Testen.

  • Moin,


    ich habe im Git mal eine Version 1.2.3 getaggt. In der 1.2.2 war noch ein übles Memory Leak, also unbedingt von der 1.2.2 updaten.


    Die "slow forward" and "slow rewind" Thematik habe ich nochmal überarbeitet. Es ist dahingehend jetzt nicht mehr abwärtskompatibel als dass bei langsamem Vor- und Zurückspulen jetzt wirklich das entsprechende Token ausgewertet werden muss. In den bestehenden" Skins müsste das also nachgezogen werden...


    Ciao Louis

  • Hallo louis,


    hab hier noch ein Problem mit Skindesigner-1.2.3 - Skin estuary4vdr & simplex!
    Im Hauptmenu von Plugin Music wird noch alles angezeigt, gehe ich z.B ins Menu Aussehen verändern werden nur << 10% von Menu angezeigt.
    Wo kann muss ich das ändern??


    P.S
    Bei all den andern Skins ist das Menu korrekt!


    Danke & Gruss
    Wolfgang

    Images