epgd / epg2vdr / scraper2vdr

  • Sehr schön...funktioniert auf den ersten Blick.


    Der Zugriff auf die "Constabel Episodenliste" in der Info zu einem Serienevent funktioniert leider nach wie vor nicht. Meinereiner bekommt da eine Fehlermeldung von wegen "Der Server konnte nicht erreicht werden!". Da das schon einmal funktioniert hat und ich an der Netzconf bei mir nichts geändert habe nehme ich an, dass der Fehler wohl am Programm liegt.


    Der für die Analyse relevante Fehler den die libcurl zurückliefert steht im log, bei dem oben beschriebenen Problem ist es:

    Code
    1. ...... epghttpd: Error, download failed; Problem with the SSL CA cert (path? access rights?) (77)


    Jörg

  • es gibt hier wohl einen false friend, zumindest bei ubuntu:


    Ich hatte es vorher gegen 'libcurl4-nss-dev' kompiliert, damit geht alles bis auf das geschilderte Problem.


    Jetzt haben wir stattdessen gegen 'libcurl4-openssl-dev' gebaut und damit gehts.



    Christian

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5

  • Jup... das war der Fehler :)


    Thx an alle Beteiligten.
    iNOB

  • Hi,


    Jetzt haben wir stattdessen gegen 'libcurl4-openssl-dev' gebaut und damit gehts.

    :] Merci, Merci!


    Hab hier noch einen Fehler/Warning im syslog

    Code
    1. Nov 25 16:29:44 easy3 epgd: Received 5 episode files
    2. Nov 25 16:29:45 easy3 epgd: Warning: (Tatort) Got invalid episode line [47#01137#0111005#011n.n.], at lease 7 columns expected
    3. Nov 25 16:29:45 easy3 epgd: Warning: (Tatort) Got invalid episode line [47#01138#0111006#011n.n.], at lease 7 columns expected
    4. Nov 25 16:29:45 easy3 epgd: Warning: (Tatort) Got invalid episode line [47#01139#0111007#011n.n.], at lease 7 columns expected
    5. Nov 25 16:29:45 easy3 epgd: Warning: (Tatort) Got invalid episode line [47#01140#0111008#011n.n.], at lease 7 columns expected


    ...auch von mir Merci, Merci an alle Beteiligten!



    Gruss
    Wolfgang

  • Fehler ist in der Tatort Datei bei eplists, nicht im epgd.

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5

  • Hallo,


    ich hatte noch einen bug bei den Aufnahmen bei mobilen Geräten. Zusätzlich habe ich das Verhalten bei drag and drop noch angepasst.
    Als nächstes werde ich es dann einbauen, dass man mehrere markieren kann und die in einem Rutsch löschen, vlt auch verschieben kann.


    Habt ihr die Suche eigentlich schon gesehen?


    Rechner

  • Hallo,


    ich habe hier vdr 2.2.0 (aus dem Repository von e-tobi), sowie epgd 1.1.42, epg2vdr 1.1.16 und scraper2vdr 1.0.1 (alle selbst gebaut).
    Immer mal wieder beim Beenden von Aufnahmen bekomme ich einen segfault in libvdr-epg2vdr.so.
    Nachdem ich es nicht geschafft habe, eine Reproduzierbarkeit herzustellen und auch hier im Forum nichts dazu gefunden habe, habe ich es jetzt endlich mal geschafft einen Backtrace zu erstellen.



    Ich habe in diesem konkreten Fall auf 2 Kanälen Direkt-Aufnahmen gestartet (ohne Timer) und dann im Hauptmenü versucht, eine dieser Aufnahmen zu beenden.
    Ich hatte denselben Fehler aber auch schon bei Timer-Aufnahmen, bei nur einer Aufnahme, usw..


    Ich habe versucht, mir den Segfault anhand des Codes zu erklären - ohne Ergebnis :-)
    Wäre schön, wenn jemand was dazu sagen könnte.


    Tschuess..
    Michael

  • Huhu,


    nach einigen Updates zeigt mir (yavdr/Frodo) das epghttpd in den Serien immernoch 'Server konnte nicht erreicht werden'... ist das nur bei mir so? Ich habe in der epgd.conf die Url auf 'eplists.de' geändert.
    Wenn ich im epghttpd die Url mit meinem Zugang angebe, wird diese auch fehlerhaft abgespeichert - es fehlt ein'/ hinter dem 'http:''


    Ist das vielleicht nur ein Schönheitsfehler?

  • Da wurden die Abhängigkeiten noch nicht geändert soweit ich dass die Tage gesehen habe im Bezug auf libcurl4-openssl-dev

    Gruß utiltiy



    VDR Projekte VDR Projects

  • Hallo zusammen,


    Im Webif kann man jetzt auch einzelne Aufnahmen selektieren und mit einem beherzten Klick auf den Mülleimer auch löschen.
    Irgendeiner wollte das mal haben, kann mich nicht errinnen wer.
    Drag and Drop geht natürlich auch noch. Die Hilfeseite dazu habe ich auch erweitert.


    gruss
    Rechner

  • @utility
    ich danke Dir für die Info! Werde dann mal abwarten...

  • Hallo zusammen,


    Im Webif kann man jetzt auch einzelne Aufnahmen selektieren und mit einem beherzten Klick auf den Mülleimer auch löschen.
    Irgendeiner wollte das mal haben, kann mich nicht errinnen wer.
    Drag and Drop geht natürlich auch noch. Die Hilfeseite dazu habe ich auch erweitert.


    gruss
    Rechner



    Erstmal Daumen hoch. Das Ding wird immer komfortabler.


    Beim Testen ist mir Aufgefallen wenn eine Aufnahme markiert und gelöscht werden soll und ich mich dann doch Entscheide das ich die Aufnahme nicht Löschen möchte wird das NEIN nicht aktzeptiert und die Aufnahme wird gelöscht.


    Gruß

    MLD 5.1 - Server - testing - ASROCK Q1900m - SSD 128 GB - HDD 4TB - Max S8
    MLD 5.1 -SZ - testing - SatIp-Client - Raspi 3
    MLD 5.1 -WZ - testing - SatIp-Client-Squeezplayer 7" RPI-Display - Raspi 3
    MLD 5.3 -WZ - unstable - SatIp-Client - ASROCK980DE3 - SSD128 GB - Athlon64 XII 240 - GT 730

  • Alles gut. Wir sind doch zum Testen da. :tup



    Gruß

    MLD 5.1 - Server - testing - ASROCK Q1900m - SSD 128 GB - HDD 4TB - Max S8
    MLD 5.1 -SZ - testing - SatIp-Client - Raspi 3
    MLD 5.1 -WZ - testing - SatIp-Client-Squeezplayer 7" RPI-Display - Raspi 3
    MLD 5.3 -WZ - unstable - SatIp-Client - ASROCK980DE3 - SSD128 GB - Athlon64 XII 240 - GT 730

  • Sorry aber ich habe da noch was.


    In den Suchtimern besteht das Problem auch. In der Übersicht und unter Bearbeiten eines einzelnen Suchtimers wird das NEIN beim löschen auch ignoriert.



    Gruß

    MLD 5.1 - Server - testing - ASROCK Q1900m - SSD 128 GB - HDD 4TB - Max S8
    MLD 5.1 -SZ - testing - SatIp-Client - Raspi 3
    MLD 5.1 -WZ - testing - SatIp-Client-Squeezplayer 7" RPI-Display - Raspi 3
    MLD 5.3 -WZ - unstable - SatIp-Client - ASROCK980DE3 - SSD128 GB - Athlon64 XII 240 - GT 730

  • So, grade getestet. Klappt jetzt wie es soll.



    Gruß

    MLD 5.1 - Server - testing - ASROCK Q1900m - SSD 128 GB - HDD 4TB - Max S8
    MLD 5.1 -SZ - testing - SatIp-Client - Raspi 3
    MLD 5.1 -WZ - testing - SatIp-Client-Squeezplayer 7" RPI-Display - Raspi 3
    MLD 5.3 -WZ - unstable - SatIp-Client - ASROCK980DE3 - SSD128 GB - Athlon64 XII 240 - GT 730

  • Woher bekommt epgd bzw. epghttpd die Channels? Schlussendlich doch aus der channels.conf des VDR oder?


    Wie kann es passieren, dass Sender, die in der channels.conf definiert sind, nicht im Webinterface des EPGD auftauchen?


    Edit 2: Ok, jetzt bin ich verwirrt. Es scheinen nur die Sender im Webinterface aufzutauchen, die in der channelmap.conf definiert sind. Dabei dachte ich müssten dort nur die Sender eingetragen werden, für die man ein zusätzliches EPG (zum DVB Stream) haben möchte, wenn man in der setup.conf des VDR ein "epg2vdr.Blacklist = 0" konfiguriert hat?! Muss ich dann jetzt doch alle Sender in der channelmap.conf definieren wenn ich sie im Webinterface sehen möchte?


    Zwei Beispiele wären:


    PHP
    1. N24 DOKU;BetaDigital:12460:HC34M2S0:S19.2E:27500:511=2:512=deu@3:34:0:48:133:5:0
    2. kabel eins Doku;ProSiebenSat.1:12544:HC56M2S0:S19.2E:22000:2559=2:2560=deu@3:41:0:17509:1:1107:


    2. Frage: Gibt es eine Möglichkeit die Namen der Sender in der Magazin Ansicht auszublenden, wenn dort bereits ein Logo vorhanden ist?


    Edit: Zu Frage 2. habe ich in den Einstellungen eine Lösung gefunden, allerdings wird bei den Sendern für die es keine Logos gibt (siehe Punkt 3) dann ebenfalls der Name entfernt. Das ist wiederum nicht sinnvoll.


    3. Frage: Bei Sendern für die es keine Logos gibt, wird ein "hässliches Bild" mit einem Fragezeichen darin eingeblendet. Kann man das irgendwie unterdrücken?



    Grüße,
    Alex

    Server: Supermicro X9SAE, Intel Xeon E3-1245v2, ESXi 6.5

    VDR VM: Ubuntu 16.04 LTS, 2x DD Cine S2, VDR 2.3.8

    The post was edited 2 times, last by Honker ().

  • Woher bekommt epgd bzw. epghttpd die Channels? Schlussendlich doch aus der channels.conf des VDR oder?


    Nein, aus der channelmap.conf, bzw. aus der Datenbanktabelle channelmap. Dort kann man sie über Einstellungen / Kanäle bearbeiten auch passend benennen.
    Alternativ per SQL-Statement, da kann man dann auch die Sortierung anpassen, z.B.


    SQL
    1. UPDATE channelmap SET channelname = 'SWR Fernsehen BW', ord = '52' WHERE channelid = 'S19.2E-1-1101-28113';


    Wie kann es passieren, dass Sender, die in der channels.conf definiert sind, nicht im Webinterface des EPGD auftauchen?


    Naja, die stehen nicht in der channelmap.conf des egpd - s.o.


    [...]


    2. Frage: Gibt es eine Möglichkeit die Namen der Sender in der Magazin Ansicht auszublenden, wenn dort bereits ein Logo vorhanden ist?


    Ja, das ist eine der Einstellungen im Web-Interface: Einstellungen - allgemein - System - logoShowName


    3. Frage: Bei Sendern für die es keine Logos gibt, wird ein "hässliches Bild" mit einem Fragezeichen darin eingeblendet. Kann man das irgendwie unterdrücken?


    Man könnte ein "schönes" Bildchen nehmen und passend benennen.


    Grüße,
    Alex


    Ciao.
    Michael.