Externremux Problem - x264 Codec - Schrottstream

  • Hallo,


    meine Festplatte wurde defekt und daher habe ich eine ander Festplatte eingebaut und Ubuntu 16.04 neu installiert und VDR neu aufgesetzt.
    Allerdings liefert mir der Aufruf -> mplayer 'http://10.0.0.2:3000/EXT;VC=x264;ABR=128;VBR=512;WIDTH=512/96' nur ein Schrottbild, nichts passt mehr?
    Ich verwende die Originalsourcen, die ich vor dem Defekt wegkopiert habe, also auch die Plugin Konfigurationen.


    VDR generiert mir folgenden Befehl:
    May 16 11:54:59 vdr vdr: [1417] externremux.sh: mencoder -msglevel
    all=1 -ovc x264 -x264encopts threads=auto:bitrate=512 -oac mp3lame
    -lameopts preset=128 -alang eng -vf scale=512:-11 -zoom -o
    /tmp/externremux-2746 -- -



    [IMG:http://i66.tinypic.com/96zypd.jpg]


    Irgendwas stimmt am generierten Befehl nicht. Fehlt ev. eine Lib oder sonstwas?



    thx

  • Probiere mal den link im VLC aus'http://10.0.0.2:3000/EXT;VC=x264;ABR=128;VBR=512;WIDTH=512/96'
    Werden da die Farben auch so schlecht dargestellt?
    Dann weist du zumindest ob es den VDR oder mplayer liegt.

    -- wird überarbeitet -- VDR- Server: Gigabyte Brix 3150 - (2x Hauppauge DualHD DVB-C Sticks mit 4 Tunern) - Ubuntu 18.04 - Aufnahme und Streaming-Server
    Client Wohnzimmer: DQ77KB - i3 - Logitech z-5500 - Blaupunkt 39" TV - Openelec (Streaming)
    Client Büro: Asus AT3N7A-I , yaVDR0.6.1 (Streaming + Cutting) - 19" TFT
    Test Client1: Raspberry Pi + openelec

  • Also x264 hat noch nie beim vlc funktioniert da kommt nur der Ton.
    Es muss am VDR Streamdev?? liegen, was passiert wenn du den mencoder Befehl, der vom VDR generiert wird, auf ein mpg anwendest? Da müsste doch bei dir auch so ein Schrottvideo rauskommen?


    mencoder -msglevel


    all=1 -ovc x264 -x264encopts threads=auto:bitrate=512 -oac mp3lame


    -lameopts preset=128 -alang eng -vf scale=512:-11 -zoom -o


    /tmp/externremux-2746 -- -


    thx

  • Nach deinem Bild liegt es eher am Player oder Grafiktreiber.

  • Ich glaube es hat was mit mencoder und dem Codec x264 zu tun (auf 2Pcs mit KUbuntu 16.04 getestet):


    mencoder test.mpeg -msglevel all=1 -ovc x264 -x264encopts threads=auto:bitrate=512 -oac mp3lame -lameopts preset=128 -alang eng -vf scale=512:-11 -zoom -o out.avi
    MEncoder 1.2.1 (Debian), built with gcc-5.3.1 (C) 2000-2016 MPlayer Team
    x264 [info]: using SAR=65/64
    x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 Cache64 SlowShuffle
    x264 [info]: profile High, level 3.0
    Segmentation fault (core dumped)


    Ich glaub ich versuchs mal auf ubuntuusers.de