SelfSat IP36 (SAT>IP Server) stürzt ab während EPGScan

  • In VDR dito.

    Einfach Sendersuchlauf und fertig. Oder noch einfacher, eine bekannt funktionierende Senderliste benutzen, gibt ja diverse Quellen dafür. ;)

  • Habe heute von Selfsat bzw. IDOIT die aktuelle Firmware erhalten für die IP36 (S/W Version: 3.1.17).

    Update war auch erfolgreich entsprechend der log-Dateien.

    Allerdings bekomme ich noch immer kein Signal von der Antenne. Die frontend-Information des neuen WebUI sagen auch aus,

    dass kein Tuner läuft.

    Legacy funktioniert tadellos.

    Bin langsam ratlos.


  • Du siehst einfach, dass kein einziger Client verbunden ist.

    Was völlig perfekt ist und genau so zu erwarten ist, wenn mit deinem Netzwerk oder deinen Clients etwas falsch konfiguriert ist.


    Möglicherweise sind in deinem Netzwerk einige Ports nicht freigegeben, die Verbindung bricht ab o.ä.

    Was sagen denn die logs der Clients?

  • Ja, das riecht nach Netzwerkproblem oder Fehl-Konfiguration.


    Hier hat das jemand mit der VU+ eingerichtet:

    Quote

    Habe nun die Selfsat>IP36 am Start. Installation war ein Kinderspiel. Habe erst mit Koaxkabel und e2remote an der VU+ ausgerichtet bis Signal optimal war. Danach Antenne über Cat5.e-Kabel mit Fritz!Box verbunden. An der VU+ SAT>IP Client eingerichtet (virtuelle Tuner). Nun kann ich ohne Koaxkabel an der VU+ alles wie vorher auch sehen/aufnehmen etc. Am ipad über elgato-App war auch sofort Live-TV da. [...]


    Probiers doch mal mit der o.g. App, vllt geht's ja damit.

  • Weil ich gerade dabei bin dokumentiere ich das Firmware Update von 2.x auf 3.1.18 unter Linux per SSH:

    Die Selfsat kommt nicht wieder hoch, man muss sie kurz vom PoE trennen.


    Mit einem lachenden und einem weinenden Auge sehe ich: die Sicherheitslücke "SSH offen mit banalem Passwort" wurde gestopft. SSH ist zwar noch aktiv, aber das Passwort ist unbekannt, deshalb kein Login mehr möglich. Dafür hat man eine Weboberfläche auf Port 8000.

  • p3t3r

    Ich habe sowohl deine Anleitung als auch das mitglieferte gss4p tool benutzt. Das läuft beides durch und sagt "OK", aber nach einem Reboot hat sich rein gar nichts verändert.

    SSH geht immernoch mit Standard-Passwort. Webinterface auf Port 8000 ist nicht da (nur der Redirect auf example.com).


    Ich habe allerdings eine IP38 (nicht 36). Weiß jemand, ob da irgendwas anders ist? Auf der selfsat.com gibt es ja nur dieses eine zip file mit der Firmware. Da wird ja nicht nach genauem Model unterschieden.

  • Ich hab bei meiner selfsat einfach busybox passend compiliert und auf /data abgelegt. Damit kann man dann per

    /data/busybox passwd


    sein eigenes Passwort nach Gutdünken setzen, was bis zum nächsten reboot bestehen bleibt (weil halt schreibgeschützes Dateisystem).

    Natürlich könnte man auch das Dateisystem erst readonly mounten, dann, .. Aber da die selfsat bei mir eh (fast) nie rebootet wird..


    Nebenbei kann dieses busybox auch ein paar weitere Befehle mehr.

  • wirbel

    Ja, aber bei mir wird das Firmware Upgrade nicht aktiv. Ich will gar nicht dass SSH-Passwort ändern, das war nur als Indikator gemeint, woran ich erkenne, dass es immer noch die alte Firmware ist. ebenso dass das Webinterface noch nicht geht.

  • Sorry für Doppelpost, aber anscheinend ist die neue Firmware bei mir doch aktiv. Wenn ich direkt auf <ip>:8000/login.html gehe, kann ich mich einloggen und bekomme auch die neue Version angezeigt.


    Am SSH User hat sich also im Gegensatz zu p3t3r nichts geändert, und die index.html vom WebUI ist wohl noch die alte.


    Leider kann man auf dem SSH Account keinerlei Informationen rausfinden, was man denn eigentlich hat. Oder hat schon jemand nützliche Tools gefunden?

  • Hi, ist zwar etwas off-Topic aber das scheint das einzige Forum mit seltsat ip Experten zu sein.

    Ich habe ein Firmware Update wie oben beschrieben durchgeführt, doch leider ist die Antenna nach dem Reboot und PoE abstöpseln und wieder dran nicht mehr über den Netzwerkport ansprechbar. Die Leitung ist tot. Etliche Male das Kabel gezogen und wieder rein, hilft alles nix.

    Hat jemand eine Idee wie ich die Antenne wieder in den Urzustand versetzen kann? SSH etc. ist ja nicht möglich da der Netzwerkport nicht mehr aktiv ist. Hat das Ding schonmal jemand aufgeschraubt?

    Habe schon den Support angeschrieben, da kam bisher aber nichts zurück.

    Danke schonmal für jegliche Art der Hilfe.

  • Das Handbuch sagt dazu..

    "Öffnen Sie den Deckel nicht, jeglicher Reparatur-Versuch einer nicht entsprechend ausgebildeten Person kann gefährlich sein"

    "Dieses Produkt enthält einen Universal-LNB, es ist untersagt, einen LNB hinzuzufügen, ihn auszuwechseln oder zu verändern."


    Der Support des Herstellers weiß sicher mehr. Vielleicht sind giftige Stoffe verbaut.

  • Hallo,

    ich habe auch eine SelfSat IP und komme seit Tagen nicht mehr auf den uPNP-Server der Schüssel :-(


    Manuell als "RTSP Network Device" kommt man an die Streams und ich nutze grade alternativ den DVBViewer Media Server um überhaupt was sehen zu können.


    Reset und Firmwareupdate auf 3.1.18 haben nichts gebracht, der SelfSat Server ist nach einem Reset für einen kurzen Moment "zu sehen" und scheint dann wieder beendet zu werden.

    Gibt es eine Möglichkeit, den Server manuell über SSH zu starten?


    Danke und Gruß

    Jens

  • Hallo,

    hier noch die laufenden Prozesse:


    Mem: 26248K used, 99688K free, 0K shrd, 0K buff, 15344K cached

    CPU: 8% usr 88% sys 0% nic 0% idle 0% io 0% irq 4% sirq

    Load average: 0.53 0.33 0.18 3/60 13081

    PID PPID USER STAT VSZ %VSZ %CPU COMMAND

    597 557 root S 2688 2% 72% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    12134 12111 root R 1520 1% 12% top

    9119 557 root R 2688 2% 4% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    11708 513 root S 1592 1% 4% dropbear

    3 2 root SW 0 0% 4% [ksoftirqd/0]

    592 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    558 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    555 1 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    593 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    599 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    557 555 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    594 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    605 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    604 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    600 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    602 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    606 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    8785 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    12811 557 root S 2688 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    480 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    477 1 root S 2200 2% 0% /opt/bin/mongoose 8000

    483 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    485 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    481 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    482 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    487 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    486 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    490 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    488 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    489 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    479 477 root S 2200 2% 0% /opt/bin/mongoose 8000

    484 479 root S 2200 2% 0% /opt/bin/mongoose 8000

    513 1 root S 1528 1% 0% dropbear

    507 1 root S 1528 1% 0% udhcpc -b -i eth0 -s /etc/udhcpc.conf -p /var/run/udhcpc.eth0.pid -t 3 -T 6 -A 100

    12111 11708 root S 1520 1% 0% -sh

    471 1 root S 1520 1% 0% acpid

    1 0 root S 1512 1% 0% init

    260 1 root S 1512 1% 0% syslogd -m 0 -s 1024 -b 3 -L -S

    516 1 root S 1512 1% 0% ntpd -p pool.ntp.org

    614 1 root S 1512 1% 0% init

    615 613 root S 1512 1% 0% sh -c logger

    616 615 root S 1512 1% 0% logger

    262 1 root S 1504 1% 0% klogd

    613 1 root S 1152 1% 0% /opt/bin/system-monitor

    4 2 root SW 0 0% 0% [kworker/0:0]

    271 2 root SW 0 0% 0% [ubi_bgt0d]

    17 2 root SW 0 0% 0% [kswapd0]

    279 2 root SW 0 0% 0% [ubifs_bgt0_0]

    10 2 root SW 0 0% 0% [kworker/u2:1]

    2 0 root SW 0 0% 0% [kthreadd]

    15 2 root SW 0 0% 0% [kworker/0:1]



    Gruß

    Jens

  • "ich habe auch eine SelfSat IP und komme seit Tagen nicht mehr auf den uPNP-Server der Schüssel

    Manuell als "RTSP Network Device" kommt man an die Streams"



    Wenn du streams hast, dann läuft dieser Prozess doch, welcher gleichermaßen für UPnP, RTSP/HTTP und RTP Services anbietet.

    Wäre der Prozess tot, hättest du auch keine streams. Klingt eher nach Netzwerkproblem zwischen Antenne und Clients.

  • wirbel ,

    da ist beim Test zwischen Antenne und Client nicht viel zwischen gewesen....


    MiniPC --- Gigabit Switch ---- PoE Injektor --------- Antenne


    MiniPC mit DHCP Server, andere Clients sonst mit am Switch, waren aber abgeschaltet.

    Gestern war selbst am MiniPC der Server der Antenne nicht verfügbar.

    Ich hätte noch den Switch raus nehmen können, das lief aber sonst auch und einen Kaltstart hatte ich mit dem auch durchgeführt.


    Ich schau nachher nochmal auf die laufenden Prozesse, ob da was zu gekommen ist.


    Gruß

    Jens

  • Hallo,

    hier die jetzt laufenden Prozesse mit einem Client:

    (evtl. interessiert`s ja noch jemanden :-)


    Mem: 26048K used, 99888K free, 0K shrd, 0K buff, 15224K cached

    CPU: 8% usr 88% sys 0% nic 0% idle 0% io 0% irq 4% sirq

    Load average: 1.05 0.82 0.50 2/60 20907

    PID PPID USER STAT VSZ %VSZ %CPU COMMAND

    593 556 root S 2832 2% 76% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    20672 20613 root R 1520 1% 16% top

    20536 514 root S 1592 1% 8% dropbear

    589 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    27510 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    557 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    554 1 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    598 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    590 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    591 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    556 554 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    4568 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    18799 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    600 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    20196 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    19558 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    601 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    603 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    20886 556 root S 2832 2% 0% /opt/bin/sat2ip_server/sat2ip_tb100.elf

    481 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    478 1 root S 2272 2% 0% /opt/bin/mongoose 8000

    480 478 root S 2272 2% 0% /opt/bin/mongoose 8000

    488 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    482 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    492 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    489 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    491 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    487 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    483 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    490 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    485 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    484 480 root S 2272 2% 0% /opt/bin/mongoose 8000

    508 1 root S 1528 1% 0% udhcpc -b -i eth0 -s /etc/udhcpc.conf -p /var/run/udhcpc.eth0.pid -t 3 -T 6

    514 1 root S 1528 1% 0% dropbear

    20613 20536 root S 1520 1% 0% -sh

    472 1 root S 1520 1% 0% acpid

    1 0 root S 1512 1% 0% init

    260 1 root S 1512 1% 0% syslogd -m 0 -s 1024 -b 3 -L -S

    612 611 root S 1512 1% 0% logger

    611 609 root S 1512 1% 0% sh -c logger

    610 1 root S 1512 1% 0% init

    262 1 root S 1504 1% 0% klogd

    609 1 root S 1152 1% 0% /opt/bin/system-monitor

    3 2 root SW 0 0% 0% [ksoftirqd/0]

    4 2 root RW 0 0% 0% [kworker/0:0]

    271 2 root SW 0 0% 0% [ubi_bgt0d]

    17 2 root SW 0 0% 0% [kswapd0]

    10 2 root SW 0 0% 0% [kworker/u2:1]

    279 2 root SW 0 0% 0% [ubifs_bgt0_0]

    27509 2 root SW 0 0% 0% [kdvb-ad-7-fe-0]

    2 0 root SW 0 0% 0% [kthreadd]

    15 2 root SW 0 0% 0% [kworker/0:1]

    8 2 root SW 0 0% 0% [kdevtmpfs]

    18 2 root SW 0 0% 0% [fsnotify_mark]

    31 2 root SW< 0 0% 0% [deferwq]

    16 2 root SW 0 0% 0% [khungtaskd]

    9 2 root SW< 0 0% 0% [writeback]

    5 2 root SW< 0 0% 0% [kworker/0:0H]

    6 2 root SW 0 0% 0% [kworker/u2:0]

    7 2 root SW< 0 0% 0% [khelper]


    Gruß

    Jens

  • Hallo Jens,

    ich habe jetzt nicht den ganzen Thread gelesen, aber es scheint so, dass selfsat mit vdr bei Dir noch nicht (rund) läuft. Ich schlage mich auch seit einem Jahr mit verschiedenen Problemen der Technik herum; bin aber nach wie vor froh, dass ich diesen Umstieg auf satip gemacht habe.

    Ich habe bei mir den Eindruck, dass ich es mittlerweile stabil als Gesamtkunstwerk laufen habe. Wenn es läuft, ist es eigentlich unspektakulär, aber es gibt offensichtlich viele kleine Störmöglichkeiten und es ist oft sehr schwer, die eigentlichen Ursachen zu finden. Das liegt natürlich auch an der so erschöpfenden Dokumentation des linux Systems der selfsat.

    Ich meine, man schaue sich mal an wieviel Gesprächsbedarf zu einem System wie vdr besteht, dass es aber keinerlei Forum für diese selfsat/satip Technik gibt und vor allem auch keinerlei Unterstützung durch die grossartigen Entwickler des Hauses; welchen Luxus geniessen wir, dass wir mit den vielen (überwiegend) netten Menschen, die an den verschiedenen vdr flavours arbeiten, so engen Kontakt haben und diese auch den Kontakt zu uns oft sogar suchen. Und dass wir das alle nur aus Spass an der Freude machen !

    Ich habe dazu auch auf amazon den schlechten support der Firma, für ein gutes Produkt, beschrieben ... vielleicht hilft es, wenn das mehrere schreiben würden ...

    So, jetzt habe ich hier mal Luft rausgelassen ... eigentlich wollte ich Jens meine Unterstützung anbieten ...

    Ich fände es sehr hilfreich, wenn Du den Inhalt der satip.conf hier mal posten würdest. Ich weiss nicht, ob in allen yavdr versionen, aber mit der ich letztens arbeitete, war die unter /etc/vdr/conf.avail/ ...

    Du kannst mir auch sehr gerne eine PN schicken ...

    Übrigens habe ich zwei selfsat IP22, die auf zwei verschiedene Sats (Astra 19.2 & Astra 28.2) gerichtet sind. Ich habe einen vdr / vnsiserver mit mehreren Kodi-Clients und zusätzlich die legacy Anschlüsse in das Koax-netz eingespeist ... Das ganze läuft mittlerweile mit exzellentem WAF-Faktor ...

    Auch bei mir gab es Zeiten, in denen ich auf DVBViewer (Media Server) zurückgegriffen habe & und froh war zu sehen, dass es läuft ... (laufen kann)