Raspberry PI 3 - VDR - WLAN

  • Hallo,


    bei mir laufen seit Monaten 2 Raspberry PI 2 als VDR-Clients mit rpihddevice über das streamdev Plugin. Angeschlossen an den VDR Server sind sie per LAN Kabel.


    Jetzt habe ich den Raspberry PI 3 als VDR-Client (rpihddevice) über das eingebaute WLAN Modul getestet,der Raspberry PI war dabei ca 6m von der FritzBox (7490) entfernt und es war eine Wand (ca. 20cm. keine Betonwand) dazwischen.


    Getestet mit HD Sender (ARD/ZDF)


    Versuch Nr. 1:
    Raspberry PI 3 im Originalzustand: es war kein stabiler Betrieb möglich.


    Versuch Nr. 2:
    Ich habe die interne WLAN Antenne das Raspberry PI 3 abgetrennt und durch eine externe Antenne ersetzt. Der Empfang war dieses Mal etwas besser aber es war immer noch kein stabiler Betrieb möglich.
    ( nach ca 10 - 20 Minuten bleibt das Bild stehen )


    Versuch Nr. 3:
    Das interne WLAN Modul habe ich stillgelegt ( blacklist brcmfmac ) und durch einen USB - WLan Stick ersetzt TL-WN823N ( rtl8192cu ). Stabiler Betrieb ist jetzt möglich.


    Fazit:
    Die Datenübertragung des internen WLAN Moduls des Raspberry PI 3 ist für einen VDR-Client nicht geeignet.




    Gruß Sig

    EasyStream 0.6 Der VDR Streamingclient für Windows,Linux und MacOSX

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von SigVDR ()

  • Danke Sigi.
    Habe seit kurzem auch einen Raspi3. Wollte das auch schon die ganze Zeit mal getestet haben. Bei mir sind es etwa 5m mit ner 24cm Stahlbeton Wand. Ich denke da wäre ich dann dran verzweifelt ;)

    Gruß Patrick


    [size=8]* Meine NeverEndingProjects ;-)*


     vectra --- glasslike ---

  • Habe mich auch schon eine Zeit lang mit dem internen Wlan Modul gespielt und bin auf das selbe Ergebnis gekommen. Verwende jetzt wieder einen Edimax USB Stick. Das Bluetooth Modul funktioniert auch nicht wirklich.

    VDR1 | MLD 5.4 64Bit Testing | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Grafik GT 630 | OctopusNet S2-2

  • Habe RPI mit Plastikgehäuse auf dem TV liegen der Router ist ca 5 Meter und eine Betonwand weiter unten. Klappt zu 99% tadellos. StreamdevClient

    #S1: Gigabyte GA-H77M-D3H, Intel 1610 Celeron, 4GB RAM, Cine S2 6.5 + Duoflex S4, NVIDIA GT 630, IBM SSD 240GB, Atric IR Einschalter, DVD-Brenner mit easyvdr 3 oder MLD5
    #S2 (offline) POV MB-D510-MATX, 2GB, GT 220, TT 1600
    #C1: RPi3 MLD5.1

  • masterpete
    was zeigt bei dir die Empfangsqualität an?

    Code
    1. sudo iwlist wlan0 scan | grep Quality


    "iwlist" zeigte bei mir im Originalzustand Werte so um die -55dBm an.

    Code
    1. Quality=50/70 Signal level=-55 dBm


    Werte zw. -50 und -60dBm sollten eigentlich für einen guten Empfang stehen, wenn denn die angezeigten Werte halbwegs der Realität entsprechen.


    Was ich oben vergessen habe zu erwähnen, ist, dass ich das bei einem HD-Kanal (ARD/ZDF) getestet hatte, SD Sender dürften wegen der geringeren Bandbreite eher funktionieren.


    Zitat

    Klappt zu 99% tadellos.


    Was bedeutet das? Alle 100 Sekunden ist 1 Sekunde gestört? ;D


    Gruß Sig

  • Selbes Ergebnis hier! Zwei Raspi 2 im Einsatz mit WLAN-Stick: funzen problemlos. Der Raspi3 mit integriertem WLAN -> kannst vergessen!!!


    Markus

    Streamingclient 1:
    [-] RaspiVDR MLD 5.x an Panasonic TV mit CEC :D 


    Streamingclient 2:
    [-] RaspiVDR MLD 4.x - IR an GPO PIN18 - FB URC7960


    Streamingserver:
    [---] VMware ESXi-Server v5.1: Hardware Fujitsu-Siemens TX150S7
    [- ] MLD 5.x Server - OctopusNet 4 Tuner

  • Quality=59/70 Signal level=-51 dBm habe ich


    Manchmal bei ARD und ZDF kommt der Streamdev aus dem Tritt und ich muss den VDR neu starten.


    Ich wollte auch erst nen Kabelhinlegen (wäre ohne Probleme machbar) aber ich habe WLAN einen Versuch gegeben und bin bisher nicht enttäuscht.


    die 99% belaufen sich auf Sendungen und nicht auf Sekunden :P

    #S1: Gigabyte GA-H77M-D3H, Intel 1610 Celeron, 4GB RAM, Cine S2 6.5 + Duoflex S4, NVIDIA GT 630, IBM SSD 240GB, Atric IR Einschalter, DVD-Brenner mit easyvdr 3 oder MLD5
    #S2 (offline) POV MB-D510-MATX, 2GB, GT 220, TT 1600
    #C1: RPi3 MLD5.1

  • Selbes Ergebnis hier! Zwei Raspi 2 im Einsatz mit WLAN-Stick: funzen problemlos. Der Raspi3 mit integriertem WLAN -> kannst vergessen!!!


    Sorry für OT:
    Was für eine WLAN-Stick hast mit RPi2 in Verwendung? Sind Triber im kernel? braucht man etwas extra?


    Danke im Voraus.

  • Sind netgear Sticks und funzen ootb ohne extra was zu installieren.

    Streamingclient 1:
    [-] RaspiVDR MLD 5.x an Panasonic TV mit CEC :D 


    Streamingclient 2:
    [-] RaspiVDR MLD 4.x - IR an GPO PIN18 - FB URC7960


    Streamingserver:
    [---] VMware ESXi-Server v5.1: Hardware Fujitsu-Siemens TX150S7
    [- ] MLD 5.x Server - OctopusNet 4 Tuner

  • wer Funk kennt - nimmt Kabel. :]


    wennes

    ScaleoE mit L4M Twin S2 6.5
    Gen2VDR 5.3 Update 7 und Gen2VDR 6.0
    diverse VDR´s in "Betreuung"
    Virtualbox-Testumgebung mit Sat-over-IP, DigibitR1
    Let’s science the expletive-expletive out of this.

  • Sorry für OT:
    Was für eine WLAN-Stick hast mit RPi2 in Verwendung? Sind Triber im kernel? braucht man etwas extra?


    für dir RasPis weden immer wieder die Edimax- Sticks angepriesen. Kann ich nur bestätigen. Günstig und bisher sehr zuverlässig bei mir.
    Unter Openelec und OSMC müssen keine Treiber installiert werden.



    Gruß Jan

    1:Asrock Z97M-ITX/ac; Intel i3-4130T; Zotac GT-730; 8GB DDR3; SSD; X10; 2 x Sundtek SkyTV Ultimate 5 2015; Cine S2 v6.1; 3x WD Red 3TB; yaVDR 0.6
    2:ASRock H67M-ITX; i3-2100; 120GB SSD; Ram 4GB DDR3; GeForce GT 440; X10; yaVDR 0.6

  • ich habe auch den rpi3 und mit wlan noch kein problem gehabt, obwohl hier wlan schon sehr problematisch ist mit dem handy, tablett und amazon fire, der rpi3 schlägt sich gut.

    | HP Microserver Gen 7 | Cine S2 + DVBSky S952 | vdr2.2 | Streamdev Server |
    | Streamdev Clients: paar Rpi2, yavdr.... |