[solved] NFS mount @boot klappt nicht

  • Hallo,


    ich frage mal hier, weil es das VDR Paket von e-TOBI auf Debian Jessie betrifft.


    Ich habe auf meinem RasPi3 Rasbian Jessie installiert und die VDR-Pakete von e-TOBI's repository dazu. Das läuft im Prinzip prima als Streaming-Client. Jedoch ist der WAF aktuell gering, weil Debian es einfach nicht schafft das VDR Aufnahmenverzeichnis zur Bootzeit per NFS zu mounten. Der Eintrag in der /etc/fstab ist richtig und funktioniert auf der Kommandozeile einwandfrei. Der VDR wird ganz normal gestartet, aber das Aufnahmenverzeichnis ist nicht gemountet.


    Ich habe mir schon einen Wolf gesucht im Rasberrypi-Forum als auch bei Debian, aber außer noch mehr Betroffenen keine funktionierende Lösung gefunden - siehe z.B. hier. Der dort präsentiere Vorschlag bzgl. mount Optionen in der fstab sorgt nur dafür, dass der VDR nicht mehr auto-startet.


    Hat jemand eine Idee bzw. Lösung z.B. bzgl. systemd? Oder wie arbeitet man per rc.local drum rum?


    Danke & Gruß, ollo

  • Wie sieht denn deine fstab aus?

    #S1: Gigabyte GA-H77M-D3H, Intel 1610 Celeron, 4GB RAM, Cine S2 6.5 + Duoflex S4, NVIDIA GT 630, IBM SSD 240GB, Atric IR Einschalter, DVD-Brenner mit easyvdr 3 oder MLD5
    #S2 (offline) POV MB-D510-MATX, 2GB, GT 220, TT 1600
    #C1: RPi3 MLD5.1

  • Hi,


    evtl. ist das Netzwerk noch nicht oben wenn er versucht das Share zu mounten. Guck mal hier.



    bye
    Sven


    Link: Richtig fragen

  • Hast Du mal die Option "Wait for Network at boot" in der raspi-config versucht?


    Bei mir mounted er über die fstab automatisch, aber ich muss nach dem VDR start noch mal im OSD das Aufnahme Verzeichnis manuell aktualisieren. Ach ja, und es funktioniert bei mir auch nur als USER="root", denn sonst kann ich keine Aufnahme löschen und er schreibt auch keinen marker wo ich gestoppt habe.


    Meine fstab:
    IPAdresseServer:/4TB_HDD/video /var/lib/video nfs auto,nolock 0 0