DVBSKY S850 unter Linux zum laufen bringen

  • Ob es die richtige Firmware ist weiß ich leider auch nicht, habe aber etliche im Ordner u.a. auch die von dir genannte.
    Muss ich diese evtl extra laden?
    Werde mal die andere löschen und schauen welche er dann wählt.

  • Ich weiß ehrlich gesagt im Moment auch nicht, was du noch probieren könntest. Vielleicht mal Computer ganz aus und nochmal an, vielleicht hat sich ja die Hardware komplett aufgehangen. Vielleicht auch die andere Firmwaredatei auch nochmal neu nach /lib/firmware reinkopieren (falls du das nicht sowieso gemacht hast, als du die demod-Firmware neu kopiert hast)... ist aber alles stochern im Nebel.

  • Ich habe jetzt mal DVBSky Mainline Support gegengelesen, wo EDIT: auf Seite 3 recht viel über die S850 steht. Wenn ich richtig durchblick, geht es anscheinend mit dem "card=49"-Trick nur mit dem media-build-bst von der DVBSky.net-Seite, aber nicht mit dem http://git.linuxtv.org//media_build.git/about/. Warum das so ist, hat man anscheinend noch nicht verstanden. Wenn ich das geschriebene richtig deute, könnte es durchaus mit der Firmware irgendwie zu tun haben.


    Entweder kriegen wir das hier noch raus oder du probierst es mal mit dem media-built-bst (plus Patch) wie olebowle ganz am Anfang dieses Threads erwähnt hat.


    Was noch interessant wäre, bevor du weiter probierst, wäre eine komplette Ausgabe von "dmesg" (also ohne irgendwelche greps oder so). Vielleicht haben ich oder olebowle dann noch ne Idee was im Moment schief geht. Denn eigentlich wäre es ja cool, wenn man das mit dem http://git.linuxtv.org//media_build.git/about/ irgendwie zum Laufen bekäme und evtl. nen Patch für das Projekt erstellen könnte.

  • Dmesg liefert mir (habe es etwas gekürzt)



    Linux video capture interface: v2.00
    [ 15.468152] cx23885 driver version 0.0.4 loaded
    [ 15.468334] cx23885 0000:03:00.0: enabling device (0000 -> 0002)
    [ 15.468378] CORE cx23885[0]: subsystem: 14f1:8512, board: DVBSky S950 [card=49,insmod option]
    [ 15.627028] intel_rapl: Found RAPL domain package
    [ 15.627037] intel_rapl: Found RAPL domain core
    [ 15.892280] cx25840 10-0044: cx23885 A/V decoder found @ 0x88 (cx23885[0])
    [ 16.860116] cx25840 10-0044: loaded v4l-cx23885-avcore-01.fw firmware (16382 bytes)
    [ 16.876056] cx23885_dvb_register() allocating 1 frontend(s)
    [ 16.876062] cx23885[0]: cx23885 based dvb card
    [ 16.879806] i2c i2c-9: Added multiplexed i2c bus 11
    [ 16.895072] Adding 4115452k swap on /dev/sda3. Priority:-1 extents:1 across:4115452k FS
    [ 16.995706] ts2020 11-0060: Montage Technology TS2020 successfully identified
    [ 16.995733] DVB: registering new adapter (cx23885[0])
    [ 16.995741] cx23885 0000:03:00.0: DVB: registering adapter 0 frontend 0 (Montage Technology M88DS3103)...
    [ 17.024655] DVBSky S950 port 1 MAC address: ff:ff:ff:ff:ff:ff
    [ 17.024663] cx23885_dev_checkrevision() Hardware revision = 0xb0
    [ 17.024670] cx23885[0]/0: found at 0000:03:00.0, rev: 2, irq: 18, latency: 0, mmio: 0x91000000



    Muss ich bei der erneuten Installation etwas beachten, das alte löschen oder sowas?


    Gruß und vielen Dank für die viele Hilfe:)
    EDIT: auf der Herstellerseite steht leider nichts über Kernel 4.4.X, trotzdem probieren?

  • Also mein Verdacht ist, dass "v4l-cx23885-avcore-01.fw" die falsche Firmware sein könnte und irgendwo stattdessen(?) halt dvb-fe-ds300x.fw hochgeladen werden müsste (oder vielleicht braucht es auch beide, jedenfalls scheint die zweite nicht hochgeladen zu werden). 100% sicher bin ich mir aber halt nicht.


    Joohn schreibt im Post DVBSky Mainline Support folgendes:


    Code
    1. Auf einer frischen Testinstallation (Ubuntu 15.10) funktioniert die Karte mit media-build-20151028 und der Option 49 oder 50 einwandfrei - von einem früheren build ist da definitiv nichts abhängig.


    Daher könntest du es mit besagtem media-build-20151028 (gemeint ist wohl media_build-bst-151028 ) von http://dvbsky.net/Support_linux.html mal versuchen. Laut olebowle (siehe Posting 4 hier im Thread) brauchst du noch einen Patch, damit der media_build-bst-151028 auf Kernel 4.4 kompiliert. Den findest du hier: https://aur.archlinux.org/cgit…ree/?h=media-build-dvbsky


    Natürlich wäre es schöner den offiziellen media_build (den du zurzeit hast) per Patch zum Laufen zu kriegen. Aber, ehrlich gesagt, wüsste ich jetzt nicht wie der Patch aussehen sollte, daher dürfte der von Joohn erprobte Weg der schnellere sein.


    PS: Soweit ich weiß werden diese media_build-bst-Kernels einfach über den vorhandenen Kernel drüberinstalliert.

  • Das Treiberpaket inkl. der Patches zu bauen ist eigentlich recht easy:

    Code
    1. $ wget http://www.dvbsky.net/download/linux/media_build-bst-151028.tar.gz
    2. $ tar xvf media_build-bst-151028.tar.gz
    3. $ cd media_build-bst
    4. $ ln -sr v4l/sit2_op.o.x$(uname -m | grep -o "[0-9]\{2\}$") v4l/sit2_op.o
    5. $ wget -qO- "https://aur.archlinux.org/cgit/aur.git/plain/4.3-compat.patch?h=media-build-dvbsky&id=2f5e6151c79e43edf8f06cdee87d9662a08e4fd4" | patch -p1 -i-
    6. $ wget -qO- "https://aur.archlinux.org/cgit/aur.git/plain/4.4-compat.patch?h=media-build-dvbsky&id=2f5e6151c79e43edf8f06cdee87d9662a08e4fd4" | patch -p1 -i-
    7. $ wget -qO- "https://aur.archlinux.org/cgit/aur.git/plain/add_s850.patch?h=media-build-dvbsky" | patch -p1 -i-
    8. $ make
    9. # make KDIR26="/lib/modules/$(uname -r)/updates/kernel/drivers/media" media-install


    Das installiert die neuen Module auch gleich in den updates Ordner, sodass die bestehenden Module nicht überschrieben werden. Die linux-headers und perl-proc-processtable müssen installiert sein, sonst läuft das ganze nicht sauber durch.


    Das sollte dann auch ohne card=49 funktionieren. Wann das bei dir läuft würde ich den Patch bei mir im AUR aufnehmen.

  • Erstmal vielen Dank für die tolle Hilfe!
    Ich habe die Schritte von olebowle befolgt und siehe da es funktioniert



    tune to: S f = 11686 kHz V SR = 22000 5/6 0,35 QPSK (1:1:1032) (time: 21:00.168)
    service = PARAMOUNT (PRISA TV)
    service = YOMVI (PRISA TV)
    service = ARAGON TV (Movistar+)
    service = NEOX (DIGITAL+)
    service = CANAL PANDA (PRISA TV)
    service = R. MADRID TV (Digital+)
    service = CLASSICA (CANAL+)
    service = ANTENA 3 (DIGITAL +)
    service = C+ DEPORT 2 (PRISA TV)
    service = EUROSPORT 2 (Movistar+)
    updating transponder:


    Wie sieht es bei einem Kernelupdate aus? Muss ich da neu kompilieren?


    Gruß

  • Wird die Karte jetzt auch ohne die option automatisch erkannt?


    Und ja, du musst das Paket bei jedem Kernelupdate neu bauen. Für das 4.5er Release wird übrigens auch ein kleiner Patch gebraucht, den ich dann noch einchecken werde.

  • Ich habe zwar die modprobe der Karte gelöscht jedoch sagt mir


    dmesg | grep -i dvb
    [ 15.217568] CORE cx23885[0]: subsystem: 14f1:8512, board: DVBSky S950 [card=49,autodetected]
    [ 16.717676] cx23885_dvb_register() allocating 1 frontend(s)
    [ 16.717683] cx23885[0]: cx23885 based dvb card
    [ 16.993413] m88ds3103_load_firmware: Waiting for firmware upload (dvb-fe-ds300x.fw)...
    [ 18.003530] DVB: registering new adapter (cx23885[0])
    [ 18.003543] cx23885 0000:03:00.0: DVB: registering adapter 0 frontend 0 (Montage DS3103/TS2022)...
    [ 18.031826] DVBSky S950 port 1 MAC address: ff:ff:ff:ff:ff:ff


    dass er es jetzt doch wieder automatisch als Karte 49 erkennt.


    EDIT: Hat noch wer ein Tipp wie ich die Fernbedinung zum laufen bekomme xD

  • ir-keytable -r sagt mir:
    Couldn't find any node at /sys/class/rc/rc*.




    und dmesg | grep lirc sagt:


    [ 8110.773797] lirc_dev: IR Remote Control driver registered, major 245
    [ 8534.679555] lirc_dev: module unloaded
    [ 8568.159755] lirc_dev: IR Remote Control driver registered, major 245

  • Hi,
    hier ist wohl dasselbe Phänomen:
    [0.6] & DVBSky S952 ?
    MfG,
    Stefan

    Test-VDR1: HP rp5700 Fertigsystem, Core2Duo E6400, 2GB RAM, FF-SD C-2300, nvidia Slim-GT218 x1 | easyVDR 2.0 64Bit
    VDR3: in Rente

    VDR4: MSI G31M2 v2, Digitainer2-Geh., t6963c 6" gLCD, E5200, 2GB, 3TB WD Red, GT730, 2x TT S2-3200; easyVDR 3.5 64bit
    VDR5: Gigabyte
    GA-G31M-S2L, Intel E2140, Zotac GT730 passiv, Digitainer2-Geh., t6963c 6 " gLCD, 2 TB WD Red, 2x TT S2-3200 (an 1 Kabel) easyVDR 3.5 64bit
    VDR6:
    Intel E5200, GT630 passiv, F1 750 GB, t6963c gLCD, 2x TT S2-3200 | easyVDR 3.5 64bit
    VDR-User #1068
    www.easy-vdr.de

  • fliger : Freut mich, dass es mit dem media_build-bst (und den entsprechenden Patches) bei dir funktioniert.


    Mich würde aber immer noch interessieren, was der media_build-bst da jetzt anders macht, als der offizielle media_build. Falls das jemand versteht, gerne hier posten. Aber immerhin gibt es jetzt einen genau bekannten Weg, die S850 zum Laufen zu kriegen.


    Zu der Fernbedienung (bzw. dem IR-Modul) kann ich leider nichts sagen, da hab ich keine Ahnung davon.

  • Hab gerade mal bei meiner S952 geschaut. Auch da wird der IR-Empfänger mit dem gepatchten media_build-bst-151028 nicht mehr erkannt. :rolleyes: Mir ist das bist jetzt noch nicht aufgefallen, da ich den Empfänger auf dem Mainboard nutze. Das hat aber definitiv schon einmal funktioniert. Schön ist was anderes.


    Das Treiberpaket sollte mal wieder auf einen aktuellen Kernel ordentlich rebased werden. Viel Hoffnung habe ich allerdings nicht, da ein Großteil der DVBSky Karten von aktuellen Kerneln mehr oder weniger unterstützt werden.

  • Hallo zusammen !
    Ich habe "dummerweise" mein Ubuntu aktualisiert und bekomme seitdem meine S850 nicht mehr zum laufen.
    Die aktuellen Treiber von DVBSky (http://dvbsky.net/Support_linux.html) sind für meinen Kernel "media_build-bst-160430.tar.gz".
    Auf der von olebowle verlinkten Seite mit den Patches (https://aur.archlinux.org/cgit…ree/?h=media-build-dvbsky)
    gibt es auch schon entsprechende Files für diese Version.
    Nur leider habe ich keine Ahnung wie ich das unter Ubuntu anstelle....


    Ich nehme an, es reicht nicht, die Links zu überarbeiten ?!
    Was bedeuten die: id=2f5e6151c79e43edf8f06cdee87d9662a08e4fd4 ?


    Kann mir das jemand erklären?


    Gruß
    FLOK

  • Last login: Wed Sep 14 21:45:19 2016 from 172.16.0.38
    root@kodibuntu:~# uname -a
    Linux kodibuntu 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86 _64 x86_64 x86_64 GNU/Linux