Mplayer unter YaVDR 0.61 funktioniert nicht. [Gelöst]

  • Ein freundliches Hallo in die Runde.
    Ich habe mich am WE nun dazu entschlossen meinen VDR auf den neuesten Stand zu Uppen. Das hat auch sehr gut funktioniert und nach diversen Anpassungen an den entsprechenden conf's und mit Hilfe der Suchfunktion funktioniert nun auch fast alles sehr angenehm und reibungslos. :tup


    Mein Problem ist nur: DerMplayer tuts einfach nicht. Das Videoverzeichnis ist in der entspr. .conf angegeben und ich kann auch darauf zugreifen. Doch egal welches Video/Videoformat ich anwähle, nach einigen Sekunden Schwarzen Bildschirm, ohne Ton erscheint wieder das Fernsehbild. dem Syslog kann ich diesbezgl. leider auch nichts entnehmen:


    Hier habe ich auch schon geschaut: https://wiki.ubuntuusers.de/MPlayer/Problembehebung/ doch leider habe ich ja keine Fehlermeldung... ?(
    Die Codecs habe ich nach Anleitung in "usr/lib/codecs" eingefügt, aber auch da geht nichts.
    Ist hier irgend etwas bekannt? Unter Yavdr 0.5 lief alles einwandfrei, aber hier will der Player gar nichts zeigen.
    Gibt es da von Eurer Seite evtl. einen Tipp wo ich da ansetzen könnte?


    Gruß Patrick

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

    Dieser Beitrag wurde bereits 5 Mal editiert, zuletzt von VDR-Dau ()

  • Ok, ich habe nun einmal versucht die Wiedergabe über die Konsole zu starten,

    Zitat

    sudo mplayer -vo xv /media/video/Vids/Endkontrolle.wmv


    da bekomme ich dann folgende Fehlermeldung:


    Liegt ja wohl somit an der Audioausgabe. Was mich aber wundert ist

    Zitat

    "Failed to initialize audio driver 'pulse'"

    ich habe aber den Ton wieder umgestellt (HDA NVidia), da ich sonst auf Kodi keinen Ton bekomme.
    Was läuft da falsch? ?(

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

  • So, ich bin nun etwas weiter gekommen.
    Dank hier: [0.6/Frodo skindesigner-yavdr ppa]Skindesigner-0.8.6 + mplayer-plugin] konnte ich nun den Mplayer zur Videovidergabe überzeugen. Der Aufruf über den oben genanten Befehl ergibt keine Ausgabe auf TV. In etwas abgewandelter Form sehe ich aber auf der Konsole dass sich aber zumindest etwas tut.


    Nun sehe ich aber bei Aufruf über die FB zwar ein Video aber ich habe keinen Ton, der ist Disabled. Leider finde ich keine log-Datei die mir einen genaueren Hinweis darauf gibt wo genau der Hund begraben ist.

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

  • Hallo, danke für den Tipp. Habe das Plugin mal installiert und ausprobiert. Hatte vorher davon noch gar nichts gelesen.
    Bis auf einige bekannte Kleinigkeiten läuft es soweit. Die Abstürze beim Stoppen und teilw. auch beim Spulen hatte ich beim MPlayer halt nicht. Ich werde das Plugin aber ersteinmal behalten und das Projekt weiter im Auge behalten. :]


    Schade dass sich zum Mplayer selbst hier keiner meldet, zumal ich den M-Player ja im VDR-Admin direkt als Paket installieren kann. Andere Plugins die mir problemlos laufen muss ich dagegen extra händisch installieren oder sogar PPA's nachtragen. ?(

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

  • vielleicht hast Du ja Lust, Dir mal mein HowTo für das mplayer-Plugin in Verbindung mit mpv anzuschauen. Es erfordert etwas mehr händishces einrichten, aber dafür kannst Du sogar den TV automatisch auf die richtige Bildwiederholfrequenz schalten lassen.


    Ob die Anleitung für yavdr 0.6.1 so übertragbar ist, weiss ich allerdings nicht. Es kann auch sein, dass in Ubuntu 14.04 schon eine mpv-version ohne direkten lirc-Support eingeflossen ist. Falls Deine Fernbedienung über lirc läuft, sollte diese dann für mpv mittels irxevent zum Laufen zu kriegen sein:
    https://github.com/mpv-player/mpv/wiki/IR-remotes

    VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
    VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

  • Schade dass sich zum Mplayer selbst hier keiner meldet, zumal ich den M-Player ja im VDR-Admin direkt als Paket installieren kann.

    Was soll ich groß dazu sagen? Ich kann das Plugin natürlich auch gerne von der whitelist nehmen, damit es im WFE nicht mehr auftaucht, wenn du dich dann besser fühlst.


    Ich nutze das Plugin nicht und war an den Umbauten für die Soundkonfiguration für yaVDR 0.6 nicht groß beteiligt. Das Template in https://github.com/yavdr/yavdr…r/mplayer/40_softhddevice sieht so aus, als ob es nicht mit angepasst wurde (die für xine/xineliboutput nicht, aber die sind mir für die Uhrzeit gerade zu umfangreich).


    Probier es stattdessen mal so:

    und expandiere das Template danach neu mit

    Code
    1. sudo process-template --mode 755 /usr/share/vdr-plugin-mplayer/mplayer


    Der mplayer schreibt übrigens nach /var/log/upstart/vdr.log, wenn er aus dem Plugin heraus aufgerufen wird - das macht das Debuggen fehlerhafter Konfig-Parameter leichter.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • zumal ich den M-Player ja im VDR-Admin direkt als Paket installieren kann.


    Seit wann ist denn der VDR-Admin Bestandteil von yaVDR?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • und wie definire ich jetzt das zu verwendende audiodevive ?


    ich hatte im yavdr 0.5 immer das von seahawk angesprochene plugin mit eignes übersetztem mpv.
    dort wurden die audio und codec settinngs einfach über die mplayer config germacht .
    Hatte seinerzeit viel für TrueHD Support eingepflegt.


    Wo / wie wird die conbfig untzer yavdr 0.6 gemacht ?
    Im Home Verszeichnis des vdr users ?


    im log sehe ich


    Server Wohnzimmer:yaVDR 0.6.1-stable HW: XIGMATECH Cube, GeForce GT 240, Philips 65PUS8601"LED Digital Devices Cine S2V6 + DuoFlex S2 +DUOFLEXC/T2, Inverto 4/2 Unicable Full HD Kernel 3.13, KODI , ACK-540 BT Tastatur actric USB Einschalter, Onkyo TX-NR636-7.2 Magnat Needle
    Logitech Harmony ULTIMATE Remote,
    Client Schlafzimmer: Zotac ZBOX HD41, yavdr 0.6.1-stable, streamdev client, SONY KDL-55W805A
    NAS Server: QNAP TS-410 mit NFS und AVAHI fuer Serienaufnahmen, 1*EMC/iOMEGA ix2, 1*EMC/Iomega IX4-300d
    Harmony Touch remote mit FLIRC
    EMC Cloudarray als NFS Gateway zu Azure!
    Sky Komplett Paket
    :vdr1

  • und wie definire ich jetzt das zu verwendende audiodevive ?


    ich hatte im yavdr 0.5 immer das von seahawk angesprochene plugin mit eignes übersetztem mpv.
    dort wurden die audio und codec settinngs einfach über die mplayer config germacht .
    Hatte seinerzeit viel für TrueHD Support eingepflegt.


    Wo / wie wird die conbfig untzer yavdr 0.6 gemacht ?
    Im Home Verszeichnis des vdr users ?


    habs gefunden ..
    /etc/vdr/conf.d/50-mpv.conf
    werde masl testen ...

    Server Wohnzimmer:yaVDR 0.6.1-stable HW: XIGMATECH Cube, GeForce GT 240, Philips 65PUS8601"LED Digital Devices Cine S2V6 + DuoFlex S2 +DUOFLEXC/T2, Inverto 4/2 Unicable Full HD Kernel 3.13, KODI , ACK-540 BT Tastatur actric USB Einschalter, Onkyo TX-NR636-7.2 Magnat Needle
    Logitech Harmony ULTIMATE Remote,
    Client Schlafzimmer: Zotac ZBOX HD41, yavdr 0.6.1-stable, streamdev client, SONY KDL-55W805A
    NAS Server: QNAP TS-410 mit NFS und AVAHI fuer Serienaufnahmen, 1*EMC/iOMEGA ix2, 1*EMC/Iomega IX4-300d
    Harmony Touch remote mit FLIRC
    EMC Cloudarray als NFS Gateway zu Azure!
    Sky Komplett Paket
    :vdr1

  • Gerald[/quote]


    Seit wann ist denn der VDR-Admin Bestandteil von yaVDR?


    Gerald


    Sorry, klar mein Fehler, ich meinte das Webfrontend. :wacko:


    Danke auch an Dr. Seltsam, Seahawk1986 und bottkars für eure Anregungen. Ich werde mir das alles mal in ner freien Minute anschauen.


    @ Seahawk1986: Da ihr eh schon nicht alle für Ubuntu und VDR erhältlichen Plugins gelistet habt, ging ich davon aus dass die die im Webfrontent enthalten sind auch von Euch auf ihre Tauglichkeit geprüft sind.


    Danke und Gruß


    Patrick

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk

  • Probier es stattdessen mal so:


    Danke, passt perfekt. :tup



    Werde mpv aber trotzdem mal testen...


    Gruß Patrick

    DVB-S TT 1.6
    VDR: mittlerweile MVDR 1.2
    Board: Asrock K7VM2 Rev.3. Bios 1.9
    CPU: Athlon Mobile XP, 1150MHz bei FSB 100MHz, Vcore 1,2V
    512 MB Ram
    Gehäuse: Francis Francis X1
    HDD Samsung 120GB 5400UPM
    FB X10 Funk